Solved

Excel 2013 Performance

Posted on 2015-01-22
3
119 Views
Last Modified: 2016-02-11
Greetings Experts,

I'm having an issue with Excel 2013 taking a long time (3-5 seconds) to make a single cell calculation.  The spreadsheet was originally created in 2010 and has single worksheet with approximately 750 rows and 20 columns.  There are 3 calculations per row, and when you change a field that affects one of those calculations, you get the spinning circle / calculating mouse pointer for 3-5 seconds.  If you open the same workbook in 2010...no issues.

Thoughts?
0
Comment
Question by:DMJorgensen
3 Comments
 

Expert Comment

by:Jose Arriaga
ID: 40564455
Hi DMJorgensen

Did you try disabling Animation feature In Office 2013?

To disable Animation please run regedit.exe
then locate this key and change dword to 1.

[HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Common\Graphics]
"DisableAnimations"=dword:00000001

To see the effect, you’ll need to reboot your computer.

To reverse the effect, change the value of the added DWORD to its default of 0.
0
 
LVL 92

Expert Comment

by:Patrick Matthews
ID: 40564562
Without seeing the actual workbook it's hard to say.  But:
1) Due to formatting you may have many additional rows/columns in the used range.  Check that
2) Do you have any cells that have volatile functions?  These recalculate whenever the worksheet does, even if dependent/antecedent relations do not dictate that they normally would
3) Are you using any array formulas?
4) Are you using any User Defined Functions with VBA?
5) Are you using references to external files/data sources?
6) Are you using functions like SUMPRODUCT, COUNTIF, SUMIF, etc, which display array behaviors?
7) Are you using VLOOKUP or INDEX, which can get expensive if you are looking in large lookup tables?
0
 
LVL 5

Accepted Solution

by:
DMJorgensen earned 0 total points
ID: 40588783
Hi Guys,

Sorry for the delay, been out of the office.  
@Jose, I saw those articles about changing modifying the registry on the internet prior to posting here...it had no affect.  @Patrick, there was one row that was performing lookups from another spreadsheet (both files were on the workstation and not the network) but the delay was happening when changing a calculation in one cell and one row at a time.  We ended up re-creating the spreadsheet in Excel 2013 and the issue was gone.  There is something in the 2010 version that 2013 just didn't like.  
Thanks for the help anyway.
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I recently resolved a client's Office 2013 installation problem and wanted to offer an observation that may help you with troubleshooting similar issues. The client ordered three Dell Optiplex system units with the Windows 7 downgrade option inst…
With the internet and the ease of information transference, many professional jobs can be done anywhere today.  Why should it make a difference whether an x-ray is read in India or the United States as long as the radiologist is qualified?   Outso…
The viewer will learn how to create a normally distributed random variable in Excel, use a normal distribution to simulate the return on an investment over a period of years, Create a Monte Carlo simulation using a normal random variable, and calcul…
An overview on how to enroll an hourly employee into the employee database and how to give them access into the clock in terminal.

829 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question