Solved

Server 2012 Backups and VSS

Posted on 2015-01-22
13
109 Views
Last Modified: 2015-08-06
Hi all we are using a Third Party Backup solution for our Hyper V Server which is failing, and I have noticed in device manager about 200 Generic Volume Shadow Copy.

These appeared when I successfully created a backup, but now the backup fails and have read that I need to clear these out.

My question is rather than individually deleting each one is there a way I can do this in 1 go.

and why do they keep appearing?

John
0
Comment
Question by:pepps11976
  • 6
  • 6
13 Comments
 
LVL 32

Expert Comment

by:Rodney Barnhardt
ID: 40566247
The first step I would do is to check the status of the VSS writers. Run the command "vssadmin list writers" and look for any errors. If there are problems, then those need to be investigated first as they are causing the problem.
0
 

Author Comment

by:pepps11976
ID: 40566285
Yes i have done this and get various Failed States however restarting various Services gets these back to normal, and then afer i try to run the backup again they then fail
0
 
LVL 32

Expert Comment

by:Rodney Barnhardt
ID: 40566291
There should be an event ID to match the failure of the VSS writer. What is the error? Also, what product are you using to perform the backup?
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 

Author Comment

by:pepps11976
ID: 40566320
The product is Active Image Protector The Event ID Is not helpful but

A Vss Writer has rejected an event with error 0x00000000 the operation completed successfully

Vss Event Log
0
 
LVL 32

Expert Comment

by:Rodney Barnhardt
ID: 40566371
Have you tried to contact their support. The error appears to relate to the writer "AIP", which is I am assuming means "Active Image Protector Writer". Since it originally worked, there could have been a Microsoft update that is causing a conflict or something along those lines. I have seen updates cause problems with third party apps in the past.

I did track down a similar issue with host on a VMware system that had Microsoft workarounds.

http://support.microsoft.com/kb/2853247

There was also a KB on the Active Image site about VSS issues:

Windows Application Log:
- Source: VSS
- Type (Level) : Error

Windows System Log:
- Source: Volsnap
- Type (Level) : Error

If the error is generated due to the AIP Software:
1. Please ensure that the AIP tracking driver was installed at the same time that AIP was installed. Also, ensure that Windows was rebooted after the AIP installation.
If a full and incremental backup task is scheduled to run while the tracking driver is not working correctly or is not installed, VSS cannot be started and consequently returns a -311 error. The tracking driver is a component included in the AIP standard installation.

* Windows 2000 systems do not include VSS. A -999 error may occur instead of a -311 error. Also, the above error will occur during a scheduled full backup task.

To confirm that the tracking driver is functioning properly, please select [System Information] - [Software Environment] and confirm that "aiptrack" is on the list of system drivers.


If the error is due to the OS:
Windows Server 2003:
Please install the update program for Windows Server 2003 or earlier as follows to see if the problem is solved.
1. Apply Windows Server 2003 Service Pack 2.

A Volume Shadow Copy Service (VSS) update package is available for Windows Server 2003
http://support.microsoft.com/kb/833167/en-us

2. Apply the roll-up package.

An update rollup package is available to resolve some Volume Shadow Copy Service (VSS) snapshot issues in Windows Server 2003.
http://support.microsoft.com/kb/940349/en-us
0
 

Author Comment

by:pepps11976
ID: 40566390
Ok this is a Hyper V server 2012, all updates are the latest, the server was rebooted after installation of AIP.

Also I did get the backup to perform once yesterday, unfortunately after that it stopped working again, but everytime it put 100's of Generic Shadow Copy Devices in storage manager, they are not used and I know having theses can cause issues, but its painful going in and having to delete these every time

Generic devices
0
 

Author Comment

by:pepps11976
ID: 40566491
I can also confirm that AIP Track is presenr
0
 
LVL 32

Expert Comment

by:Rodney Barnhardt
ID: 40566526
Ok. These have to do with system restore. Microsoft released an update\hotfix for the problem in server 2008.

http://support.microsoft.com/kb/982210

You could also stop the shadow copy service otherwise. This could be a bug for 2012 that they have not addressed yet.
0
 
LVL 32

Assisted Solution

by:Rodney Barnhardt
Rodney Barnhardt earned 250 total points
ID: 40566529
I did find where there is a scripting option: http://www.storagecraft.com/support/forum/deleting-generic-volume-shadow-copies-command-or-script

"If you download devcon.exe from Microsoft, you can remove them with a simple command at the command prompt. If you want to know how many items you have that need removing, you can do:

devcon findall * | find "HARDDISKVOLUMESNAPSHOT"

That will show all the devices. Look for STORAGE\VOLUMESNAPSHOT\HARDDISKVOLUMESNAPSHOT followed by a number. It won't hurt to try to remove devices that don't exist, you'll just get a message that no devices were removed.

Then run this command, change 1527 to your highest number found, if you want.

for /L %b in (0,1,1527) do devcon remove @"STORAGE\VOLUMESNAPSHOT\HARDDISKVOLUMESNAPSHOT%b"
0
 

Author Comment

by:pepps11976
ID: 40566625
yep ok I have downloaded the Devcon and managed to clear them down, I have just uninstalled AIP and reinstalled with a reboot.

Just tried to do a full backup job and same errors etc happening
0
 
LVL 32

Expert Comment

by:Rodney Barnhardt
ID: 40567248
Unfortunately, I am not familiar with this backup product. I checked their support website, but there really is not that much information available. I was going to suggest contacting them, but then I located an article with someone having the same problem using Computer Associates ArcServe product in a 2012 Hyper-V environment. It appears to be a Microsoft issue based on his findings.

Here is the workaround:
http://www.guillaumeverrey.com/2013/07/error-the-specified-component-was-not-reported-by-the-vss-writer-error-517-in-windows-server-2012-backup/

Here is the original thread:
https://communities.ca.com/thread/106282465
0
 

Author Comment

by:pepps11976
ID: 40569201
Yes I have tried this but when I try to list the shadows I just get no shadows can be found
0
 
LVL 8

Accepted Solution

by:
piyushranusri earned 250 total points
ID: 40908160
basically you have to run vssadmin list writers( with admin priviliges ) on command prompt
and it will show you writers status with no error or timed out error.

with Timed out error writers, you have to restart the related services. and run again vssadmin command
it will show no error

like IIS related times out error-  restart IIS admin services
WMI timed out error- wmi service

Please share the services status with us, so that i can give you the proper service name to be restarted.
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to update Firmware and Bios in Dell Equalogic PS6000 Arrays and Hard Disks firmware update.
Sometimes drives fill up and we don't know why.  If you don't understand the best way to use the tools available, you may end up being stumped as to why your drive says it's not full when you have no space left!  Here's how you can find out...
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…
This tutorial will walk an individual through the steps necessary to install and configure the Windows Server Backup Utility. Directly connect an external storage device such as a USB drive, or CD\DVD burner: If the device is a USB drive, ensure i…

837 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question