Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 358
  • Last Modified:

Sharepoint 2010 metadata search not showing in Quick launch bar

For some reason the metadata and filter search section is not displaying on my quick launch bar under my document library.

I don't know what I've missed in setting this up. Here's what I've done/checked.

   
Metadata Navigation and Filtering feature is activated in my Site Features list
   
Went to Metadata Navigation setting under Document Library Settings and added my hierarchy fields and key filter fields.
   
Metadata nav that is missingUploaded document with metadata field filled out to my document library
0
imstac73
Asked:
imstac73
  • 2
  • 2
2 Solutions
 
colly92002Commented:
If I remember correctly your list/content type will need a configured metadata column before it shows you this, and so you will need a  hierachy setting up in Central Admin that the column uses.
0
 
imstac73Author Commented:
When I try to add a metadata column I get an access denied.  Do you know what permissions I need for this?  I do not have any access to Central Admin level at all.
0
 
Walter CurtisSharePoint AEDCommented:
You can enable the filter control by going to list settings -->Metadata Navigation Settings, then configure the control as you desire. You will then see the control in the quick launch on the page your document library is on.

Hope that helps
0
 
imstac73Author Commented:
SneekCo, I tried doing this and it still doesn't show on the Quick Launch.
0
 
colly92002Commented:
I still suspect this is simply a problem with your permission level and perhaps you have missed a step when setting it up.
Ensure you have followed the instructions here:
http://www.dynamics101.com/2013/04/managed-metadata-column-navigation-in-10-steps/
https://support.office.com/en-ie/article/Create-a-Managed-Metadata-column-8fad9e35-a618-4400-b3c7-46f02785d27f

If I remember correctly , if you have not defined a term set then the only one available is the folder/file hierachy.

I think you will need at least: "design" permission on the site to do this.

To create a new term set, you will require at least: "Term Store Administrator" permissions.  Follow these instructions to set up a new term set:
https://support.office.com/en-gb/article/Create-configure-and-manage-groups-and-term-sets-e0104c0b-5267-458e-9b6b-dc36eca0c261

Once you have a managed metadata colum in your list, the navigation panel should automatically appear in the quick launch area.

I would recommend you request a test/development site (possibly on its on web app) in order to explore these features, and request "Site Collection Administrator" rights on this site.  Sharepoint hides options from users that do not have the required access level, which makes it very difficult to learn how to do this stuff.  If your administrators reject this request, then ask for a dev web farm in which to do this stuff.  There really is no reason why you shouldn't be allowed your own  development area, Sharepoint is very resilient and unless you are coding it you shouldn't be able to do anything to any other site collections provided it has been set up correctly.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now