• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 671
  • Last Modified:

How to execute MSWord 2013 always in safe mode for all users, in a RDS session ?

Hello all,

On a Windows 2008 R2 server, Office 2013 has been installed (upgraded from 2010). Since then, all the users accessing this server through RDS and lauching MSWord 2013 are receiving the msgbox "We're sorry but this feature appears to be broken and needs to be repaired. [...].", and then MSWord opens normaly.
After trying a lot of different things to remove this msgbox, I found that forcing the execution in safe mode always "resolves" the problem.
I modified the registry by adding the Resiliency key as supported by Microsoft (http://support.microsoft.com/kb/924684). This way, Word opens in safe mode, but only for the Admin user. All other users still have the msgbox, and the key doesn't seem to be replicated in their registry.

How to fix that so that all users, existing and new, will be able to open Word in safe mode ?
0
OGisler
Asked:
OGisler
  • 2
  • 2
1 Solution
 
SagiEDocCommented:
You could create a batch file that modify's the registry key and load it as a login script. This will ensure the registry is updated for the specific user and will result in the application then being launch in safe mode.
0
 
OGislerAuthor Commented:
Thank you SagiEDoc, but I wanted to avoid that kind of resolution. I find it quite strange that modified valued like this one is not copied in the registry of the user. Don't you think there is another way to resolve it ?
0
 
SagiEDocCommented:
That registry hive is generated per user, so when you change it you are only changing it for the current (logged in) user. You could push the setting to the registry with a GPO.
0
 
VB ITSSpecialist ConsultantCommented:
Create a shortcut to the Word executable with the /safe switch at the end of it and replace the default shortcut to Word in the All Users Start Menu and Desktop.

- Browse to the location of the Word executable (i.e. C:\Program Files\Microsoft Office 15\root\office15\)
- Right click on winword.exeSend ToDesktop
- Right click on the new shortcut on the Desktop then click on Properties
- In the Target path add the /safe switch at the end
- Click OK
- Rename the new shortcut to Word 2013
- Double click the new shortcut to test - Word should open in Safe Mode
- Replace existing shortcuts to Word in the All Users Start Menu and Desktop with this new shortcut
0
 
OGislerAuthor Commented:
Thank you VB ITS, finally I modified the GPO with a registry tweak. Word is not executed through desktop, but launched from an application with Citrix.
0

Featured Post

Threat Trends for MSPs to Watch

See the findings.
Despite its humble beginnings, phishing has come a long way since those first crudely constructed emails. Today, phishing sites can appear and disappear in the length of a coffee break, and it takes more than a little know-how to keep your clients secure.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now