Solved

Local drives are not available when using RemoteApp on RDS

Posted on 2015-01-23
10
291 Views
Last Modified: 2015-04-30
Hi,

we have Windows Server 2008 R2 server configured with Remote Desktop Service role with published application via RemoteApp Manager (RDS, RemoteApp, RD Gateway Manager, RD Session Host Configuration Remote Desktop Service Manager).
Classic RDP session to server working fine, all local resources are accessible drives, ports, printers, etc.

Problem is when users starts application from RDS web (RemoteApp and Desktop Connection) or .rdp file , then the local drives are not accessible.

User PCs and RDS server are in different domains with no trust between them.

Our configuration :
1. RemoteApp manager -> RDP Settings -> Common RDP Settings -> Devices and Resources -> all options are checked
2. RemoteApp manager -> RDP Settings -> Custom RDP Settings ->
authentication level:i:2
enablecredsspsupport:i:0
3. RD Session host Configuration -> Connections -> RDP-Tcp -> Client Settings -> Redirection -> all options are unchecked
4. This is our test environment so no special GPO are applied. Just 4 GPO are applied to server (ntp, wsus, passwod policy, default domain policy), 2 GPO to users (default domain policy, IE trusted)

Thank you for help.

Simon
0
Comment
Question by:ZUNO
  • 6
  • 4
10 Comments
 
LVL 7

Expert Comment

by:DrAtomic
ID: 40566084
Hi Simon, have you checked the settings in the .rdp file on a non working client to see if they are correct? It sounds to me that the settings in the .rdp file are not correct (connect drives disabled).
0
 

Author Comment

by:ZUNO
ID: 40566106
Hi DrAtomic, we have checked the rdp settings in .rdp file couple of times but didn't find any problems.

I have attached rdp files for IE and excel, please check it if there is some issue.

http://www.donkz.nl/files/rdpsettings.html

thank you
EXCEL.rdp.txt
Internet-Explorer.rdp.txt
0
 
LVL 7

Expert Comment

by:DrAtomic
ID: 40566139
Have you tried to republish the rdp file without signing? Alternatively try to edit one of the .rdp files and remove it manually (Find the line starting “signscope:s:” and delete any of the text on that line and after it.)
0
 
LVL 7

Expert Comment

by:DrAtomic
ID: 40566165
Also I see that you don't have devicestoredirect set, try setting that to * as well even though that shouldnt be the issue it may be worth the attempt.
0
 

Author Comment

by:ZUNO
ID: 40566191
Both .rdp files edited :

devicestoredirect:s:*
signscope:s:

Everything on the line where signscope:s: is and after it deleted.

Result is the same, local drives still not available.
EE--drAtomic--EXCEL.rdp.txt
EE--drAtomic--Internet-Explorer.rdp.txt
0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
LVL 7

Expert Comment

by:DrAtomic
ID: 40570139
The idea I was following through here is that local drives not being mapped is the default behaviour, thus it may have had the wrong signscope.

Did you check Redirectdrives in Custom RDP settings; redirectdrives:i:1, see https://technet.microsoft.com/en-us/library/ff393706(v=ws.10).aspx
0
 

Author Comment

by:ZUNO
ID: 40572345
Hi DrAtomic,
as you can see from attached files before, the redirectdrives:i:1 has been set.

Maybe there is discrepancy between rdp settings in .rdp file or we are missing some setting.
Do you have any idea what else we can check?

Thank you.
0
 
LVL 7

Expert Comment

by:DrAtomic
ID: 40572445
Hmmm, I'm running out of ideas here, just to make sure, is the RDS server domain added to the IE Trusted domains in the policy on the Users domain?

Did you check the eventlogs (both client and server sided) to see if that contains any hints?
0
 

Author Comment

by:ZUNO
ID: 40579599
RDS server domain is added to the IE Trusted domains.
No problems/errors in event log, just common information.
0
 
LVL 7

Accepted Solution

by:
DrAtomic earned 500 total points
ID: 40588285
Hmmm, ok, just to make sure, did you run gpresult / rsop.msc on the client machine?

Computer configuration\administrative templates\windows components\Remote desktop services\remote desktop sessions host\device and resource redirection

Should have these two options disabled (default behaviour is on, which over rules the rdp files):
Do not allow clipboard redirection
Do not allow drive redirection

This seems to be inline with the behaviour that it is working for admins but not for users.
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Remote Desktop Connections allow you to control remote host machines via the magic of the Internet and RDP (Remote Desktop Protocol). For the purposes of this article we will assume you are connecting from your home PC or laptop to a remote offic…
Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
This tutorial will walk an individual through the steps necessary to configure their installation of BackupExec 2012 to use network shared disk space. Verify that the path to the shared storage is valid and that data can be written to that location:…
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now