Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 415
  • Last Modified:

Virtual pc shared folder permissions

Hello

On my home network, any pc can map a drive to my NAS and get access to a particular folder....no problems

One of those pcs is running Windows Server 2012 R2. On this same server, I installed VMWare workstation 10. The o/s on it is Windows 7. I'm using the bridged network adaptor.
On this VM, I was able to go to Shared folders and map to my NAS, BUT when I try to open the folder, I get permission denied.

Question is, why would that be since all other pcs on my network have no problem accessing the data. So the problem shouldnt be a folder permission issue

So far I havnt seen in documentation how to resolve this.

Thanks
0
HenryV1955
Asked:
HenryV1955
  • 2
  • 2
  • 2
  • +1
2 Solutions
 
JohnBusiness Consultant (Owner)Commented:
I installed VMWare workstation 10. .... I'm using the bridged network adaptor.  <-- If you have ensured this is true and the VM IP address is the same subnet as the host machine, then two things:

1. Ensure VMware Tools have been installed and are running as this can affect sharing.
2. If Tools are running, then it is not a VMware issue at all.

In the machines, check that Network Discovery, File and Print Sharing and password protected sharing are all ENABLED.  Make sure NIC's are on Work/Private and not Public.
0
 
Dawid FusekVirtualization Expert, Sr B&R, Storage SpecialistCommented:
"On this VM, I was able to go to Shared folders and map to my NAS, BUT when I try to open the folder, I get permission denied."

there may be a problem with new installation of Windows 7 you use and default settings, this problem occur in some Windows versions as I remember with default settings to use home sharing, so on every shared folder it connect use guest account, not a local user with it password hash, in this situation on some default NAS it just can't authenticate at all and you will get into exactly problem you describe.

to switch windows 7 to "classic sharing" you may easy do it in my way, so:
- click menu start and type mmc, press enter, then click File/Add/Remove Snap-in
- in available snap-in on left side find "Group Policy Object Editor", click Add and at new window where the Local Computer is selected click Finish
- then on the right console you will see "Local Computer Policy", click OK
- here expand Console Root/Local Computer Policy/Computer Configuration/Windows Settings/Security Settings/Local Policies\Security Options and here find "Network access: Sharing and security model for local accounts" and click it
- here in new window you may switch from probably "Guset only - local user authenticate as Guest" to "Classic - local users authenticate as themselves".

then if your local windows user have same password that this user on NAS you will be automatically transparently authenticated, if not, you will be asked for user and password.

best regards
NTShad0w
0
 
compdigit44Commented:
Are their any logs on the NAS that you can view?
What about the Event logs on the Windows 7 workstation?
Are you connecting with the same username and password?
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
HenryV1955Author Commented:
Hi all

Thanks for your comments. I need a bit of time to look into these, so I will get back to you

H
0
 
HenryV1955Author Commented:
Thank You - Problem resolved
0
 
JohnBusiness Consultant (Owner)Commented:
@HenryV1955  - Thanks for the update and I was happy to help.
0
 
Dawid FusekVirtualization Expert, Sr B&R, Storage SpecialistCommented:
It's good to help you mate.

best regards
NTShad0w
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 2
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now