• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 135
  • Last Modified:

Issues with a new GPO

Hello,
I created a simple GPO to enforce a screen saver of type X and activate within 1800 seconds. The policy is under the Users Configuration. I then went to the Scope and made sure Auth users and Domain users are in the security filtering, and it is linked to the domain XXXXX.local.

I went to a Windows 7 end PC which is on the domain, did several gpupdate/force and ran gpresult /r but keep getting N/A under applied GPO under the User Settings.... what am I missing here.

It is a new Windows 2012 R2 domain which I migrated from Windows 2003 server. The migration went pretty smooth, but maybe I missed something.

Do I need to enable loopback maybe?
0
SpiderPig
Asked:
SpiderPig
  • 5
  • 2
  • 2
  • +1
2 Solutions
 
Cliff GaliherCommented:
If you do a verbose output, or run the results wizard in the GPMC GUI, you can see every applied *AND* denied GPO. And why a GPO was denied. Start there.
0
 
Joseph MoodyBlogger and wearer of all hats.Commented:
You also don't need domain user and auth users. Auth users contains domain users.

You don't need loopback if the policy is linked at the domain and contains auth users.
0
 
SpiderPigAuthor Commented:
OK so I made some progress and was able to make all the User Config GPOs work. From some reason I cannot seems to get the GPOs with the Computer Config policies to work. For example password policies... I have Auth users in the security filtering, I assume thats why and I need to add computers there, but its a pain in the bXXX to manually add PCs. Is there away to tell it to implement for all hardware or computers in the office? I dont want to maintain security groups for computers... Any ideas?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
Cliff GaliherCommented:
Password policies are unique in that they can normally only be implemented at the domain level. The authenticated users group includes all computers. If you want more granular policies, you have to implement Fine Grained Password Policies and that is not a trivial undertaking. TechNet thoroughly documents all of this.
0
 
SpiderPigAuthor Commented:
Oh you are right it is working. I tried "Don not require ALT CTRL Del" And the PC I am working on actually got the policy even though when you type GPresult it does not show anything under computer only user policies....
0
 
SpiderPigAuthor Commented:
Thank you all. Got it sorted out. It was also something weird with MS Bing Desktop which caused the screen saver to operate outside of the GPO scope. Very strange.
0
 
MaheshArchitectCommented:
Whenever you create new Policy, run gpupdate /force on domain controller 1st
Then run gpupdate /force on client computers
Also some computer configuration policies in order to get applied you must reboot the client computer, by simply running gpupdate /force won't help
All user policies will get applied after gpupdate /force on client machines, however some policies do need logoff and logon again in order to get applied

As stated earlier all users and computers \ servers are member of authenticated users group
If you don't want to apply policy only to users or computers, then remove authenticated users from security filtering and add either domain users or domain computers group
OR
more specifically you can create security groups and add required users \ computers in that group
Example:
U might have OU containing all computers, but you wanted to apply GPO to specific computers only within that OU, in that case you can create new security group and add required computers in that group and add that group on security filtering tab, remove authenticated users

U cannot disable default password policy for any domain user unless you create Fine Grained Password Policy
FGPP will override default domain password policy
0
 
SpiderPigAuthor Commented:
By the way, if I dont enable the policy by right clicking it, will it still take effect? I noticed that some PCs got the policy even though it was not enabled.
0
 
MaheshArchitectCommented:
By default any group policy is enabled only even if its not linked to anywhere (domain level, OU level), you may disable all setting if wanted to, this will prevent GPO setting to be pushed to workstations \ users
Even if GPO is enabled, it will not effect unless you link it to any OU \ domain
Instead of disabling GPO, just unlink it from respective OU \ domain.

The problem here is once GPO is applied on workstation, in reality the changes will get written in computers registry, hence even if you remove \ unlink \ disable policy, registry changes will not get reverted automatically
Either you need to reverse policy setting or push another GPO with reverse setting to revert.
0
 
SpiderPigAuthor Commented:
Awesome, thank you. Much appreciated.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

  • 5
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now