Solved

VMware 5.5  with Prolient G5 and MSA 2000

Posted on 2015-01-24
29
189 Views
Last Modified: 2015-01-31
I have a Prolient G5 DL 350 server  with a scsi  Prolient MSA 2000 storage unit
The ESX 5.5. software does not see the HBA.  Know its older equipment  but I need to get this working.
As anybody managed to get this kind of setup working  ?
0
Comment
Question by:thombie
  • 16
  • 12
29 Comments
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
You are correct the G5 is not on the HCL for ESXi 5.5.

But this does not mean it does not work, it's just not supported, not been tested or certified with 5.5.

Are you using the HP OEM version of ESXi 5.5 from HP ?

What is the HBA?

Have you tried downloading the driver from VMware for ESXi 5.5 ?
0
 

Author Comment

by:thombie
Comment Utility
Hi  I am not using the HP OEM. I have downloaded  but still not working.
The HBA  is EMULEX  not sure what version.
I ran esxcfg-scsidevs -a  I and did not see the HBAs
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
HBA  is EMULEX I need more than that I need a model number at least, there a few hundred EMULEX cards!

Possible the HBA is not on the HCL, and drivers have been removed from ESXi 5.5!

try

lspci

and this will show all the PCI devices installed in the server.
0
 

Author Comment

by:thombie
Comment Utility
whats the syntax for ispci ?
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
just type lspci <hit enter or return>
0
 

Author Comment

by:thombie
Comment Utility
Thanks

the HBA is   a  Emulex LPe11000
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
0
 

Author Comment

by:thombie
Comment Utility
I installed it needs a rebooted.  see attached
How do find the PCI ID
installed.docx
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
after a reboot does it show under Storage Adaptors ?

cut and paste the information shows when typing  lspci
0
 

Author Comment

by:thombie
Comment Utility
Ok these are  the ID I think got the `HBAs

0000:13:00.0 10df:fe00 10df:fe00 vmkernel vmhba3
0000:13:00.1 10df:fe00 10df:fe00 vmkernel vmhba5
0000:17:00.0 10df:fe00 10df:fe00 vmkernel vmhba2
0000:17:00.1 10df:fe00 10df:fe00 vmkernel vmhba4
0
 

Author Comment

by:thombie
Comment Utility
I dont see them under storage adapters
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
how do we know it's a  Emulex LPe11000

where's this information from lspci, upload the entire output from lspci.

did you reboot ?

the problem with EMULEX adaptors, the firmware must match the driver, and there are many different EMULEX cards, and some are OEM and different.
0
 

Author Comment

by:thombie
Comment Utility
I have attached the  output
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
where ?

type

lspci > lspci.txt

and upload lspci.txt
0
Free Gift Card with Acronis Backup Purchase!

Backup any data in any location: local and remote systems, physical and virtual servers, private and public clouds, Macs and PCs, tablets and mobile devices, & more! For limited time only, buy any Acronis backup products and get a FREE Amazon/Best Buy gift card worth up to $200!

 

Author Comment

by:thombie
Comment Utility
attached
output.docx
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
did you reboot ?

have you updated the firmware on the server and Emulex HBA ?

check this document for minimum firmware requirements

http://www-dl.emulex.com/support/elx/rt960/b122a/esxi5.5_guide_elx.pdf
0
 

Author Comment

by:thombie
Comment Utility
I will reboot  in the morning I and check back with you Thanks for your help
0
 
LVL 5

Expert Comment

by:Dawid Fusek
Comment Utility
hmm

I remember similar config:
HP Prolient DL 380 G5 server with Emulex LPe11000 4G FC HBA + HP MSA 2012fc 4G FC storage unit + some broacade 4G FC switch installed in 2008 year.

HP MSA 2000 is in fact MSA 2012fc, 2012i or 2012sa array.

Config was installed in 2008 with ESX v3.x, year later updated to ESX 3.5 and after 2 years updated to ESXi v4.1, and as Andy saw it's not supported to work with newer ESXi version. One I may add that this config was not so flexible of support and working even with supported hardware, why? because it needs a correct one firmware for array, FC hba cards and FC brocade switch type to work with correct version of ESXi, so I may think it may some problems and restrictions why it not working with other config, you may consider it while working on it, it may sometimes happens data corruption if you will use some rare unsupported VMware ESXi config with FC HBA/Switch/Arrays.

from here:
http://www.vmware.com/resources/compatibility/detail.php?deviceCategory=san&productid=3594&vcl=true
You may see that "Emulex HBAs are not currently supported with Brocade switches for this array."
In my opinion there ware some imcompatibilities between emulex HBA, brocade switch and MSA 2000 array (MSA 2012fc), and main problem was in my opinion with Emulex HBA.

So if you want to recover some data from that config (??), I will recommend to use last supported version of ESXi what was 4.1U3, but if you want to run some test lab on it with latest ESXi, just try as Andy suggest to match firmware and drivers version (which will be not fully possible at all because of not supported config on newer than ESXi v4.1U3),

Also some option that choose my customer (with my recommendation) was to use QLogic QLE2460 4GB FC HBA with this array (2012fc), this config working ok with that  brocade switch and with ESXi v5.5, it costs 15-20usd on ebay:
http://www.ebay.pl/sch/i.html?_from=R40&_trksid=p2050601.m570.l1313&_nkw=QLOGIC+QLE2460&_sacat=0

best regards
NTShad0w
0
 

Author Comment

by:thombie
Comment Utility
Thanks I rebooted last night to no avail. I will try to match the firmware. By the way there is no SAN switch involved just
a  direct FC connection the the storage. The customer as limited funds so really need to get this solution working.
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
what it's connected to at present should not stop it being displayed as a storage adaptor in ESXi 5,5, connected to SAN, Switch or no connection.

Is this an HP part?

Often non-HP parts do not work well with HP servers.
0
 

Author Comment

by:thombie
Comment Utility
Os a none HP Emulex
0
 

Author Comment

by:thombie
Comment Utility
This is what see in my Host -  No HBA as far as I can see
Screen-Shot-2015-01-25-at-20.35.43.png
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
Incompatible FC HBA, or driver not loaded or installed.

Firmware, check the document I linked to!

This is the risk, expected running non-HCL OS on uncertified hardware!
0
 

Author Comment

by:thombie
Comment Utility
How  do  i  load driver
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
Did you not install the driver, I found you above ?

Did you download this driver ?

I thought you had installed this driver ? It could be the incorrect driver, or the firmware does not match the driver.

Did you read the PDF ?

https://my.vmware.com/group/vmware/details?downloadGroup=DT-ESXI55-EMULEX-LPFC-100725203&productId=353

http://www-dl.emulex.com/support/elx/rt960/b122a/esxi5.5_guide_elx.pdf
0
 

Author Comment

by:thombie
Comment Utility
Sorry I misunderstood. I did load the driver it does not work
I have found a couple  HP badged Brocade  with 8G  FC SFP i wonder if this will work
HP part number is  AP770-60001 REV B
0
 
LVL 117

Accepted Solution

by:
Andrew Hancock (VMware vExpert / EE MVE) earned 500 total points
Comment Utility
0
 

Author Comment

by:thombie
Comment Utility
Thanks I will give it ago
0
 

Author Closing Comment

by:thombie
Comment Utility
Installed  the  brocade   HBA  and all is working thank you
0

Featured Post

Zoho SalesIQ

Hassle-free live chat software re-imagined for business growth. 2 users, always free.

Join & Write a Comment

Create your own, high-performance VM backup appliance by installing NAKIVO Backup & Replication directly onto a Synology NAS!
In this step by step tutorial with screenshots, we will show you HOW TO: Enable SSH Remote Access on a VMware vSphere Hypervisor 6.5 (ESXi 6.5). This is important if you need to enable SSH remote access for additional troubleshooting of the ESXi hos…
Teach the user how to install and configure the vCenter Orchestrator virtual appliance Open vSphere Web Client: Deploy vCenter Orchestrator virtual appliance OVA file: Verify vCenter Orchestrator virtual appliance boots successfully: Connect to the …
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now