Solved

Dell 6224 Config to Cisco Catalyst 3850 Config

Posted on 2015-01-26
18
447 Views
Last Modified: 2016-11-23
Hi All

I'm hoping you wonderful people can help me. I have a stacked pair of Dell 6224 PowerConnect switches. At Present these switches are being used as core switches and I've been asked to upgrade these to Cisco switches.

We have purchased two 3850 switches with the stacking kit, on initial configuration the Cisco's are stacked and have recognised each other.

The issue I am having is that I have attempted to map across most of the config to a Cisco command set. Unfortunately its not worked and I had to rollback.

What I am after is just to have a direct mapping and then its just a case of an unplug from port 1 on the Dell and plug into Port 1 on the Cisco etc....

The Dell config is as follows:
 ------------------------------------

!Current Configuration:
!System Description "Powerconnect 6224, 3.2.1.3, VxWorks 6.5"
!System Software Version 3.2.1.3
!Cut-through mode is configured as disabled
!
configure
vlan database
vlan 2,5,20,30,40,50
vlan routing 20 1
vlan routing 30 2
vlan routing 2 3
vlan routing 1 4
exit
hostname "mtpswig001"
stack
member 1 1
member 2 1
exit
ip address 10.5.93.240 255.255.255.0
ip address vlan 5
ip routing
ip route 10.0.96.0 255.255.255.0 10.0.93.250
ip route 10.0.97.0 255.255.255.0 10.0.93.250
ip route 0.0.0.0 0.0.0.0 10.0.93.253
ip route 10.35.96.0 255.255.255.0 10.0.93.250
ip route 10.0.95.0 255.255.255.0 10.0.93.250
ip route 10.0.98.0 255.255.255.0 10.0.93.250
interface vlan 1
routing
ip address 10.0.93.254 255.255.255.0
no ip proxy-arp
exit
interface vlan 2
name "Clients"
routing
ip address 10.0.94.254 255.255.255.0
ip helper-address 10.0.93.21 dhcp
no ip proxy-arp
exit
interface vlan 5
name "Switch"
exit
interface vlan 20
name "iSCSI"
routing
no ip proxy-arp
ip mtu 1500
exit
interface vlan 30
name "Managment"
routing
ip address 10.30.93.250 255.255.255.0
no ip proxy-arp
exit
interface vlan 40
name "vMotion"
exit
interface vlan 50
bridge multicast forward-all
exit
username "root" password c24d1ba02018f4536005103e310e28fd level 15 encrypted
monitor session 1 source interface 1/g9
ip ssh server
spanning-tree priority 0
ip multicast
!
interface ethernet 1/g1
spanning-tree portfast
switchport mode general
switchport general pvid 30
switchport general allowed vlan add 30
switchport general allowed vlan add 40 tagged
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g2
spanning-tree portfast
switchport mode general
switchport general pvid 30
switchport general allowed vlan add 30
switchport general allowed vlan add 40 tagged
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g3
spanning-tree portfast
switchport mode general
switchport general allowed vlan add 2,5,20,30,40,50 tagged
exit
!
interface ethernet 1/g4
spanning-tree portfast
exit
!
interface ethernet 1/g5
spanning-tree portfast
switchport mode general
switchport general allowed vlan add 5,30 tagged
exit
!
interface ethernet 1/g6
spanning-tree portfast
switchport mode general
switchport general allowed vlan add 5,30 tagged
exit
!
interface ethernet 1/g7
spanning-tree portfast
switchport access vlan 20
exit
!
interface ethernet 1/g8
spanning-tree portfast
switchport access vlan 20
exit
!
interface ethernet 1/g9
spanning-tree portfast
switchport mode general
switchport general pvid 20
switchport general allowed vlan add 20 tagged
exit
!
interface ethernet 1/g10
spanning-tree portfast
switchport mode general
switchport general pvid 20
switchport general allowed vlan add 20 tagged
exit
!
interface ethernet 1/g11
spanning-tree portfast
switchport mode general
switchport general allowed vlan add 5,30 tagged
exit
!
interface ethernet 1/g12
spanning-tree portfast
switchport mode general
switchport general allowed vlan add 5,30 tagged
exit
!
interface ethernet 1/g13
switchport mode general
switchport general pvid 20
switchport general allowed vlan add 20 tagged
exit
!
interface ethernet 1/g14
spanning-tree portfast
switchport access vlan 30
exit
!
interface ethernet 1/g15
description 'MTPEQLG002 CTRL0 MGMT'
spanning-tree portfast
switchport access vlan 30
exit
!
interface ethernet 1/g16
spanning-tree portfast
exit
!
interface ethernet 1/g17
description 'MTPEQLG002 CTRL0 ETH0'
spanning-tree portfast
switchport access vlan 20
exit
!
interface ethernet 1/g18
description 'MTPEQLG002 CTRL0 ETH1'
spanning-tree portfast
switchport access vlan 20
exit
!
interface ethernet 1/g19
spanning-tree portfast
exit
!
interface ethernet 1/g20
spanning-tree portfast
exit
!
interface ethernet 1/g21
description 'MTPEQLG002 CTRL1 ETH2'
spanning-tree portfast
switchport access vlan 20
exit
!
interface ethernet 1/g22
description 'MTPEQLG002 CTRL1 ETH3'
spanning-tree portfast
switchport access vlan 20
exit
!
interface ethernet 1/g23
channel-group 1 mode auto
switchport access vlan 2
exit
!
interface ethernet 1/g24
switchport mode general
switchport general pvid 2
switchport forbidden vlan add 20
switchport general allowed vlan add 2,30
exit
!
interface ethernet 1/xg3
switchport access vlan 20
exit
!
interface ethernet 1/xg4
switchport access vlan 20
exit
!
interface ethernet 2/g1
spanning-tree portfast
switchport mode general
switchport general pvid 30
switchport general allowed vlan add 30
switchport general allowed vlan add 40 tagged
switchport general allowed vlan remove 1
exit
!
interface ethernet 2/g2
spanning-tree portfast
switchport mode general
switchport general pvid 30
switchport general allowed vlan add 30
switchport general allowed vlan add 40 tagged
switchport general allowed vlan remove 1
exit
!
interface ethernet 2/g3
description 'IML Temp backup Box iLo'
spanning-tree portfast
exit
!
interface ethernet 2/g4
spanning-tree portfast
switchport mode general
switchport general allowed vlan add 20 tagged
exit
!
interface ethernet 2/g5
spanning-tree portfast
switchport mode general
switchport general allowed vlan add 5,30 tagged
exit
!
interface ethernet 2/g6
spanning-tree portfast
switchport mode general
switchport general allowed vlan add 5,30 tagged
exit
!
interface ethernet 2/g7
spanning-tree portfast
switchport mode general
switchport general allowed vlan add 5,30 tagged
exit
!
interface ethernet 2/g8
spanning-tree portfast
switchport mode general
switchport general allowed vlan add 5,30 tagged
exit
!
interface ethernet 2/g9
spanning-tree portfast
exit
!
interface ethernet 2/g10
spanning-tree portfast
exit
!
interface ethernet 2/g11
spanning-tree portfast
switchport access vlan 20
exit
!
interface ethernet 2/g12
spanning-tree portfast
switchport access vlan 20
exit
!
interface ethernet 2/g13
spanning-tree portfast
exit
!
interface ethernet 2/g14
spanning-tree portfast
switchport access vlan 30
exit
!
interface ethernet 2/g15
description 'MTPEQLG002 CTRL0 ETH2'
spanning-tree portfast
switchport access vlan 20
exit
!
interface ethernet 2/g16
spanning-tree portfast
exit
!
interface ethernet 2/g17
description 'MTPEQLG002 CTRL0 ETH3'
spanning-tree portfast
switchport access vlan 20
exit
!
interface ethernet 2/g18
description 'IML Temp Backup Box'
spanning-tree portfast
exit
!
interface ethernet 2/g19
description 'MTPEQLG002 CTRL1 MGMT'
spanning-tree portfast
switchport access vlan 30
exit
!
interface ethernet 2/g20
spanning-tree portfast
exit
!
interface ethernet 2/g21
spanning-tree portfast
exit
!
interface ethernet 2/g22
description 'MTPEQLG002 CTRL1 ETH0'
spanning-tree portfast
switchport access vlan 20
exit
!
interface ethernet 2/g23
channel-group 1 mode auto
switchport access vlan 2
exit
!
interface ethernet 2/g24
description 'MTPEQLG002 CTRL1 ETH1'
spanning-tree portfast
switchport access vlan 20
exit
!
interface port-channel 1
description 'UPLINK-TO-PROCURVE'
switchport access vlan 2
exit
exit
0
Comment
Question by:goldied
  • 10
  • 8
18 Comments
 
LVL 50

Accepted Solution

by:
Don Johnston earned 500 total points
ID: 40570375
Many, mabye even most of the command will work on a Cisco switch. But some will need some work.

For example, VLANs are named in VLAN config context, not on the SVI. So you have to do it like this.

vlan 2
name Clients
vlan 5
name Switch
vlan 20
name iSCSI
vlan 30
name Managment
vlan 40
name vMotion
vlan 50

Open in new window


Spanning Tree is going to be a challenge.  By default, Cisco uses PVSTP (Per VLAN Spanning Tree Protocol).  Not sure what the rest of your switches are using, but in multi-vendor environments, I usually use 802.1s Multi Instance Spanning Tree.  It's a standard so just about all vendors support it.

Your interface commands will need some work too.
First the format is different.  With Cisco, it's "type switch/module/port".  So where you have:

interface ethernet 1/g2

That will be

interface g1/0/2  (assuming a gigabit ethernet port 2 on switch 1)  The middle number is always 0

The commands under the interface will need work as well. Cisco doesn't have a "switchport mode general" command so you will need to change all of those to "switchport mode trunk"


spanning-tree portfast
switchport mode general
switchport general pvid 30
switchport general allowed vlan add 30
switchport general allowed vlan add 40 tagged
switchport general allowed vlan remove 1

Open in new window


will most likely become
spanning-tree portfast
switchport mode trunk
switchport trunk native vlan 30
switchport trunk allowed vlan remove 1

Open in new window


To create channel groups, change your existing command "channel-group 1 mode auto" to "channel-group 1 mode on (or active)" as Cisco's mode auto uses their proprietary PAgP protocol.  If, on the other hand, the device at the other end supports PAgP, then you can keep that command the same.
0
 
LVL 1

Author Comment

by:goldied
ID: 40570489
Thats great, I will make an attempt at re-mapping all the config.

Just a query on some of the syntax, what do these commands mean?

vlan routing 20 1
vlan routing 30 2
vlan routing 2 3
vlan routing 1 4

I assume this is intervlan routing or some sort of priority?
0
 
LVL 1

Author Comment

by:goldied
ID: 40570493
Also, apologies for the ignorance, what are Channel Groups?
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40570543
Just a query on some of the syntax, what do these commands mean?
According to the documentation, this enables routing for a VLAN.  With Cisco, routing is enabled globally so it's not required.
Also, apologies for the ignorance, what are Channel Groups?
Channel-groups are where multiple physical links are "grouped" or aggregated together to create a single, faster link. On your Dell, 1/23 and 2/23 are aggregated to create a 2gb link.
0
 
LVL 1

Author Comment

by:goldied
ID: 40570608
I did some research on the Spanning-Tree protocol stuff. What you are saying makes sense, it is a multi brand environment. There is a HP ProCurve and a set of Dell switches in the mix.

How do I enable the specific version of Spanning Tree that you have mentioned about?

Thanks for all the help.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40570905
There are variables which need to be considered such as the region name, which VLANs are in which instance, etc., but this should get you there.

How to configure MSTP
0
 
LVL 1

Author Comment

by:goldied
ID: 40571239
Hi Don

I don't really understand the MST stuff.

Having said that, the uplink to the additional switch for clients to connect (patch ports) is on a switchport access on vlan 2, all communication between other sites goes through an MPLS router so I think this should do the trick without the MST.

I'll be giving this a go one evening this week. If you could take a quick browse over my config I'd greatly appreciate it.

The // comments are just incase I need the syntax, I intend to run this is manually one section at a time.

Thanks for your help Don, My config is below:

enable

//spanning-tree mst configuration
//instance 1 vlan 1-50
//name region1
//revision 1
//show pending
//exit
//spanning-tree mode mst
//end

vlan database
vlan 2
vlan 2 name Clients
vlan 5
vlan 5 name Switch
vlan 20
vlan 20 name iSCSI
vlan 30S
vlan 30 name Managment
vlan 40
vlan 40 name vMotion
vlan 50
exit


conf t
hostname "CiscoCoreStack"

interface gigabitethernet 0/0
ip address 10.5.93.240 255.255.255.0
exit

ip routing
ip route 10.0.96.0 255.255.255.0 10.0.93.250
ip route 10.0.97.0 255.255.255.0 10.0.93.250
ip route 0.0.0.0 0.0.0.0 10.0.93.253
ip route 10.35.96.0 255.255.255.0 10.0.93.250
ip route 10.0.95.0 255.255.255.0 10.0.93.250
ip route 10.0.98.0 255.255.255.0 10.0.93.250

interface vlan 1
ip address 10.0.93.254 255.255.255.0
no ip proxy-arp
exit
interface vlan 2
ip address 10.0.94.254 255.255.255.0
no ip proxy-arp
exit
interface vlan 5
exit
interface vlan 20
no ip proxy-arp
ip mtu 1500
exit
interface vlan 30
ip address 10.30.93.250 255.255.255.0
no ip proxy-arp
exit
interface vlan 40
exit
interface vlan 50
exit

ip multicast auto-enable

interface gigabitethernet 1/0/1
spanning-tree portfast
switchport mode trunk
switchport trunk native vlan 30
switchport trunk allowed vlan add 40
switchport trunk allowed vlan remove 1
exit

interface gigabitethernet 1/0/2
spanning-tree portfast
switchport mode trunk
switchport trunk native vlan 30
switchport trunk allowed vlan add 40
switchport trunk allowed vlan remove 1
exit

interface gigabitethernet 1/0/3
spanning-tree portfast
switchport mode trunk
switchport trunk allowed vlan add 2,5,20,30,40,50
exit

interface gigabitethernet 1/0/4
spanning-tree portfast
exit

interface gigabitethernet 1/0/5
spanning-tree portfast
switchport mode trunk
switchport trunk allowed vlan add 5
switchport trunk allowed vlan add 30
exit

interface gigabitethernet 1/0/6
spanning-tree portfast
switchport mode trunk
switchport trunk allowed vlan add 5,30
exit

interface gigabitethernet 1/0/7
spanning-tree portfast
switchport access vlan 20
exit

interface gigabitethernet 1/0/8
spanning-tree portfast
switchport access vlan 20
exit

interface gigabitethernet 1/0/9
spanning-tree portfast
switchport mode trunk
switchport trunk native vlan 20
exit

interface gigabitethernet 1/0/10
spanning-tree portfast
switchport mode trunk
switchport trunk native vlan  20
exit

interface gigabitethernet 1/0/11
spanning-tree portfast
switchport mode trunk
switchport trunk allowed vlan add 5,30
exit

interface gigabitethernet 1/0/12
spanning-tree portfast
switchport mode trunk
switchport trunk allowed vlan add 5,30
exit

interface gigabitethernet 1/0/13
spanning-tree portfast
switchport mode trunk
switchport trunk native vlan 20
exit

interface gigabitethernet 1/0/14
spanning-tree portfast
switchport access vlan 30
exit

interface gigabitethernet 1/0/15
description 'MTPEQLG002 CTRL0 MGMT'
spanning-tree portfast
switchport access vlan 30
exit

interface gigabitethernet 1/0/16
spanning-tree portfast
exit

interface gigabitethernet 1/0/17
description 'MTPEQLG002 CTRL0 ETH0'
spanning-tree portfast
switchport access vlan 20
exit

interface gigabitethernet 1/0/18
description 'MTPEQLG002 CTRL0 ETH1'
spanning-tree portfast
switchport access vlan 20
exit

interface gigabitethernet 1/0/19
spanning-tree portfast
exit

interface gigabitethernet 1/0/20
spanning-tree portfast
exit

interface gigabitethernet 1/0/21
description 'MTPEQLG002 CTRL1 ETH2'
spanning-tree portfast
switchport access vlan 20
exit

interface gigabitethernet 1/0/22
description 'MTPEQLG002 CTRL1 ETH3'
spanning-tree portfast
switchport access vlan 20
exit

interface gigabitethernet 1/0/23
channel-group 1 mode on
switchport access vlan 2
exit

interface gigabitethernet 1/0/24
switchport mode trunk
switchport trunk native vlan 2
switchport trunk allowed vlan remove 20
switchport trunk allowed vlan add 2,30
exit

interface gigabitethernet 2/0/1
spanning-tree portfast
switchport mode trunk
switchport trunk native vlan 30
switchport trunk allowed vlan add 40
switchport trunk allowed vlan remove 1
exit

interface gigabitethernet 2/0/2
spanning-tree portfast
switchport mode trunk
switchport trunk native vlan 30
switchport general allowed vlan add 30
switchport general allowed vlan add 40 tagged
switchport general allowed vlan remove 1
exit

interface gigabitethernet 2/0/3
description 'IML Temp backup Box iLo'
spanning-tree portfast
exit

interface gigabitethernet 2/0/4
spanning-tree portfast
switchport mode trunk
switchport trunk native vlan 20
exit

interface gigabitethernet 2/0/5
spanning-tree portfast
switchport mode trunk
switchport trunk allowed vlan add 5,30
exit

interface gigabitethernet 2/0/6
spanning-tree portfast
switchport mode trunk
switchport trunk allowed vlan add 5,30
exit

interface gigabitethernet 2/0/7
spanning-tree portfast
switchport mode trunk
switchport trunk allowed vlan add 5,30
exit

interface gigabitethernet 2/0/8
spanning-tree portfast
switchport mode trunk
switchport trunk allowed vlan add 5,30
exit

interface gigabitethernet 2/0/9
spanning-tree portfast
exit

interface gigabitethernet 2/0/10
spanning-tree portfast
exit

interface gigabitethernet 2/0/11
spanning-tree portfast
switchport access vlan 20
exit

interface gigabitethernet 2/0/12
spanning-tree portfast
switchport access vlan 20
exit

interface gigabitethernet 2/0/13
spanning-tree portfast
exit

interface gigabitethernet 2/0/14
spanning-tree portfast
switchport access vlan 30
exit

interface gigabitethernet 2/0/15
description 'MTPEQLG002 CTRL0 ETH2'
spanning-tree portfast
switchport access vlan 20
exit

interface gigabitethernet 2/0/16
spanning-tree portfast
exit

interface gigabitethernet 2/0/17
description 'MTPEQLG002 CTRL0 ETH3'
spanning-tree portfast
switchport access vlan 20
exit

interface gigabitethernet 2/0/18
description 'IML Temp Backup Box'
spanning-tree portfast
exit

interface gigabitethernet 2/0/19
description 'MTPEQLG002 CTRL1 MGMT'
spanning-tree portfast
switchport access vlan 30
exit

interface gigabitethernet 2/0/20
spanning-tree portfast
exit

interface gigabitethernet 2/0/21
spanning-tree portfast
exit

interface gigabitethernet 2/0/22
description 'MTPEQLG002 CTRL1 ETH0'
spanning-tree portfast
switchport access vlan 20
exit

interface gigabitethernet 2/0/23
channel-group 1 mode on
switchport access vlan 2
exit

interface ethernet 2/0/24
description 'MTPEQLG002 CTRL1 ETH1'
spanning-tree portfast
switchport access vlan 20
exit

interface port-channel 1
description 'UPLINK-TO-PROCURVE'
switchport access vlan 2
exit
exit

FYI, If you ever have any Citrix related problems please drop me a message, that is where my strength lies.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40571426
When posting configs, please use the code feature.  It makes it easier to read.

Before applying this,
interface gigabitethernet 0/0
 ip address 10.5.93.240 255.255.255.0 
 exit

Open in new window

you'll need to make the interface a layer-3 interface
interface gigabitethernet 0/0
 no switchport
 ip address 10.5.93.240 255.255.255.0
 exit

Open in new window

0
 
LVL 1

Author Comment

by:goldied
ID: 40584664
Hi Don

So close. I swapped the switches this evening. When I rebooted all my VMWare servers it all worked and I could ping all my servers.

The downside was that the default gateway for my machines is 10.0.94.254 (This is the IP for VLAN1), and it didn't seem to allow for an internet connection?

The Firewall is 10.0.93.253 which I could see also , its so much more closer than before.

Am I missing something here?

Also: The No Switchport command did not work.
0
Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

 
LVL 50

Expert Comment

by:Don Johnston
ID: 40584681
Do you have a default route?  Should be:

ip route 0.0.0.0 0.0.0.0 10.0.93.253

"no switchport" didn't work??? If this is a Cisco 3850 then it should accept the command.  Did you apply it to the correct physical interface?
0
 
LVL 1

Author Comment

by:goldied
ID: 40584813
Hi Don

Yes I do have the default route. I'll post the config again below:

Its definitely a Cisco 3850.

I was on gigabitethernet0/0.

NOTE: This is what I typed as I typed it in.

enable

spanning-tree mst configuration
instance 1 vlan 1-50
name region1
revision 1
show pending
exit
spanning-tree mode mst
end

conf t

vlan 2
name Clients
exit
vlan 5
name Switch
exit
vlan 20
name iSCSI
exit
vlan 30
name Managment
exit
vlan 40
name vMotion
exit
vlan 50
exit
vlan 60
name PVS
exit

hostname "CiscoCoreStack"

interface gigabitethernet 0/0
//no switchport
ip address 10.5.93.240 255.255.255.0
exit

ip routing
ip route 10.0.96.0 255.255.255.0 10.0.93.250
ip route 10.0.97.0 255.255.255.0 10.0.93.250
ip route 0.0.0.0 0.0.0.0 10.0.93.253
ip route 10.35.96.0 255.255.255.0 10.0.93.250
ip route 10.0.95.0 255.255.255.0 10.0.93.250
ip route 10.0.98.0 255.255.255.0 10.0.93.250

interface vlan 1
ip address 10.0.93.254 255.255.255.0
no ip proxy-arp
exit
interface vlan 2
ip address 10.0.94.254 255.255.255.0
no ip proxy-arp
exit
interface vlan 5
exit
interface vlan 20
no ip proxy-arp
ip mtu 1500
exit
interface vlan 30
ip address 10.30.93.250 255.255.255.0
no ip proxy-arp
exit
interface vlan 40
exit
interface vlan 50
exit

ip multicast auto-enable

interface gigabitethernet 1/0/1
spanning-tree portfast
switchport mode trunk
switchport trunk native vlan 30
switchport trunk allowed vlan add 40
switchport trunk allowed vlan remove 1
exit

interface gigabitethernet 1/0/2
spanning-tree portfast
switchport mode trunk
switchport trunk native vlan 30
switchport trunk allowed vlan add 40
switchport trunk allowed vlan remove 1
exit

interface gigabitethernet 1/0/3
spanning-tree portfast
switchport mode trunk
switchport trunk allowed vlan add 2,5,20,30,40,50
exit

interface gigabitethernet 1/0/4
spanning-tree portfast
exit

interface gigabitethernet 1/0/5
spanning-tree portfast
switchport mode trunk
switchport trunk allowed vlan add 5 
switchport trunk allowed vlan add 30
exit

interface gigabitethernet 1/0/6
spanning-tree portfast
switchport mode trunk
switchport trunk allowed vlan add 5,30
exit

interface gigabitethernet 1/0/7
spanning-tree portfast
switchport access vlan 20
exit

interface gigabitethernet 1/0/8
spanning-tree portfast
switchport access vlan 20
exit

interface gigabitethernet 1/0/9
spanning-tree portfast
switchport mode trunk
switchport trunk native vlan 20
exit

interface gigabitethernet 1/0/10
spanning-tree portfast
switchport mode trunk
switchport trunk native vlan  20
exit

interface gigabitethernet 1/0/11
spanning-tree portfast
switchport mode trunk
switchport trunk allowed vlan add 5,30
exit

interface gigabitethernet 1/0/12
spanning-tree portfast
switchport mode trunk
switchport trunk allowed vlan add 5,30
exit

interface gigabitethernet 1/0/13
spanning-tree portfast
switchport mode trunk
switchport trunk native vlan 20
exit

interface gigabitethernet 1/0/14
spanning-tree portfast
switchport access vlan 30
exit

interface gigabitethernet 1/0/15
description 'MTPEQLG002 CTRL0 MGMT'
spanning-tree portfast
switchport access vlan 30
exit

interface gigabitethernet 1/0/16
spanning-tree portfast
exit

interface gigabitethernet 1/0/17
description 'MTPEQLG002 CTRL0 ETH0'
spanning-tree portfast
switchport access vlan 20
exit

interface gigabitethernet 1/0/18
description 'MTPEQLG002 CTRL0 ETH1'
spanning-tree portfast
switchport access vlan 20
exit

interface gigabitethernet 1/0/19
spanning-tree portfast
exit

interface gigabitethernet 1/0/20
spanning-tree portfast
exit

interface gigabitethernet 1/0/21
description 'MTPEQLG002 CTRL1 ETH2'
spanning-tree portfast
switchport access vlan 20
exit

interface gigabitethernet 1/0/22
description 'MTPEQLG002 CTRL1 ETH3'
spanning-tree portfast
switchport access vlan 20
exit

interface gigabitethernet 1/0/23
channel-group 1 mode on
switchport access vlan 2
exit

interface gigabitethernet 1/0/24
switchport mode trunk
switchport trunk native vlan 2
switchport trunk allowed vlan remove 20
switchport trunk allowed vlan add 2,30
exit

interface gigabitethernet 2/0/1
spanning-tree portfast
switchport mode trunk
switchport trunk native vlan 30
switchport trunk allowed vlan add 40
switchport trunk allowed vlan remove 1
exit

interface gigabitethernet 2/0/2
spanning-tree portfast
switchport mode trunk
switchport trunk native vlan 30
switchport trunk allowed vlan add 30
switchport trunk allowed vlan add 40
switchport trunk allowed vlan remove 1
exit

interface gigabitethernet 2/0/3
description 'IML Temp backup Box iLo'
spanning-tree portfast
exit

interface gigabitethernet 2/0/4
spanning-tree portfast
switchport mode trunk
switchport trunk native vlan 20
exit

interface gigabitethernet 2/0/5
spanning-tree portfast
switchport mode trunk
switchport trunk allowed vlan add 5,30
exit

interface gigabitethernet 2/0/6
spanning-tree portfast
switchport mode trunk
switchport trunk allowed vlan add 5,30
exit

interface gigabitethernet 2/0/7
spanning-tree portfast
switchport mode trunk
switchport trunk allowed vlan add 5,30
exit

interface gigabitethernet 2/0/8
spanning-tree portfast
switchport mode trunk
switchport trunk allowed vlan add 5,30
exit

interface gigabitethernet 2/0/9
spanning-tree portfast
exit

interface gigabitethernet 2/0/10
spanning-tree portfast
exit

interface gigabitethernet 2/0/11
spanning-tree portfast
switchport access vlan 20
exit

interface gigabitethernet 2/0/12
spanning-tree portfast
switchport access vlan 20
exit

interface gigabitethernet 2/0/13
spanning-tree portfast
exit

interface gigabitethernet 2/0/14
spanning-tree portfast
switchport access vlan 30
exit

interface gigabitethernet 2/0/15
description 'MTPEQLG002 CTRL0 ETH2'
spanning-tree portfast
switchport access vlan 20
exit

interface gigabitethernet 2/0/16
spanning-tree portfast
exit

interface gigabitethernet 2/0/17
description 'MTPEQLG002 CTRL0 ETH3'
spanning-tree portfast
switchport access vlan 20
exit

interface gigabitethernet 2/0/18
description 'IML Temp Backup Box'
spanning-tree portfast
exit

interface gigabitethernet 2/0/19
description 'MTPEQLG002 CTRL1 MGMT'
spanning-tree portfast
switchport access vlan 30
exit

interface gigabitethernet 2/0/20
spanning-tree portfast
exit

interface gigabitethernet 2/0/21
spanning-tree portfast
exit

interface gigabitethernet 2/0/22
description 'MTPEQLG002 CTRL1 ETH0'
spanning-tree portfast
switchport access vlan 20
exit

interface gigabitethernet 2/0/23
channel-group 1 mode on
switchport access vlan 2
exit

interface gigabitethernet 2/0/24
description 'MTPEQLG002 CTRL1 ETH1'
spanning-tree portfast
switchport access vlan 20
exit

interface port-channel 1
description 'UPLINK-TO-PATCH-PORTS'
switchport access vlan 2
exit
exit

Open in new window

0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40585033
This is part of a stack.  There is no gig 0/0 interface.  You apply the commands to whatever interface you want to assign an IP address.

Can the hosts ping 10.0.93.254?

Can the switch ping 10.0.93.253?
0
 
LVL 1

Author Comment

by:goldied
ID: 40585124
The hosts cannot ping .254 I didn't try the switch .253 , I will possibly be taking the whole lot down at the weekend to tackle this. I have to get agreement with the business to do so.

There is a gigabitethernet 0/0 , it's on the back of the first switch. I know it's there because if I wire up my laptop to it , it states it's up and if I enable ssh I can manage it on that port. Eventually ill want to manage it through my management vlan 30. I'm just keen to get them working now. It's close.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40585184
I thought you were talking about data traffic.

Gig 0/0 is a layer 3 management interface.  It is only used to manage the switch.  Since it's Layer-3 only, there is no option to make it layer-2.
0
 
LVL 1

Author Comment

by:goldied
ID: 40586282
Hi Don

Do you have any thoughts on the gateway or do you just think it should work with the above config?

The Management interface can stay where it is, you gave me the above code example so I was just making you aware it doesn't work as expected.

I appreciate your help, thank you.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 40586308
What is the IP address of the host that you are testing from?
Can the host ping its default gateway?
Can the switch ping 10.0.93.253?
0
 
LVL 1

Author Comment

by:goldied
ID: 40586316
Hi Don

Let me get all the details specifically and sense check it all before I frustrate you with insufficient information.

I'll answer these question probably after this weekend.

Regards

Leee
0
 
LVL 1

Author Closing Comment

by:goldied
ID: 40609505
Thanks Don, the issue turned out to be the config on the switch port of the up link to the mpls.  Took a while to nail it down but all sorted now. 1/0/13 had a native vlan of 20 but actually it just needed to be a plain trunk. The mpls routes back into the network for internal ranges, this wasn't happening. Thanks for all your help though.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
tplink repeater 3 25
Iptables and mirroring ports 4 46
Comms between vlans via router 2 22
traffic flow without STP 9 13
This article will step through configuring a SonicWALL appliance to utilize an internal DHCP server for Global VPN Client (GVC) hosts.  There are times when using an external (external to the SonicWALL) DHCP server, such as Windows Servers, isn’t pr…
Before I go to far, let's explain HA (High Availability) and why you should consider it.  High availability is the mechanism used to provide redundancy to any service at the same site and appears as a single service to the users of that service.  As…
In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now