Solved

Voip Lab

Posted on 2015-01-26
9
345 Views
Last Modified: 2015-01-29
I am setting up a voip lab. I have 1 cisco 3560 switch. 1 2811 router. 1 pc and 1 esxi server.  The esxi server is on a different subnet but for some reason I cant ping it from the switch or the pc. I can from the router though. Most of the network is 10.10 but the exsi is on the 192 network. Below are my configs. I don't want to change any of the ip info or config. Just want to make it work the way it is.


Switch:
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/2
 switchport access vlan 10
 switchport mode access
 switchport voice vlan 15
 spanning-tree portfast
!
interface FastEthernet0/3
 switchport access vlan 10
 switchport mode access
 switchport voice vlan 15
 spanning-tree portfast
!
interface FastEthernet0/4
 switchport access vlan 10
 switchport mode access
 switchport voice vlan 15
 spanning-tree portfast
!
interface FastEthernet0/5
 switchport access vlan 10
 switchport mode access
 switchport voice vlan 15
 spanning-tree portfast
!
interface FastEthernet0/6
 switchport access vlan 10
 switchport mode access
 switchport voice vlan 15
 spanning-tree portfast
!
interface FastEthernet0/7
 switchport access vlan 10
 switchport mode access
 switchport voice vlan 15
 spanning-tree portfast
!
Omitted

interface Vlan1
 no ip address
 shutdown
!
interface Vlan11
 ip address 10.11.0.2 255.255.255.0
!
interface Vlan15
 no ip address
!
ip default-gateway 192.168.15.20
ip http server
ip http secure-server
!
!
ip route 0.0.0.0 0.0.0.0 10.10.0.1
!
!
!
!
line con 0
 exec-timeout 120 0
 password cisco
 logging synchronous
 login
line vty 0 4
 login
line vty 5 15
 login
!
end

Switch# interface Vlan1
         ^
router:

Current configuration : 1788 bytes
!
! Last configuration change at 16:57:39 UTC Mon Jan 26 2015
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
ip dhcp excluded-address 10.10.0.1 10.10.0.10
ip dhcp excluded-address 10.15.0.1 10.15.0.10
ip dhcp excluded-address 192.168.15.0 192.168.15.9
!
ip dhcp pool Data
 network 10.10.0.0 255.255.255.0
 default-router 10.10.0.1
 option 150 ip 10.10.0.1
!
ip dhcp pool Voice
 network 192.168.15.0 255.255.255.0
 default-router 192.168.15.1
 option 150 ip 192.168.15.1
!
!
!
no ip domain lookup
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO2811 sn FTX1425A0E5
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.10
 description Data VLAN
 encapsulation dot1Q 10
 ip address 10.10.0.1 255.255.255.0
!
interface FastEthernet0/0.11
 description Management VLAN
 encapsulation dot1Q 11
 ip address 10.11.0.1 255.255.255.0
!
interface FastEthernet0/0.15
 description Voice VLAN
 encapsulation dot1Q 15
 ip address 192.168.15.1 255.255.255.0
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 192.168.15.10 255.255.255.255 192.168.15.0
!
!
!
!
control-plane
!
!
!
!
mgcp profile default
!
!
!
!
!
line con 0
 exec-timeout 120 0
 password cisco
 logging synchronous
 login
line aux 0
line vty 0 4
 login
 transport input all
!
scheduler allocate 20000 1000
end

Router#
0
Comment
Question by:Jobeethemage
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
9 Comments
 
LVL 20

Expert Comment

by:José Méndez
ID: 40570977
Questions:

- The PC is configured with 10.10.0.1 as its def gateway?
- Can you ping 192.168.15.1 from the PC?
- Please copy the output of a tracert 192.168.15.1
- The output of a show ip route from the gateway
- Have you tried adding the <ip routing> command to the 2811?
0
 

Author Comment

by:Jobeethemage
ID: 40570995
----Yes, pc has 10.10.0.1 as gateway  

 -----    10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C        10.10.0.0/24 is directly connected, FastEthernet0/0.10
L        10.10.0.1/32 is directly connected, FastEthernet0/0.10
C        10.11.0.0/24 is directly connected, FastEthernet0/0.11
L        10.11.0.1/32 is directly connected, FastEthernet0/0.11
      192.168.15.0/24 is variably subnetted, 3 subnets, 2 masks
C        192.168.15.0/24 is directly connected, FastEthernet0/0.15
L        192.168.15.1/32 is directly connected, FastEthernet0/0.15
S        192.168.15.10/32 [1/0] via 192.168.15.0
Router#


pc can ping 192.168.15.1
0
 
LVL 20

Expert Comment

by:José Méndez
ID: 40571134
- Have you tried adding the <ip routing> command to the 2811?

or

if it already has that command, try negating it

no ip routing

play around with that and see
0
How Do You Stack Up Against Your Peers?

With today’s modern enterprise so dependent on digital infrastructures, the impact of major incidents has increased dramatically. Grab the report now to gain insight into how your organization ranks against your peers and learn best-in-class strategies to resolve incidents.

 

Author Comment

by:Jobeethemage
ID: 40571174
judging from the wireshark capture it seems like when I try to ping 192.168.15.10, it gets there but cant get back. does this help at all?
0
 
LVL 29

Expert Comment

by:Predrag Jovic
ID: 40572126
nice route on router :)
ip route 192.168.15.10 255.255.255.255 192.168.15.0
delete it

Data pool don't need option 150

pc can ping 192.168.15.1
What is 192.168.15.10 default gateway?
if gateway is 192.168.15.1
then what is output from
show int trunk
show vlan
0
 

Author Comment

by:Jobeethemage
ID: 40573137
Gateway for 192.168.15.10 is 192.168.15.1

Switch#show int trunk

Port        Mode             Encapsulation  Status        Native vlan
Fa0/1       on               802.1q         trunking      1

Port        Vlans allowed on trunk
Fa0/1       1-4094

Port        Vlans allowed and active in management domain
Fa0/1       1,10-11,15

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/1       1,10-11,15


Switch#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/25, Fa0/26, Fa0/27, Fa0/28
                                                Fa0/29, Fa0/30, Fa0/31, Fa0/32
                                                Fa0/33, Fa0/34, Fa0/35, Fa0/36
                                                Fa0/37, Fa0/38, Fa0/39, Fa0/40
                                                Fa0/41, Fa0/42, Fa0/43, Fa0/44
                                                Fa0/45, Fa0/46, Fa0/47, Fa0/48
                                                Gi0/1, Gi0/2, Gi0/3, Gi0/4
10   Data                             active    Fa0/2, Fa0/3, Fa0/4, Fa0/5
                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21
                                                Fa0/22, Fa0/23, Fa0/24
11   Management                       active
15   voice                            active    Fa0/2, Fa0/3, Fa0/4, Fa0/5
                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21
                                                Fa0/22, Fa0/23, Fa0/24
 --More--
0
 
LVL 29

Accepted Solution

by:
Predrag Jovic earned 500 total points
ID: 40573411
ip default-gateway 192.168.15.20 looks wrong, but that should not have any influence on problem.

Everything looks OK.
Routes are in routing table. Directly connected interfaces, there should not be any problem.
Host can ping router and router interface 192.168.15.1. Router can ping esxi server.
If exsi server is 192.168.15.10 I guess that that ip address should be in excluded addresses.

If subnet masks are OK, I don't see reason for configuration not to work.

The only thing that I can think of trying is to add subinterface for vlan 1 to Fa0/1

interface fastethernet 0/0.1
encapsulation dot1q 1 native
0
 

Author Comment

by:Jobeethemage
ID: 40573762
That last set of commands made it work.  Can you please explain to me why ?
0
 
LVL 29

Expert Comment

by:Predrag Jovic
ID: 40573896
Trunk needed native VLAN for trunk to work properly.
0

Featured Post

Forrester Webinar: xMatters Delivers 261% ROI

Guest speaker Dean Davison, Forrester Principal Consultant, explains how a Fortune 500 communication company using xMatters found these results: Achieved a 261% ROI, Experienced $753,280 in net present value benefits over 3 years and Reduced MTTR by 91% for tier 1 incidents.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Cisco Phone implementation supported backups 1 45
Distinguished username as email address 4 45
Certification Follow-up 2 63
hsrp tracking 2 13
PRTG Network Monitor lets you monitor your bandwidth usage, so you know who is using up your bandwidth, and what they're using it for.
This article will inform Clients about common and important expectations from the freelancers (Experts) who are looking at your Gig.
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

696 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question