?
Solved

Crystal Reports Stack overflow upon opening report(s)

Posted on 2015-01-26
14
Medium Priority
?
229 Views
Last Modified: 2015-02-02
Hello experts -

Whenever I attempt to open a Crystal Report, any Crystal Report (at least it seems that way), I receive a 'Stack Overflow at line: 779' or 'line: 1164'.  It started happening in the last few days when I started receiving Script Errors on the Start Page.  I have tried to do updates in Crystal and even updated Java on my computer thinking that might be the issue, but no dice.  I have Crystal 2008 Version 12.5.

Whenever I open the program I get 4 Script Errors - I thought that was just the web page portion of the start page not loading, but with the other error, I am not so sure.

Does anybody have any ideas?

-- Lisa
0
Comment
Question by:lcallah93
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 7
14 Comments
 
LVL 101

Expert Comment

by:mlmcc
ID: 40571611
Can you create new reports and open them?

Have you tried to uninstall Crystal and reinstall it?
If you don't know the key code you can get it from the title page when you run Crystal.

mlmcc
0
 

Author Comment

by:lcallah93
ID: 40572643
Yes - I can create reports, open existing reports, etc.  I just have to click 'yes' to keep running the scripts on the start page.  And then when I open the report and get the stack overflow error I just click OK on the 'message from webpage' and am good to go.

Is there a way to NOT display the webpage at startup?  Maybe that will solve my problem.

-- Lisa
0
 
LVL 101

Expert Comment

by:mlmcc
ID: 40572747
What scripts are running?

Is this when you open Crystal to design/modify a report? Or is this some application that displays reports?

mlmcc
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 

Author Comment

by:lcallah93
ID: 40572782
Yes - whenever I open Crystal.  I am fairly confident the issue is due to the web page on start up. I have attached the errors.  When I click on the first error, part of the lower start page show up, when I click on the second error, a little more shows up, etc. until the whole thing shows up after I click on the fourth error.  Then when I open any report I get the stack overflow error 'Message from webpage'.

I just uninstalled and re-installed hoping that would fix it, but that did not work.
0
 
LVL 101

Expert Comment

by:mlmcc
ID: 40573069
Is this a local install on your PC?

I have CR 2008 and it doesn't open with a web page.

How are you starting?
Is it
START MENU --> ALL PROGRAMS --> CRYSTAL REPORTS 2008 --> CRYSTAL REPORTS 2008

mlmcc
0
 

Author Comment

by:lcallah93
ID: 40573117
Yes - it's a local copy.  I have a shortcut on my desktop but that's how I get there.

Weird - right??
0
 
LVL 101

Expert Comment

by:mlmcc
ID: 40573335
It makes no sense.

Try running from the start menu as if the shortcut isn't there.
Is it any different?

mlmcc
0
 

Author Comment

by:lcallah93
ID: 40573372
Same errors...

Sigh...
0
 
LVL 101

Expert Comment

by:mlmcc
ID: 40573447
The only thing I see on the SAP/Crystal knowledge base involves using Crystal Enterprise (BO Enterprise) and the Crystal viewer which you aren't doing.

mlmcc
0
 

Author Comment

by:lcallah93
ID: 40573515
We do have a Business Objects server that I save reports to.  Maybe there is something there? Can you send me the link to the article you found?
0
 
LVL 101

Expert Comment

by:mlmcc
ID: 40573758
0
 

Accepted Solution

by:
lcallah93 earned 0 total points
ID: 40575211
My IT guy figured it out - I needed to upgrade to IE 11. The upgrade was disabled as we needed to stay on IE 9 due to other proprietary software but that is no longer a problem so all is well.
0
 
LVL 101

Expert Comment

by:mlmcc
ID: 40575253
That really doesn't make any sense since I have one machine still running IE8 and don't have issues with CR 2008.

If that solved it then great.  I wonder if there was a file extension setting that changed to point RPT files to Crystal rather than something else.

mlmcc
0
 

Author Closing Comment

by:lcallah93
ID: 40583557
My IT guy figured it out - I needed to upgrade to IE 11. The upgrade was disabled as we needed to stay on IE 9 due to other proprietary software but that is no longer a problem so all is well.
0

Featured Post

New benefit for Premium Members - Upgrade now!

Ready to get started with anonymous questions today? It's easy! Learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hot fix for .Net Crystal Reports 10.2.3600.0 to fix problems with sub reports running on 64 bit operating systems ISSUE: Reports which contain subreports fail with error "Missing Parameter Value" DEPLOYMENT SERVER OS: Windows 2008 with 64 bi…
There have always been a lot of questions related to when Crystal Reports evaluates report components (such as formulas, summaries, cross-tabs, charts, to name a few examples). Crystal Reports uses a two-pass reporting process to provide greater …
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…
In this video you will find out how to export Office 365 mailboxes using the built in eDiscovery tool. Bear in mind that although this method might be useful in some cases, using PST files as Office 365 backup is troublesome in a long run (more on t…
Suggested Courses
Course of the Month12 days, 17 hours left to enroll

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question