Solved

ie11 compatibility vertical scrollbar

Posted on 2015-01-26
22
304 Views
Last Modified: 2015-02-18
When setting compatibility mode in IE11 a vertical scrollbar displays at all times, enabled and disabled as required - even for www.google.co.uk. We have to use compatibility for our own site so how can this be removed ?
0
Comment
Question by:cehrnow
  • 8
  • 7
  • 7
22 Comments
 
LVL 50

Expert Comment

by:jcimarron
Comment Utility
cehrnow--
To what version of IE are setting the Compatibility Mode?  Is there really some content to see by scrolling down?
Is this something new?  If so run a System Restore to a time before it started.
0
 
LVL 37

Expert Comment

by:Bing CISM / CISSP
Comment Utility
better give a screenshot please?
0
 

Author Comment

by:cehrnow
Comment Utility
Screenshot attached - the vertical scrollbar is disabled
Thanks
ss.jpg
0
 
LVL 50

Expert Comment

by:jcimarron
Comment Utility
cehrnow--
Maybe your Zoom level is incorrect.
Click the gear at the top right and click Zoom.  Click on a lower zoom level, like 125%.

Is this happening on all sites you visit in IE?
0
 

Author Comment

by:cehrnow
Comment Utility
Yes, happens on all sites.
Zoom is set to 100%.
Also noticeable that the Google symbol is not displayed correctly.
0
 
LVL 50

Expert Comment

by:jcimarron
Comment Utility
cehrnow--
I suggest you uninstall and reinstall IE 11.

Control Panel|Programs and Features|View Installed Updates|in "Microsoft Windows" section scroll to Internet Explorer 11|right click |Uninstall.  If IE is your only browser, it might be best to download the installation files for IE11 before uninstalling.
http://windows.microsoft.com/en-us/internet-explorer/ie-11-worldwide-languages
0
 
LVL 37

Expert Comment

by:Bing CISM / CISSP
Comment Utility
if only some specific sites or pages need to be visited in compatibility view then you may simply add the sites in Compatibility View Settings of IE11 and access most sites in a normal way with the browser's default view.

see below the blog post giving the how-to details.

http://winaero.com/blog/how-to-enable-compatibility-view-in-internet-explorer-11-ie11/
0
 
LVL 37

Expert Comment

by:Bing CISM / CISSP
Comment Utility
if only some specific sites or pages need to be visited in compatibility view then you may simply add the sites in Compatibility View Settings of IE11 and access most sites in a normal way with the browser's default view.

see below the blog post giving the how-to details.

http://winaero.com/blog/how-to-enable-compatibility-view-in-internet-explorer-11-ie11/
0
 
LVL 37

Expert Comment

by:Bing CISM / CISSP
Comment Utility
sorry for the repeated post sent from my aged mobile phone.
0
 

Author Comment

by:cehrnow
Comment Utility
jcimarron - uninstalled but when reinstalling get the message that IE11 failed to install properly - damn it.
bbao - already aware of this.
0
 

Author Comment

by:cehrnow
Comment Utility
Have now reinstalled IE10 and this also displays the same issue.
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 37

Expert Comment

by:Bing CISM / CISSP
Comment Utility
> already aware of this.

so you do mean google.co.uk is not listed under Compatibility View but it does display like that even with an incomplete logo shown in the middle of Google UK's home page?
0
 

Author Comment

by:cehrnow
Comment Utility
Under IE10 google.co.uk displays okay. But if you then select compatibility (using the compatibility button) it then also displays as shown in the image previous attached.
0
 
LVL 50

Expert Comment

by:jcimarron
Comment Utility
cehrnow--
"Under IE10 google.co.uk displays okay. But if you then select compatibility (using the compatibility button) it then also displays as shown in the image previous attached. "
Well, don't use the Compatibility button.

Compatibility Mode in !E 10  allows you to choose what version of IE you want to use.
http://techathlon.com/internet-explorer-10-run-compatibility-mode/
It is slightly different in IE 11--reached by clicking F12.  Then click the drop down arrow for Document Mode.

Compatibility View in either IE 10 or IE 11 only uses IE7.
http://windows.microsoft.com/en-us/internet-explorer/use-compatibility-view#ie=ie-11-win-7
0
 

Author Comment

by:cehrnow
Comment Utility
As stated in the initial question we have to use compatibility for our own site. The point of mentioning google is to demonstrate that the issue it is not specific to our code.
0
 
LVL 50

Expert Comment

by:jcimarron
Comment Utility
Note the difference between Compatibility Mode  and Compatibility View.
Also can you use IE 10 instead of IE 11?
0
 

Author Comment

by:cehrnow
Comment Utility
We are now using IE10 with Compatibility View.
0
 
LVL 37

Accepted Solution

by:
Bing CISM / CISSP earned 500 total points
Comment Utility
> Under IE10 google.co.uk displays okay.
> (using the compatibility button) it then
also displays as shown in the image

that sounds like by design and that google home page is not supposed to be accessed that way.

you should only use the Compatibility View button when necessary (NOT always or by default), and use the Compatibility View Settings to manage the sites to be viewd in compatible mode.
0
 
LVL 50

Expert Comment

by:jcimarron
Comment Utility
cehrnow--
"We are now using IE10 with Compatibility View. "
I am not sure what you are telling us.  Is the problem fixed?
0
 

Author Comment

by:cehrnow
Comment Utility
Having uninstalled IE11 as suggested and reinstallation failing, a Windows Update has installed IE10 which displays exactly the same issue.
0
 
LVL 50

Expert Comment

by:jcimarron
Comment Utility
cehrnow--
Have you tried Resetting IE?
http://support.microsoft.com/kb/923737
0
 
LVL 37

Expert Comment

by:Bing CISM / CISSP
Comment Utility
i would guess if it is a site-specific issue... have you tried accessing some other sites to see if the issue persists?
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

If I have to fix slow responding website my first thoughts are server side optimizations: the database may not be optimized or caching is not enabled, or things like that. We often overlook another major part of our web application: the client. We o…
#Citrix #Internet Explorer #Enterprise Mode #IE 11 #IE 8
This Micro Tutorial will demonstrate how to add subdomains to your content reports. This can be very importing in having a site with multiple subdomains.
How to create a custom search shortcut to site-search Experts Exchange using Google in the Firefox browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch your Bookmark Menu: Press 'Ctrl +…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now