Skype Removal via WMIC

Hi, I am trying to remove previous versions of Skype via wmic,  but it always returns no instances found even though Skype is installed.

wmic product where "name like 'SkypeT 7%'" call uninstall /nointeractive
wmic product where "name like 'SkypeT 6%'" call uninstall /nointeractive

I check the product name via wmic product get name
and get value SkypeT 6.18
I also tried wmic product where name="Skype 6.18" call uninstall and it also returns no instance
I ran cmd via administrator

Any idea?
kwatt562Asked:
Who is Participating?
 
oBdAConnect With a Mentor Commented:
Can't reproduce that here (at least with some other software, as I don't have Skype installed).
Are you testing this directly in a command prompt or in a batch file? The additional percent sign would be required in a batch to escape the real one.
Do any of the following work:
wmic product where "name like 'SkypeT 6%%'" get name
wmic product where "name like 'Skype%%'" get name
wmic product where "name like 'SkypeT 6.18'" get name

Open in new window

0
 
oBdACommented:
I guess you're trying that inside a batch script? Double up on the wildcard percent sign (and is the T at the end of Skype really there?):
wmic product where "name like 'SkypeT 6%%'" call uninstall /nointeractive

Open in new window

0
 
kwatt562Author Commented:
Thanks, I tried with double wildcard, but get the same result. Its named SkypeT 6.18 when I scan products via wmic
0
 
oBdACommented:
On a side note: did you copy and paste the "SkypeT"?
Could it be that the "T" is not a capital T, but a (r) or (tm) symbol or some such, that got garbled in the output because of the code page?
Does the "T" look like a T when you paste it into a Word document or Notepad and add a "real" T next to it?
How does the name look in Control Panel > Programs and Features?
0
 
kwatt562Author Commented:
thanks for the help
wmic product where "name like 'Skype%%'" get name - returned value skypeT 6.18
so wmic product where "name like 'Skype%%'" call uninstall /nointeractive uninstalled version 6.18 and I did a test with version 7 which also worked.
0
All Courses

From novice to tech pro — start learning today.