Solved

Force Windows to prompt for credentials while accessing share.

Posted on 2015-01-27
5
1,144 Views
Last Modified: 2015-02-13
We want to map a network share for our board room but we want it so that any time a user wants to access this network drive they can login with their own credentials just like the attached picture shows. This computer is using Windows 7 and is not on our domain.
3.png
0
Comment
Question by:OrbusLLC
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
5 Comments
 
LVL 95

Expert Comment

by:John Hurst
ID: 40573028
Open Windows Explorer, right click on Network, choose Map Network Drive.

The screen you want (near enough) comes up. Add the server name, authenticated user name and allow it to prompt for password. This will work (I use the method myself on my non-domain machine at clients).
0
 

Author Comment

by:OrbusLLC
ID: 40573098
After mapping the drive and relogging into the local profile I get an error or a prompt to confirm the password of the user that I used to map the drive. It shouldn't be either of these I just want it to prompt for a username and password so when user access this network share all they have to do is type domain\their-username and their password.
error.jpg
prompt.jpg
0
 
LVL 95

Expert Comment

by:John Hurst
ID: 40573125
There should be a box in the Map Network Drive window to remember the share. Try checking that box.

The Map Network dialogue is fixed by Microsoft and only has the options on the screen.
0
 
LVL 95

Expert Comment

by:John Hurst
ID: 40573163
I have attempted to provide a solution on your terms here. I know it works, because I use it.

Another way, which I find preferable is to build a script:

NET USE Z: /Delete
NET USE Z: \\server\foldershare /user:username  

Place this is a file on the desktop named connect.bat.

The user double clicks the file, is prompted for password, enters password and connects.

This works as well.
0
 
LVL 5

Accepted Solution

by:
Aaron earned 500 total points
ID: 40573165
You can create a shortcut on the desktop to the file path. Go to the location then right click the folder you want to have access to and say create desktop shortcut. When you select it then it should prompt for access. This way it shouldn't try to map it... I would also make sure to tell people not to save credentials.
0

Featured Post

Free eBook: Backup on AWS

Everything you need to know about backup and disaster recovery with AWS, for FREE!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Learn how ViaSat reduced average response times for IT incidents from 10 minutes to 30 seconds.
Are client relationship the only driver of a successful MSP? While important, client relationships are only one component. Learn how else MSPs can broaden their horizon and differentiate themselves.
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…
The viewer will learn how to successfully download and install the SARDU utility on Windows 8, without downloading adware.

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question