rename a wildcard SSL certificate in IIS

We have a working wildcard SSL certificate.         *.cissltd.com     i exported the PFX file from a working server and imported on another server.

We are trying to use host headers on the second server - and somehow the wildcard "*" prefix in the name got dropped....any idea on how to rename with the wildcard prefix?
CISS-cert.rtf
LVL 1
bensonwalkerAsked:
Who is Participating?
 
it_saigeDeveloperCommented:
I can validate the certificate linked to that site:Capture.JPG-saige-
0
 
it_saigeDeveloperCommented:
Wild card prefixes are generated when you add the certificate to a site.Capture.JPGCapture.JPGThe name you are seeing:Capture.JPGIs just the friendly name and does not affect the certificates validity.  It's sole purpose is to allow for you to easily identify the certificate when choosing to bind it.

-saige-
0
 
bensonwalkerAuthor Commented:
I believe you are correct - maybe it is a microsoft IIS issue - but host headers don't work without that friendly name having the "*." in front of it..........can I just readd (import_) the certificate again and rename in the process?  the problem is I don't think importing from IIS give you the chance to name the certificate....maybe I need to re-export and then re-import?
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
it_saigeDeveloperCommented:
Importing/Exporting does not give you the option to rename or change the certificate in anyway.  This would invalidate the certificate.

What does the certificate look like on the original server?  When you exported the certificate, did you export it as a PFX?

-saige-
0
 
bensonwalkerAuthor Commented:
yep, the original server has the wildcard in the name. export and import through PFX
0
 
bensonwalkerAuthor Commented:
you can see the original server in the RTF file I posted
0
 
it_saigeDeveloperCommented:
You may be correct that it is an IIS issue, but that should not preclude you from assigning the host header value in the hostname text box.

Have you bound the certificate to a new site and not been able to validate the certificate when accessing the new site via HTTPs???  

-saige-
0
 
bensonwalkerAuthor Commented:
yep, the cert works outside of IIS host headers.  https://www.cissltd.com   is a site under that cert
0
 
bensonwalkerAuthor Commented:
right, we seem to have an IIS bug with host headers.  headres only work if the cert name is *.cissltd.com .....now, how can I rename it?
0
 
it_saigeDeveloperCommented:
Lets try using the Certificate Console instead of IIS (something may have been lost in translation ;) )...

https://www.geocerts.com/support/migrate_iis

Comodo even says to do this:

https://support.comodo.com/index.php?/Knowledgebase/Article/View/678/0/exporting-and-restoring-a-pfx-file-to-iis

-saige-
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.