?
Solved

How to fix error: Remote host said: 550 Access denied - Invalid HELO name (See RFC2821 4.1.1.1)

Posted on 2015-01-28
6
Medium Priority
?
1,530 Views
Last Modified: 2015-02-03
I have received the error: Remote host said: 550 Access denied - Invalid HELO name (See RFC2821 4.1.1.1)  as well as simply error: Remote host said: Invalid HELO string (mailserver).

I use Outlook 2013 to send the messages and have it checked that my outgoing mail server uses SMTP authentication checked as well as use same settings as incoming mail.

I use SmarterMail on my mailserver also.

How do I fix this error so all of my messages get to their intended recipients?
0
Comment
Question by:lkretzBK
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
6 Comments
 
LVL 3

Accepted Solution

by:
Richard Amiss earned 1000 total points
ID: 40575893
All mail servers must provide a valid ehlo.  Here is how to set this up SmarterMail:

- Login as admin
- Go to: Settings -> General Settings -> Server Info
- Set the hostname to your valid SMTP mail server address. (ie mail.yourdomain.com)

Also: Make sure you have your ISP create a Reverse DNS PTR record for the server ip to resolve back to mail.yourdomain.com

Richard
0
 

Author Comment

by:lkretzBK
ID: 40575937
I have a feeling that this was never set up correctly.

When I log in as administrator and go to the server info - there is a message telling me there should be a fully qualified domain name.  So...maybe I need to start all over again? Does the information look correct in the attached screenshot?

I'm not sure what the qualifying mail address would be.
GeneralSettingsTab.jpg
0
 
LVL 38

Assisted Solution

by:Hypercat (Deb)
Hypercat (Deb) earned 1000 total points
ID: 40575964
Richard stated you need the fully qualified domain name in that field.  This would be the full server.domain.com name that external email servers use to send to your mail server. So, if your domain is "domain.com" and your external DNS zone has a host and an MX record that point to "mail" for your email server, then the FQDN in that field would have to read "mail.domain.com."  You have to know what that external name is before you can properly complete that field.
0
 

Author Comment

by:lkretzBK
ID: 40576071
Thank you. I believe I have the setting correct now. Thank you so very much for your assistance. The answer was to have mail.domainname.com
0
 

Author Comment

by:lkretzBK
ID: 40577355
Because I felt they both had the correct answer - one was just a bit more detailed but they were the same - to me anyway.
0

Featured Post

Does Your Cloud Backup Use Blockchain Technology?

Blockchain technology has already revolutionized finance thanks to Bitcoin. Now it's disrupting other areas, including the realm of data protection. Learn how blockchain is now being used to authenticate backup files and keep them safe from hackers.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

As tax season makes its return, so does the increase in cyber crime and tax refund phishing that comes with it
As cyber crime continues to grow in both numbers and sophistication, a troubling trend of optimization has emerged over the last year.
This Experts Exchange video Micro Tutorial shows how to tell Microsoft Office that a word is NOT spelled correctly. Microsoft Office has a built-in, main dictionary that is shared by Office apps, including Excel, Outlook, PowerPoint, and Word. When …
CodeTwo Sync for iCloud (http://www.codetwo.com/sync-for-icloud?sts=6554) automatically synchronizes your Outlook 2016, 2013, 2010 or 2007 folders with iCloud folders available via iCloud Control Panel. This lets you automatically sync them with…
Suggested Courses

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question