Windows not assigning Drive letter

For some reason my system no longer automatically assign's the next available drive letter when I plug a USB device into the system, it just does not show up in Computer.  I have to go into Disk Management and manually assign it a drive letter that is not in use.  My system is Windows 7 Pro, I have tried running diskpart automount enable this did not resolve issue.
ManieyaK_Citrix Systems / Network AdminAsked:
Who is Participating?
 
VB ITSSpecialist ConsultantCommented:
Just to confirm, you ran the the following commands in an elevated Command Prompt window?
diskpart
automount enable

Open in new window


Also try running mountvol.exe /e
0
 
ManieyaK_Citrix Systems / Network AdminAuthor Commented:
That it is correct I ran Diskpart automount enable with elevated rights as well as mount.exe /e no changes.
Also I ran sfc -scannow with elevated rights no change.  The only way i can get drive to show up in computer is to assign a static letter.
0
 
VB ITSSpecialist ConsultantCommented:
Might be worth updating the drivers for your USB controller as a next step.
0
 
ManieyaK_Citrix Systems / Network AdminAuthor Commented:
Okay think I  figured out what the issue was, I had a Mapped network drive that was disconnected which was assigned drive letter G, which every time I inserted a USB device it was also assigning it Drive letter G.  I disconnected that network drive inserted a USB device it was assigned next available mount point.

Thank You for the quick reply's   :)
0
 
ManieyaK_Citrix Systems / Network AdminAuthor Commented:
Thanks again
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.