Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Internal Server Error when saving document unchanged

Posted on 2015-01-28
5
Medium Priority
?
91 Views
Last Modified: 2015-01-31
I edit a file in filezilla and when I upload it i get:  
Internal Server Error

What could cause this?  The website works perfectly.  I
I open the file locally and make no changes to it
I save it and filezilla saves the unchanged file to the server.
I go to that same url and it's not working.  

Is there anything that might cause this?
0
Comment
Question by:vrosas_03
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 2

Assisted Solution

by:Uwe Degenhardt
Uwe Degenhardt earned 2000 total points
ID: 40577315
This could be caused by a permission problem.
Did you have a look in the Webserver-Logfile ?
0
 

Author Comment

by:vrosas_03
ID: 40578430
If I change the index.php to index.html it works.

there are php pages on there already though but they only work if they remain on the server.  I can change the name and change it back and they will still work.

I checked the permissions and they are the same for pages that work as for pages that don't.  
What directory would the log file be in?  
Would it be in the site folder in a multisite website.  
Which directory:
var
usr
tmp
sys
srv
sbin
bin
mnt
?
There are other directories it could be in but if you know a common directory where the log file would be located that would help a lot.
0
 
LVL 2

Accepted Solution

by:
Uwe Degenhardt earned 2000 total points
ID: 40578518
Check in /etc/httpd/conf/... (CentOS) or in /etc/apache2/sites-enabled/000-default (default) (Debian/Ubuntu)
if you can see any virtualhost giving you the actual physical document-root directory
either in: /var/www/ or /home/... or /srv/www
Most of the times (95%) it is somewhere in these three directory trees.
If you have the DocumentRoot path it should be solvable. If you have no virtualhosts go and check apache2.conf or http.conf
There you can the the webservers document-root as well.
0
 

Author Closing Comment

by:vrosas_03
ID: 40581139
I think it's caused by being the wrong owner.   The files i upload have a different owner than the ones that are there already.
0
 
LVL 2

Expert Comment

by:Uwe Degenhardt
ID: 40581936
Yes. Thank you for your points. Then try to change the umask and/or the standard user of the ftp-user logging in.
Also add the user to the group-file under /etc/group
After that begin with umask 022 and the new ownership delivery in the group and all should be fine.
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Thoughout my experience working on eCommerce web applications I have seen applications succumbing to increased user demand and throughput. With increased loads the response times started to spike, which leads to user frustration and lost sales. I ha…
Without even knowing it, most of us are using web applications on a daily basis.  In fact, Gmail and Yahoo email, Twitter, Facebook, and eBay are used by most of us daily—and they are web applications. We generally confuse these web applications to…
This video teaches users how to migrate an existing Wordpress website to a new domain.
Learn how to set-up custom confirmation messages to users who complete your Wufoo form. Include inputs from fields in your form, webpage redirects, and more with Wufoo’s confirmation options.

610 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question