Windows 2008 having to use FQDN??

I am working on moving an application from a Windows 2003 32bit server to a Windows 2008 R2 64bit server.  I have pretty much everything working, but I am having issue with a web service getting DNS errors.  I have to following url:

http://transflo/Transflo.WebService.Wse3/TransfloWS-wse3.asmx

On the Windows 2003 server the url resolves to the web service page perfectly.

If I use the same url on the Windows 2008 R2 server I get the following error:

"Network Error (dns_server_failure)

 Your request could not be processed because an error occurred contacting the DNS server.  
The DNS server may be temporarily unavailable, or there could be a network problem.  "

If I changed the url to http://transflo.csxt.ad.csx.com/Transflo.WebService.Wse3/TransfloWS-wse3.asmx

the page will open successfully, but the application itself doesn't like that url (maybe a check back or a hard coded url).  Is there a way to get around having to use the FQDN for this url?

I tried looking at the DNS suffixes and they look ok,
I can get the translo name to resolve via nslookup, just can't browse the page...

Any ideas?
LVL 6
Chad FranksSenior System EngineerAsked:
Who is Participating?
 
Will SzymkowskiConnect With a Mentor Senior Solution ArchitectCommented:
The only time I have seen this issue is when the URL is not in the trusted sites or in the local intranet. You might been to check the settings on your web server.

Will.
0
 
Will SzymkowskiSenior Solution ArchitectCommented:
Have you tried adding the server URL to trusted sites in Internet options? Also can you ping the server via Netbios name without using FQDN?

Will.
0
 
Chad FranksSenior System EngineerAuthor Commented:
I can ping it just fine via netbios
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
Will SzymkowskiSenior Solution ArchitectCommented:
Have you tried adding the server URL to trusted sites or local intranet?

Will.
0
 
Chad FranksSenior System EngineerAuthor Commented:
how would I add that to the site to zone list?  *transflo or something else?
0
 
Will SzymkowskiSenior Solution ArchitectCommented:
You would add the http://servername/...

Will.
0
 
Chad FranksSenior System EngineerAuthor Commented:
I put it in trusted sites and I am still getting the same DNS error message...
0
 
Chad FranksSenior System EngineerAuthor Commented:
I also tried to put it in the local intranet and I am still getting the same error.
0
 
Chad FranksSenior System EngineerAuthor Commented:
Anyone know?  Is there a GPO setting that doesn't allow DNS resolution via http://servername  ??
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.