?
Solved

Windows 7 dismounting laptop optical drive instead of ejecting disc

Posted on 2015-01-29
4
Medium Priority
?
225 Views
Last Modified: 2016-11-23
I'm working with a Dell Latitude E6520, and I'm running into a strange issue. Like many laptops, it has a built-in optical drive, but Windows 7 seems to be treating it like a removable storage device. If we try to eject the disc in the drive, the drive itself disappears. We then have to use a paper clip to pop out the tray and remove the disc, then reboot the PC in order for it to detect the drive again. I also noticed that the device is listed under Safely Remove Hardware. If a disc is in the drive, it will list both the drive and the disc as being removable, but dismounts the drive no matter what you select.

We had Dell replace this drive once already, but it is still doing the same thing. The strange thing is, I ran tool from Dell that runs a complete diagnostic on the computer, and one of the tests it ran was to try opening the drive. When it got to that step, the drive opened without issue.

Has anyone run into a similar issue? If so, how did you go about fixing it? I see some third-party utilities that I could install to work around this issue, but the end user would like to try and get it working as intended if possible. Thank you.
0
Comment
Question by:PIMSupport
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
4 Comments
 
LVL 47

Expert Comment

by:noxcho
ID: 40577518
In My Computer - right click on DVD-ROM - Properties - Hardware - select your DVD-ROM - at the bottom Properties - Details. What is there selected? Properties or removal policy?
0
 
LVL 47

Accepted Solution

by:
noxcho earned 2000 total points
ID: 40577553
Look this trick which describes how to make a workaround: http://en.community.dell.com/support-forums/disk-drives/f/3534/t/19446583

Also try another trick, go to BIOS and switch the HDD mode from AHCI to SATA or IDE compatible.
0
 

Author Closing Comment

by:PIMSupport
ID: 40577841
The link you posted wound up being the solution. The properties for the device said the removal policy was set to 00000002 (which I found out was the EJECTSUPPORTED flag), but in the registry it was set to 0x00000006 (which meant it had the EJECTSUPPORTED and REMOVABLE flag set). Changing that to 0x00000002 allowed us to eject the disc without removing the drive.

Thanks for your help!
0
 
LVL 47

Expert Comment

by:noxcho
ID: 40578151
Glad to hear that I could help.
Take care
Nox
0

Featured Post

The Eight Noble Truths of Backup and Recovery

How can IT departments tackle the challenges of a Big Data world? This white paper provides a roadmap to success and helps companies ensure that all their data is safe and secure, no matter if it resides on-premise with physical or virtual machines or in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The business world is becoming increasingly integrated with tech. It’s not just for a select few anymore — but what about if you have a small business? It may be easier than you think to integrate technology into your small business, and it’s likely…
A look at what happened in the Verizon cloud breach.
This Micro Tutorial will give you a basic overview of Windows Live Photo Gallery and show you various editing filters and touches to photos you can apply. This will be demonstrated using Windows Live Photo Gallery on Windows 7 operating system.
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…
Suggested Courses

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question