WBADMIN Fails to backup Exchange 2010 Databases

Windows 2008 R2 64 Bit Server
Exchange 2010 Enterprise 64 bit server

Using MKSBACUP as a Frontend to WBADMIN

Problem is that all of a sudden it is not backing up my exchange database files

Backup JOB 1  backups up only D:\Program Files\Microsoft\Exchange Server\V14\Mailbox folder

Backup Job 2 backups up everything except for that folder.

Both backup jobs give same errors.

So one thing Backup Job 2 exclude function is not working.

The errors are these  see the attached files

The backup ini files from mksbackup  see atcched files

Ran VSSADMIN list writers

All came back with no error
LVL 23
Thomas GrassiSystems AdministratorAsked:
Who is Participating?
Carol ChisholmConnect With a Mentor Commented:
"The reason is that most of these large drives have a 4K sector size, rather than the older 512 byte sector size. You can get a patch for Windows 7 and Windows Server 2008 R2 that fixes most problems, but it does not fix the backup issue."

Thomas GrassiSystems AdministratorAuthor Commented:
Thanks for the info

Some more info

This all started happening after I upgraded to a 2 TB USB storage device for the backups

I checked I have KB982018 the fix for the sector size differences.

Also I tried running WBADMIN using the GUI selecting just the files I want

I get the same errors as I do with my scripts from mksbackup. So it is not my scripts.

I had a 500 GB drive which worked fine but ran out of space fast.

I have another Windows 2008 server with same setup but only has a 1TB drive

So I am thinking I have a bug with large usb drive

Any thoughts.
Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

Thomas GrassiSystems AdministratorAuthor Commented:

Update 2

Found that "Microsoft Exchange Server Extension for Windows Server Backup" service was not started. Changed to Automatic. Started service.

Add this to the registry

Dword EnableVSSWriter   value 0 zero


Found that the external usb drive had 4096 Bytes Per sector

See attached the F: drive is the 2TB drive   G: drive is a 500 GB drive

So I changed the output to point to the 500 GB drive.

Then I started the Windows Server Backup GUI
Selected d:\Program Files\Microsoft\Exchange Server\V14\Mailbox

The job ran to success completion.

So what's up with Large Drives on Windows 2008 Server?  the Hotfix KB982018 was already installed

Thomas GrassiSystems AdministratorAuthor Commented:

Thanks for responding

I read that article already also As I mentioned in my post I applied the patch and found that it was already installed.

Any further thoughts?

Carol ChisholmCommented:
It will never work on 2008 R2.
You have to upgrade.

I have wasted a lot of time trying.

I really advise 2012 R2. It is a really good OS and the backup interface is much improved (add new media from the GUI and so on).
Thomas GrassiSystems AdministratorAuthor Commented:
Not an option,

Just installed this server not going thru another upgrade at this time.

This is a production email server.

I have another windows 2008 server backing up with not problem.

If 2008 can not backup to a 2 tb drive then I can get around that with another method.

The first post has errors listed that is the real problem here  not the 2tb drive issue that is another issue.

Lets see if we can figure out how to back up Exchange 2010 on a windows 2008 server.
Carol ChisholmCommented:
I would first try to a local disk and look for error with log files.
Carol ChisholmCommented:
With 2008 and 2008 R2 I had nothing but grief with backup to large drives. It was erratic.

Here is a long thread I participated in along time ago about all the whys and wherefores and a snip of a good summary post. I really doubt that now (2015) you can actually buy a drive that will work reliably, Even in 2011 it was hard going.


"For anyone new to this thread, read this first
Basically there are two things that could be causing your backup to fail if it is a removable HD.  I am going to save you the trouble of reading this whole thread and catch you up.  

1.     Your removable HD has bloatware (crapware, extra software, custom bios, etc etc…) that prevents windows from seeing it for what it should be (a removable HD).  When you plugged your disk in did you also get a new CDROM drive also?  Did you install some special software in order to get to the disk?  Encryption software maybe?  Your disk is not going to work.  Stop reading any further and return it.  Don’t feel bad.  Chances are you didn’t know it was going to be that way and the manufacturer did a poor job of telling you about it before you purchased it. Return your drive and go to this site where there is a nice list developing that tracks disks that have been tested:  http://social.technet.microsoft.com/wiki/contents/articles/1780.aspx

2.     Your disk has more than 512 bytes per physical sector.  If it new and large (like 1TB or more) it probably has 4096 bytes per physical sector.  The windows backup software was designed to work with disks that have 512 bytes per physical sector.  Again, don’t feel bad about getting the wrong disk.   I did a quick check of about 10 disks online and couldn’t find a single one where the manufacturer listed the bytes per physical sector in the specs anywhere.  Also, until you have this problem, you will probably never know about the 512 byte design issue.

 Anyhow, now that you do know about it, you can try to fix it using the Microsoft hotfix here: http://support.microsoft.com/kb/982018 which adds support for 4096 byte disks to server 2008 and 2008 R2 (and any SBS versions based on them).  Once the hotfix is applied and you reboot, try assigning the removable HD a drive letter and formatting it.   Once that is done you can check to see if the disk is going to work by using fsutil.  Here is an example showing the command line and the result:

 C:\Users\administrator>fsutil fsinfo ntfsinfo f:
 NTFS Volume Serial Number :       0x2ebc529bbc525d81
 Version :                         3.1
 Number Sectors :                  0x000000000e8b4eff
 Total Clusters :                  0x000000000e8b4eff
 Free Clusters  :                  0x000000000e8aa566
 Total Reserved :                  0x0000000000000000
 Bytes Per Sector  :               4096
Bytes Per Physical Sector :       <Not Supported>
Bytes Per Cluster :               4096
 Bytes Per FileRecord Segment    : 4096
 Clusters Per FileRecord Segment : 1
 Mft Valid Data Length :           0x0000000000100000
 Mft Start Lcn  :                  0x00000000000c0000
 Mft2 Start Lcn :                  0x0000000000000002
 Mft Zone Start :                  0x00000000000c0000
 Mft Zone End   :                  0x00000000000cc820
 RM Identifier:        42643033-B240-11E0-9765-3C4A92E16BD6

 You see where it says “Bytes Per Physical Sector:” and the result was “<Not Supported>”?  That means this disk will not work with the backup even though the hotfix is installed.  Some disks don’t report their bytes per physical sector correctly and therefore won’t work.   If you get one that does report 512 or 4096 you should be OK.  

 Btw, if you do find one that works, be kind and add it to the list of drives here: http://social.technet.microsoft.com/wiki/contents/articles/1780.aspx with a comment about your test setup and results.

This thread includes a solution which might help you
Thomas GrassiSystems AdministratorAuthor Commented:

1. Not running SBS

2. I have moved the backups to a 500 GB drive with 512 bytes per sector

So Again I am asking about the errors I first reported in my original post

I am not concerned about the large drive issue at this point

I was just seeing what that might be.

Re read the original post with the attached files those are the event log error messages I get when backing uyp the exchange database.
Carol ChisholmCommented:
(SBS uses exactly the same WBADMIN and DPM uses VSS)

You are giving us the WADMIN errors, WBADMIN is bad at reporting what the underlying errors are.

Event ID 9782 (One of the backup files could not be created.). Please review the event details for a solution, and then rerun the backup operation once the issue is resolved
The backup did not complete successfully, and no log files were truncated for this database

We need more information in what the error is. It is most probably either an Exchange issue (probably missing or corrupted logfile) or a VSS writer issue.

You need to look more in the events log on your server to find out which one it is. Then you at least know what you are trying to fix.

Thomas GrassiSystems AdministratorAuthor Commented:

Went thru my system and application logs today,

Also found two other errors and warnings.

They are see attached.

Nothing to do with this issue I believe.

The article you posted looked promising got to the step where it said install hotfix kb980794

Download the hot fix an attempted to install the hot fix got message saying this fix is not applicable to your system.

Windows 2008 R2 Standard

My Exchange is SP1 I am thinking to apply SP3

Carol ChisholmCommented:
Definitely do SP3.
Can't see your errors attached.
Is your Windows fully patched?
Thomas GrassiSystems AdministratorAuthor Commented:

oops forgot to attach see the attached now

Yes Windows 2008 updates are current I use WSUS Server to maintain all my servers and computers.
Thomas GrassiSystems AdministratorAuthor Commented:

Just updated Exchange Server 2010 to SP3 Rollup 8

Hoping the backup runs today scheduled to run at 8 PM EST

Will post results.
Thomas GrassiSystems AdministratorAuthor Commented:

Backup ran tonight failed same errors.

Not sure where to go from here
Carol ChisholmCommented:
Did you do the VSS diagnostic? and check the system events as well for VSS or more detailed backup errors.

Run a manual backup using the GUI of Exchange and see where it breaks? them look closely in all the logs at the appropriate time.
Thomas GrassiSystems AdministratorAuthor Commented:


Had to hold on this for a couple of days lost the external usb drive the other day hardware error.

New drive will be here tomorrow.

Do not get any event errors other than the ones I posted originally.

The VSS shows all are OK

Will try manual backup after drive arrives.
Carol ChisholmCommented:
OK; I think manual backup will show more detail. If you have disk space do it to disk.
Thomas GrassiSystems AdministratorAuthor Commented:

Update.  I finally received a 1 TB drive that has 512 bytes per sector. No Windows 2008 server backup recognizes the drive.

I ran a manual backup using the Windows Server Backup GUI interface.  The job ran successfully.

I then created a scheduled job.

Found the task went into the  properties action tab

%windir%\system32\wbadmin.exe start backup -templateID:{7608db45.................} -quiet

Search all over can not find templateID would love to know the complete command line that this ran

Do you have a command line version that I can try?

How can we find the -templateID file?
Carol ChisholmCommented:
First: Very glad your Exchange is OK and can be backed up manually.
Can you confirm that It backed up to the external drive?

I have got to go out now, but  I will get back to you later today. I never used a templateID, just the standard command line parameters.
My guess is the template is a combination parameters.

Thomas GrassiSystems AdministratorAuthor Commented:

Thanks for your help on this.

WBADMIN just needs to be upgraded and fixed for Windows 2008 Server.
Do not understand why a Microsoft product will not backup Microsoft products with out a problem.

I decided not to waste any more time on this topic since all of us have better things to work on.

I found a third party product that's works and works very well no errors when the backup runs.
That product is BackupAssist it Has an Exchange Addon which backs up each individual mailbox to a pst file very cool.

Again thanks for your help on this
Carol ChisholmCommented:
In 2012R2 WBADMIN is much better, I think MS wanted to get out of this market (like TMG) but then realised they had to provide something that worked. But it took 3 tries, as usual.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.