Solved

RD Connection Broker for High Availability could not create database error

Posted on 2015-01-29
10
785 Views
Last Modified: 2015-02-06
Server Manager, Remote Desktop Service, RD Connection Broker, Configure High Availability

Configure:
- Database connection string:
- Folder to Store Database Files:
- DNS Round Robin Name

Goes to the next screen nothing above fails at this point. Hit next and get the following error:
Configure RD
0
Comment
Question by:WORKS2011
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 2
  • 2
  • +1
10 Comments
 
LVL 81

Expert Comment

by:David Johnson, CD, MVP
ID: 40579116
does the database server have tcpip/named pipes enabled?  (sql configuration manager) does that account have login properties?
0
 
LVL 24

Expert Comment

by:VB ITS
ID: 40579122
Are you trying to connect to remote SQL server? Please provide the DB connection string just as well or at the very least the syntax you are using.

Have you confirmed that you have met all the prerequisites for High Availability for the RD Connection Broker role?

Taken from this following Microsoft blog post: http://social.technet.microsoft.com/wiki/contents/articles/10390.deploying-rd-connection-broker-high-availability-in-windows-server-2012.aspx
- A Microsoft SQL Server with write permissions granted to all RD Connection Broker servers that will be part of the deployment
- The Microsoft SQL Server Native Client is installed on all RD Connection Broker servers that will be part of the deployment
- Static IP addresses have been assigned to all RD Connection Broker servers that will be part of the deployment
- DNS resource records with a single DNS name have been created for all RD Connection Broker servers that will be part of the deployment
- Also note that the SQL Server must be at least SQL Server 2008 R2.
Also make sure that your SQL permissions and firewall is configured correctly: http://social.technet.microsoft.com/wiki/contents/articles/10393.rd-connection-broker-ha-sql-permissions.aspx
0
 
LVL 17

Author Comment

by:WORKS2011
ID: 40579401
Hi VB ITS, I've done everything in the documentation you mentioned.

It's interesting I didn't pass the following at first:  Configure: Database connection string, Folder to Store Database Files, DNS Round Robin Name until I removed SQL completely and reinstalled.

After doing so I can now get past the above screen but it fails with the screen shot.

Seems like something with SQL to me.
0
Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

 
LVL 50

Expert Comment

by:Vitor Montalvão
ID: 40579930
There's no error log? Or at least an entry in the Event log?
That error message is too generic and we need to get something more to point you to the right direction.
0
 
LVL 24

Expert Comment

by:VB ITS
ID: 40580038
You'll need to provide more information as Vitor has mentioned above. Can you please at least confirm that you have a dedicated SQL server running at minimum SQL Server 2008 R2?

Have you verified that your environment meets the minimum requirements outlined in my previous comment?
0
 
LVL 17

Author Comment

by:WORKS2011
ID: 40580214
Yes all the requirements are met and tried SQL Server 2008 and 2012 R2.
0
 
LVL 17

Author Comment

by:WORKS2011
ID: 40580228
Dell support has been working on it for hours, appears it may be something in the registry and at this point a fresh install is likely the way to go. The server was taken out of the box four days ago, it's this new and nothing is on it. Problem is we really need the remote access.

Others have had this problem with the same results (not allot of information reporting back). Others that had this problem didn't report a solid way to fix which doesn't help much. When I say "Others" I mean the few posts I found.
0
 
LVL 81

Expert Comment

by:David Johnson, CD, MVP
ID: 40582349
it shouldn't be creating a database mssqlserver but a database ON servername\mssqlserver. This is the default instance, if you changed the instance name then it would be server\instancename
0
 
LVL 17

Accepted Solution

by:
WORKS2011 earned 0 total points
ID: 40582941
Hi David, understand and tried all these things. Found there was something in the NIC and registry that was causing an issue.
0
 
LVL 17

Author Closing Comment

by:WORKS2011
ID: 40593228
Thank you for all the help, greatly appreciated.
0

Featured Post

Online Training Solution

Drastically shorten your training time with WalkMe's advanced online training solution that Guides your trainees to action. Forget about retraining and skyrocket knowledge retention rates.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Ever wondered why sometimes your SQL Server is slow or unresponsive with connections spiking up but by the time you go in, all is well? The following article will show you how to install and configure a SQL job that will send you email alerts includ…
Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
Via a live example, show how to backup a database, simulate a failure backup the tail of the database transaction log and perform the restore.
Using examples as well as descriptions, and references to Books Online, show the documentation available for datatypes, explain the available data types and show how data can be passed into and out of variables.

740 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question