Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Need help with Apache SSL configuration

Posted on 2015-01-30
2
Medium Priority
?
123 Views
Last Modified: 2015-01-31
Hello Experts,

I have installed Owncloud on a server and tried to install GoDaddy Wildcard SSL.

http works just fine but https isn't. When i try to open website using https, browser throws an error that says -

‘ssl_error_rx_record_too_long’

I tried searching for a solution but nothing seems to be working.

I need a Step-by-step guide as available documentation leads to confusion.

I am wondering which file to edit after all, some docs says its httpd.conf, some says its ssl.conf and some says its default and default-ssl.conf. too much confusion.

I am using Apache 2.2 on Ubuntu 12.04 LTS.  Any definite help would be greatly appreciated.

Thank you.

Best Regards
Raghav.
0
Comment
Question by:Raghav
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 64

Accepted Solution

by:
btan earned 2000 total points
ID: 40580935
Ref - https://www.digicert.com/ssl-support/apache-fix-common-ssl-errors.htm#SSLRecordLength

a) This error often occurs because SSL traffic is not set up correctly on the server that you are trying to secure. For example, the DNS is not correct in the DNS name on your VirtualHost.
Or
b) A mismatch between the IP address being published for the domain (e.g. in HOSTS file) and the IP address in Apache's httpd-ssl.conf file (e.g. 127.0.0.14 vs. 127.0.0.1). When the browser tried to do an https: type SSL connection, they were trying on port 127.0.0.1:443 instead. Change HOST to match the IP address in .conf
Or
c) This error can also occur if you have a misconfigured proxy that doesn't allow you to do an SSL handshake on port 443 correctly. The way to test this is to try connecting to the site from outside of your network with a few different web browsers and see if you still receive the error. If you do not receive the error the proxy is probably misconfigured.
0
 
LVL 7

Author Closing Comment

by:Raghav
ID: 40581470
Thanks a lot. Your pointers proved very helpful.

The problem was in host name mismatch and thus name resolution. I corrected the problem and re-enabled the site. This worked.

Thanks again.

Best Regards
Raghav.
0

Featured Post

Understanding Web Applications

Without even knowing it, most of us are using web applications on a daily basis. Gmail and Yahoo email, Twitter, Facebook, and eBay are used by most of us daily—and they are web applications. We often confuse these web applications tools for websites.  So, what is the difference?

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Online collaboration is quickly becoming embedded in the workplace, and its benefits are tangible. See what the current landscape looks like and what the future holds for collaboration tools and the future of work.
These days, all we hear about hacktivists took down so and so websites and retrieved thousands of user’s data. One of the techniques to get unauthorized access to database is by performing SQL injection. This article is quite lengthy which gives bas…
Use Wufoo, an online form creation tool, to make powerful forms. Learn how to choose which pages of your form are visible to your users based on their inputs. The page rules feature provides you with an opportunity to create if:then statements for y…
Learn how to set-up custom confirmation messages to users who complete your Wufoo form. Include inputs from fields in your form, webpage redirects, and more with Wufoo’s confirmation options.

704 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question