Solved

Exchange 2007 SBS 2008 autodiscover.xml You do not have permission to view this directory or page.

Posted on 2015-01-30
8
477 Views
Last Modified: 2015-02-08
Hi there, i have exhausted my knowledge on this one. Im trying to get the OOF working for a domain im now looking after.

After re pointing all the addresses to the correct ones creating DNS records, testing with  the outlook test auto configuration. checking the permissions on the IIS autodiscover and now using the https://testconnectivity.microsoft.com i get one last error which i hope once solved will allow the OOF to work

When visting https://autodiscover.mydomain.com/Autodiscover/Autodiscover.xml i get You do not have permission to view this directory or page.

on the ms test site i get the following error

      Attempting to send an Autodiscover POST request to potential Autodiscover URLs.
       Autodiscover settings weren't obtained when the Autodiscover POST request was sent.
       
      Additional Details
       
Elapsed Time: 679 ms.
       
      Test Steps
       
      The Microsoft Connectivity Analyzer is attempting to retrieve an XML Autodiscover response from URL https://autodiscover.mydomain.com:443/Autodiscover/Autodiscover.xml for user cl@mydomain.com.
       The Microsoft Connectivity Analyzer failed to obtain an Autodiscover XML response.
       
      Additional Details
       
An HTTP 403 forbidden response was received. The response appears to have come from Unknown. Body of the response: You do not have permission to view this directory or page.
HTTP Response Headers:
Pragma: no-cache
Transfer-Encoding: chunked
Cache-Control: no-cache
Content-Type: text/html
Date: Sat, 31 Jan 2015 00:10:06 GMT
Expires: -1
Server: Microsoft-IIS/7.0
X-AspNet-Version: 2.0.50727
X-Powered-By: ASP.NET
Elapsed Time: 678 ms.
0
Comment
Question by:David
8 Comments
 
LVL 5

Assisted Solution

by:Hello World
Hello World earned 166 total points
Comment Utility
Hi,

Did you change the autodiscover record in DNS to point to the new server? Please also make sure that the correct permissions are set on the IIS directories. Also make sure that the users have full permissions to there mailboxes.

Additional, I find an similar thread about your question, please refer to:
https://social.technet.microsoft.com/Forums/lync/en-US/06eda9ed-53bc-4ec7-9d44-681725272fac/403-forbidden?forum=ocsmobility
0
 

Author Comment

by:David
Comment Utility
This being a 1 server SBS environment the DNS records wasnt there originally but i did add it a while back but still no luck, the outlook test email auto cofiguration find the autodiscover but as i say the ms test page points to this permission problem but im not sure
0
 
LVL 23

Assisted Solution

by:Suliman Abu Kharroub
Suliman Abu Kharroub earned 167 total points
Comment Utility
0
 

Author Comment

by:David
Comment Utility
FYI this is a exchange 2007 SP1
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Author Comment

by:David
Comment Utility
I found the problem there, it was the internal and external url for the active sync.

Now the microsoft test passes for auto discover but i still cant get the OOO working, i still get a

Your automatic reply settings cannot be displayed because the server is currently unavailable
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
Comment Utility
Exchange 2007 Sp1 is no longer supported.
Download and install Exchange 2007 Sp3 (it is fully SBS aware) and then the latest rollup. I would bring the server up to date before I do anything else.

Once complete, run the fix my network wizard in the SBS console. As this is an SBS server you need to manage it in the way that SBS expects, otherwise you will break things quite badly. SBS 2008 makes changes that are not standard to the Exchange configuration, so it is important the wizard is used.

Simon.
0
 

Author Comment

by:David
Comment Utility
Yep cheers simon, we are suggesting to this client to get them moved to a hosted exchange solution as their ISP speed is so poor for their in house exchange server, so im a bit reluctant to upgrade them to SP3 with the fear of SP3 breaking anything. Would you upgrade to SP3 or wait?
0
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 167 total points
Comment Utility
I would upgrade to Exchange 2007 SP3. No hesitation.
Exchange service packs effectively reinstall the product and as such resolve a lot of problems. If I had seen that server, it would have been upgraded before doing ANY other work or troubleshooting. I see no point in wasting time fixing problems on a server that is so out of date.

Simon.
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

Suggested Solutions

We are happy to announce a brand new addition to our line of acclaimed email signature management products – CodeTwo Email Signatures for Office 365.
OfficeMate Freezes on login or does not load after login credentials are input.
This tutorial will walk an individual through locating and launching the BEUtility application and how to execute it on the appropriate database. Log onto the server running the Backup Exec database. In a larger environment, this would generally be …
This tutorial will walk an individual through the steps necessary to configure their installation of BackupExec 2012 to use network shared disk space. Verify that the path to the shared storage is valid and that data can be written to that location:…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now