Solved

Unable to find shared folder in Ubuntu10.04 guest OS, Oracle VM Virtualbox - Very small guest OS screen

Posted on 2015-01-31
21
335 Views
Last Modified: 2015-02-08
I installed an Ubuntu 10.04 guest machine in an Ubuntu 14.04 host. I assigned a shared folder in the host as follows:
Shared folder assigned in VM Virtualbox settingsthen, I added the user named 'user' to the group 'vboxusers' in the host OS, here verifying that
it is already added:

compgen -g
.....
pulse
pulse-access
user
sambashare
vboxusers
winbindd_priv
user@user-A55MLV:~$ sudo adduser user vboxusers
[sudo] password for user: 
The user `user' is already a member of `vboxusers'.
user@user-A55MLV:~$ 

Open in new window


Now, there is no sf_ folder is to be found anywhere on the guest (Ubuntu 10.04) system. I searched the whole
file system.

Maybe it needs to be mounted first, in the guest OS, to have it accessible?

mount -t  ??????

How would I mount this?

How would I mount it so that it is permanently available, and create a launcher to it
inside the guest OS running in the virtual machine?

Also, the guest OS screen is very small, as it was installed by the Ubuntu installer:
This shows that the maximum resolution available is 800x600 pixels
How can I make it larger than 800x600?

Thanks.
0
Comment
Question by:AttilaB
  • 8
  • 6
  • 5
  • +1
21 Comments
 
LVL 87

Expert Comment

by:rindi
Comment Utility
Other Linux Distro's automatically load the VBox guest additions when they realize they are running as a VM. Ubuntu doesn't seem to do that, For shared folders and other things to work properly, like changing the resolution and getting the mouse to properly work within the guest, you must install the guest additions.

You can probably install the guest additions via the synaptic package manager (search for VirtualBox, then look at the list and select guest additions).

Another way to install them is via "Devices", "Insert Guest Additions CD Image" in the VM's menu bar.Then open the CD in ubuntu and install the drivers from there.

After a reboot you can resize the VM by pulling it's edges.
0
 
LVL 5

Expert Comment

by:sno0401
Comment Utility
Hi. rindi's advice is good. If you need to install the guest additions from the terminal, there is a good step by step guide here: https://mylinuxramblings.wordpress.com/2010/06/03/installing-virtualbox-guest-additions-on-ubuntu-server-10-04/
0
 

Author Comment

by:AttilaB
Comment Utility
Thanks. I had no trouble installing the guest additions based on your suggestion:
Installing Guest Additions
Then, I still cannot find the shared folder on the guest. Don't I need to mount it?

I tried this:
Cannot Mount Shared FolderThen I saw a suggestion come up for a second in virtualbox, if I hovered the mouse over the
shared folder, based on that I tried to look for shared folders, but it is not even a linux command:
Cannot Find Name of SharedThis is what it looks like the shared in the host:
Settings in Host
The screen size issue is fixed now, with the Guest Addition install.

How do I find and permanently mount the shared folder in the guest OS 10.04 now?
0
 
LVL 61

Expert Comment

by:gheist
Comment Utility
0
 
LVL 87

Expert Comment

by:rindi
Comment Utility
You need to reboot after having installed the additions. If in the shared folders you enabled "Auto-Mount", navigate to /media, and it will be shown there, mounted.
0
 

Author Comment

by:AttilaB
Comment Utility
It is not in media. I rebooted, there is no media. I need to manually do it:

But how do I edit this file? (Read-only, when opened in gedit)

File not editable
Thanks.
0
 
LVL 87

Expert Comment

by:rindi
Comment Utility
It must be in media if you enabled the auto-mount option:

VirtualBox Shared Folders
Under /Media of my Linux (Makulu) it shows up as /sf_E_Drive, where "sf" is short for "Shared Folders", and "E_Drive" is the label you gave the shared folder when you set it up.
0
 

Author Comment

by:AttilaB
Comment Utility
Hi 'rindl'. Well, on mine I have the exact identical settings:
Shared Folder Settings
Still it doesn't show up as media:
Media FoldersNone of these media folders have the right folder inside them.

I think I have to manually permanently mount it. I will try 'gheist' 's advice, I just have to figure out how to edit '/etc/fstab'  file (with root privileges). I have no idea.
(Mounting unprotected (guest) network folders, as seen at
 https://wiki.ubuntu.com/MountWindowsSharesPermanently)
0
 
LVL 61

Expert Comment

by:gheist
Comment Utility
It should be in /media if at all
If not - use fstab
0
 
LVL 87

Expert Comment

by:rindi
Comment Utility
Open a terminal and enter ls /media and look at the output.
0
What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

 
LVL 61

Expert Comment

by:gheist
Comment Utility
Asker searches under /usr
No there are no automounts there at all.
Click "file system" in left side, then look for one single "media" folder, where automounts should be...
0
 

Author Comment

by:AttilaB
Comment Utility
Thank you for all your advice. The computer I was setting up this on has been occupied by my son working on a video project for school, and I cannot get to it. I will try it all as soon as I get to it and let you know.
0
 

Author Comment

by:AttilaB
Comment Utility
Sorry for the delay. I got back on my computer now  I got to the point where I have the shared folder
showing up in the guest, but not accessible:
Ubuntu Shared Folder Showing up  - Not accessible
So, what do I need to do with the following:

In fstab:
https://wiki.ubuntu.com/MountWindowsSharesPermanently

I don't quite understand what I need to do here, because it is such a short explanation:

1:     I do the following in the Host (12.04) OS.

2.  I came up with the following:
 I do Alt F2 and then open the file fstab  using GEdit using gksudo like this:
gksudo gedit file
Then opened file:
This is how FSTAB opened
3. Question: How do you put in the line? - if my shared folder name is:

The Example:
//servername/sharename  /media/windowsshare  cifs  guest,uid=1000,iocharset=utf8  0  0

My Shared Folder Name:
"Ubuntu Share Folder"

Can you type it here?

Thanks.
0
 
LVL 61

Expert Comment

by:gheist
Comment Utility
virtualbox shared folders come from virtualnox guest additions.
Do not edit ANY fstab.
0
 
LVL 87

Expert Comment

by:rindi
Comment Utility
Access the folders using sudo or gksudo.
0
 

Author Comment

by:AttilaB
Comment Utility
That's exactly what my problem is:  

The guest has no permission to access the shared folder, even if it is the guest root user, because Permission Denied. I have to change permisssions from

See screenshot:Permission Denied to Guest Root User
0
 
LVL 5

Assisted Solution

by:sno0401
sno0401 earned 250 total points
Comment Utility
Can you try adding your user to the virtualbox group on the guest machine using the following command in the terminal:    

sudo usermod -a -G vboxusers $USER

You may need to at least log off or restart the guest machine for the change to take hold. After this, try and access the shared folder.
0
 
LVL 87

Accepted Solution

by:
rindi earned 250 total points
Comment Utility
Open the file manager as root from a terminal, and you should be able to access the shared folders:

sudo nautilus

If you need to access the shared folders without doing it as root, add your user account to the vboxsf group in your /etc/group file:

sudo gedit /etc/group

in the line that has:

voboxsf:x:125:

just add the username after the last :

Personally I don't see why you are trying to use Ubuntu as a VM. It performs terribly slowly, and the unity desktop is one of the worst one around. Practically every other Linux distro will run much better and be more usable, and besides that most of them install the VBox additions automatically when they realize they are run as a VBox VM.
0
 

Author Comment

by:AttilaB
Comment Utility
Yes, your suggestions of 'sno0401' and 'rindi' actually worked! So, I will definitely give the two of you shared credit for
answering (I had to do both steps to make it work)

I did these steps:

1.  adding the user to the virtualbox group on the Host machine:
adding the user to the virtualbox group
2. Then, in the Guest machine I did the mod to the /etc/group file as you suggested:
Modification to /etc/group file
3. Then it just worked: (I could not only see the contents, I could delete/ edit it - read-write-delete permissions)
Read-write-delete access to folder from Guest
Thanks guys.

:)
0
 

Author Comment

by:AttilaB
Comment Utility
You asked WHY I want to do this: Ubuntu 10.04 virtual machine in Ubuntu 14.04:

I have to keep upgrading Ubuntu to the latest version because of dropped support for it. After a while dependencies go missing, no new programs supported. (Linux has the same 'Microsoft Syndrome' of abandoning old, working ways for new buggy inconvenient ways, nobody asked for. Like the various new Ubuntu desktop configurations loaded with bugs, replacing Gnome in 12.04 and 14.04.)

Ubuntu 10.04 with Gnome desktop is something that WORKS. So, I would like to keep using it when I can.
Because I LIKE the way it was done.
0
 
LVL 61

Expert Comment

by:gheist
Comment Utility
Debian has same ol gnome for ages....
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

Suggested Solutions

Citrix XenDesktop 7.6 Citrix Policies Graphics
VMware Update Manager(VUM) “error code: 15” during ESXi 6.0 Remediate update in VUM operation
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

6 Experts available now in Live!

Get 1:1 Help Now