• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 506
  • Last Modified:

Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'.

Hi experts,
i am trying to execute a query the pull data from another serve, i added the server as a linked server to the another one but i am getting the following error when try to execute the query

Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'.
\
search the net but didnt find any step by step solution to solve this issue, please help
0
AZZA-KHAMEES
Asked:
AZZA-KHAMEES
  • 4
  • 3
  • 2
1 Solution
 
QlemoC++ DeveloperCommented:
In the Linked Server properties you should have a Security setting. This seems to be set to not using any security association. Change it to something more appropriate, in a domain you should be able to have it using your current user info, otherwise try with a fixed user and password.
0
 
Vitor MontalvãoMSSQL Senior EngineerCommented:
Post here how's your linked server defined.
'NT AUTHORITY\ANONYMOUS LOGON' is a local user so it won't be able to connect to a remote database.
0
 
QlemoC++ DeveloperCommented:
Vitor, that is nonsense. That user exists on each PC.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Vitor MontalvãoMSSQL Senior EngineerCommented:
@Qlemo:
I've said: "'NT AUTHORITY\ANONYMOUS LOGON' is a local user" and you replied: "That user exists on each PC. "
Isn't that a definition of local user!!?

He should have a domain user otherwise he needs to impersonate the user. Having the same name doesn't means that's the same user since internally they have different ID's.
0
 
AZZA-KHAMEESAuthor Commented:
thank you for the reply
do i have to create a new user with a permission to the other server,
when i configure the linked server i choose
[Be made using the login's security context]

which option do i have to chose? and do i have to add local login under the impersonate?
Linked server
0
 
Vitor MontalvãoMSSQL Senior EngineerCommented:
That option "Be made using the login's security context" it's only for domain users that needs to exists in both instances.
You can use an existing user from the other instance by choosing the option  "Be made using this security context". You just need to give the correct credential.
0
 
QlemoC++ DeveloperCommented:
If you want to have individual users mapping to other users, depending on who uses the link, then use the upper part of the dialog to enter those mappings. Data entered there superseeds anything you set up in the lower half, which is only used if the upper half does not match.

But interesting that MSSQL falls back to Anonymous if the user cannot get resolved on remote ... That account means "I have no user credentials available", and that again means "I don't use security". Most servers will deny access (default setting), but Anonymous Login can be switched on - that much just for completeness sake. Having authenticated users is mandatory.
0
 
AZZA-KHAMEESAuthor Commented:
i modified the properties in the security section of he linked server by adding username and password, and now i am getting a different error

OLE DB provider "SQLNCLI10" for linked server "mofneo" returned message "Unspecified error".
OLE DB provider "SQLNCLI10" for linked server "mofneo" returned message "The stored procedure required to complete this operation could not be found on the server. Please contact your system administrator.".
Msg 7311, Level 16, State 2, Line 1
Cannot obtain the schema rowset "DBSCHEMA_TABLES_INFO" for OLE DB provider "SQLNCLI10" for linked server "mofneo". The provider supports the interface, but returns a failure code when it is used.

note the server is sql 2008 and the linked server is sql 2000
0
 
Vitor MontalvãoMSSQL Senior EngineerCommented:
note the server is sql 2008 and the linked server is sql 2000
SQL Server Native Client is only compatible with SQL Server 2000 with SP4 installed. Verify which SP do you have installed in the SQL Server 2000 instance.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now