Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

IE Wont start at RDC connection, user gets logged off instead

Posted on 2015-02-01
9
Medium Priority
?
222 Views
Last Modified: 2015-02-01
In an RDC client I set start a program = c:\program files\internet explorer\iexplore.exe for connecting to a 2008R2 Terminal Server.  The user logs on, IE never displays (nor does the desktop) and then the user is immediatley logged off.
0
Comment
Question by:Tom F
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
9 Comments
 
LVL 24

Expert Comment

by:VB ITS
ID: 40583088
Check the event viewer on the 2008 R2 server for errors/warnings, sounds like there was an issue with the user's profile at logon.

What if you try to log in with the Start the following program on connection box unticked so that IE doesn't start at logon?
0
 
LVL 1

Author Comment

by:Tom F
ID: 40583121
Log in is just fine when not trying to start IE at logon.
0
 
LVL 1

Author Comment

by:Tom F
ID: 40583123
..it also doesn't seem to matter what user I attempt to login as....
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
LVL 24

Expert Comment

by:VB ITS
ID: 40583127
Have you checked the event logs for any errors around the time the user logs in and gets kicked off?

What happens when you try and run IE manually by copying and pasting "c:\program files\internet explorer\iexplore.exe" into a new shortcut (right click on the Desktop > New > Shortcut)?
0
 
LVL 1

Author Comment

by:Tom F
ID: 40583129
Shortcut or from the run command just opens up IE.  I'll check the logs in a moment...
0
 
LVL 1

Author Comment

by:Tom F
ID: 40583176
Log Name:      Application
Source:        Desktop Window Manager
Date:          2/1/2015 10:09:00 PM
Event ID:      9003
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      Themis.x.x
Description:
The Desktop Window Manager was unable to start because a composited theme is not in use
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Desktop Window Manager" />
    <EventID Qualifiers="16384">9003</EventID>
    <Level>4</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2015-02-02T03:09:00.000000000Z" />
    <EventRecordID>21238</EventRecordID>
    <Channel>Application</Channel>
    <Computer>Themis.x.x</Computer>
    <Security />
  </System>
  <EventData>
  </EventData>
</Event>
0
 
LVL 24

Accepted Solution

by:
VB ITS earned 2000 total points
ID: 40583241
So you don't see any error messages when you log in with Internet Explorer set as the startup program? Have you added Internet Explorer to the list of allowed programs in RemoteApp Manager?

While logged in as an admin, click on Start > Run > type in remoteprograms.msc > click Add RemoteApp Programs on the top right under Actions > go through the wizard and tick Internet Explorer > try logging in again with a user account.

May I ask what you are trying to achieve here? If the idea is to publish IE to the users as if it's running as a local application then you're better off creating a RemoteApp file and then placing this file on the users' Desktops. If you simply want IE starting up when users login then the Programs tab in RDC isn't the way to go as once IE is closed, the user will get logged off the 2008 R2 RD Session Host.
0
 
LVL 1

Author Comment

by:Tom F
ID: 40583265
Adding it to remote programs did the trick.

Long story short, I have a user who needs to access a website within a remote session.  I'd prefer they just be able to access IE and not the entire ts, so when they do close IE, yes, they do get logged off - thats perfect.  Thanks for the help.
0
 
LVL 24

Expert Comment

by:VB ITS
ID: 40583270
In that case that's fine. Just wanted to have a better idea of what you were trying to achieve so I could assist you better. I would still look at deploying a custom RemoteApp file (not that hard to do through the RemoteApp Manager console you opened to allow the remote program) as it'll publish IE running on the server and make it appear as a local application to the client.

Happy to have helped!
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Sometimes drives fill up and we don't know why.  If you don't understand the best way to use the tools available, you may end up being stumped as to why your drive says it's not full when you have no space left!  Here's how you can find out...
This article explains how to install and use the NTBackup utility that comes with Windows Server.
This tutorial will walk an individual through the steps necessary to configure their installation of BackupExec 2012 to use network shared disk space. Verify that the path to the shared storage is valid and that data can be written to that location:…
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…

704 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question