Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Windows Server 2012 IIS 8 Default site not working

Posted on 2015-02-02
23
Medium Priority
?
1,081 Views
Last Modified: 2016-02-29
I have just installed a new Windows Server 2012 essentials server and cannot get clients connected via the http://<server-name>/connect. I receive a 404 error.

On the server under IIS manager the default site will not start giving the message "This website cannot be started. Another website  may be using the same port" see attachment

This error makes no sense as this is a new server and there are no new apps to listening on port 80. I've checked the bindings and the only two entries are port 80 and port 443 for https.

One the SERVER MANAGER there are errors under the IIS EVENTS which are  "1007 - Error - Microsoft Windows-IIS-W3SVC"

The World Wide Web Publishing Service (WWW Service) did not register the URL prefix http://*:80/ for site 1. The necessary network binding may already be in use. The site has been disabled. The data field contains the error number.

As I said this is a new server on its own domain with no other applications loaded.

Help most appreciated.

KJP
iis8-error.png
0
Comment
Question by:kenpar51
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 11
  • 9
23 Comments
 
LVL 8

Expert Comment

by:nader alkahtani
ID: 40583711
try this  

"               netstat -aon | find ":80"

               netstat -aon | find ":443"

You will see an output similar to the following. Remember the actual PID will vary from case to case.

               TCP    0.0.0.0:80             0.0.0.0:0              LISTENING       3604

               TCP    0.0.0.0:443           0.0.0.0:0              LISTENING       3320

Now using Task Manager you can easily find out to which process the above PID belongs and take appropriate action. "

you can end the service...etc
then restart waht do you another service
from http://support.microsoft.com/kb/973094

and this https://technet.microsoft.com/en-us/library/cc735170(v=ws.10).aspx
0
 

Author Comment

by:kenpar51
ID: 40583763
Hi Nader

The only PID listening is PID 4 which is being run by SYSTEM NT Kernel & System so I don't want to shut that process down.

I have tried binding port 8080,8888,8081 with the same results keeps giving me the original error message.
0
 
LVL 20

Expert Comment

by:Peter Hutchison
ID: 40583800
Could you send a screen shot of Task Manager so we can see what services are running?
Apache is known to use port 80, check if that is installed.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:kenpar51
ID: 40583821
Screenshot attached of tasks running.!

netstat-image.pngtasks-running.pngtasks-running1.png
0
 
LVL 20

Expert Comment

by:Peter Hutchison
ID: 40583921
Try disabling the Web Root Secure Anywhere service and see what happens.
Also, check firewall settings and make sure inbound traffic for por t80/443 is allowed.
0
 

Author Comment

by:kenpar51
ID: 40584182
Hi Peter

Sorry forgot to mention that I have tried with the Webroot software disabled and processes ended. Also the firewall has been disabled.

Thanks
0
 
LVL 20

Expert Comment

by:Peter Hutchison
ID: 40584221
I noticed that you have WsusService.exe For Windows Server Update Services installed, which I know will use the IIS web server for deploying WSUS updates.
0
 

Author Comment

by:kenpar51
ID: 40584250
Hi Peter

Stopped WSUS service restarted web server still same error message!
0
 

Author Comment

by:kenpar51
ID: 40584271
I don't know if this is a clue but when I try and enable directory browsing I get the following error!

directory-browsing-error.png
0
 
LVL 20

Expert Comment

by:Peter Hutchison
ID: 40584327
Try go to bindings in IIS and re-add http (port 80) to the default web site and make sure it is enabled.
0
 

Author Comment

by:kenpar51
ID: 40584355
Hi Peter

I've tried re adding the ports but this didn't work. Could you explain what you mean by enabling it? where do you enable the bindings?

Many thanks
0
 
LVL 20

Expert Comment

by:Peter Hutchison
ID: 40584383
I was going by this error:
The World Wide Web Publishing Service (WWW Service) did not register the URL prefix http://*:80/ for site 1. The necessary network binding may already be in use. The site has been disabled. The data field contains the error number.

Maybe removing and re-adding the Web Services may help, if its possible.
Alternatively, add and required additional Web components via Server Manager.
0
 

Author Comment

by:kenpar51
ID: 40584507
This hasn't worked either, same errors. Even typing in localhost to the browser on the server ask me to login and will not accept the admin user!!

server-login.png
iis-web-sites.png
0
 
LVL 20

Expert Comment

by:Peter Hutchison
ID: 40585726
Looks like the DEfault web site has the appropriate ports, but seems have been stopped.
Have you tried right clicking Default web site and select Start on the actions menu. Does that work?
0
 

Author Comment

by:kenpar51
ID: 40585734
Hi Peter

I've tried that with no success! - Can't understand, a new server with new Server OS nothing complicated just asking for the basic services and it takes hours and hours of troubleshooting!!!
0
 
LVL 20

Expert Comment

by:Peter Hutchison
ID: 40585739
Next thing to do is check permissions on c:\Inetpub\wwwroot, System ,Administrators and TrustedInstaller should have full control, the Users and IIS_IUSRS groups should have read/list rights. If thye not set you may need to re-gain ownership and reset the rights.
0
 

Author Comment

by:kenpar51
ID: 40585745
Hi Peter

All permissions are correct as listed on wwwroot
0
 
LVL 20

Expert Comment

by:Peter Hutchison
ID: 40585924
Can you check permissions for C:\Program files\Windows Server\Bin as well?
0
 

Author Comment

by:kenpar51
ID: 40586018
The only difference from the permissions on wwwroot is the TrustedInstaller has read and special permissions, but when I look at the effective permissions is says TrustedInstaller has full control.
0
 
LVL 20

Accepted Solution

by:
Peter Hutchison earned 2000 total points
ID: 40586125
At this stage, I would recommend a reinstall as there is something seriously wrong with this installation..
0
 

Author Comment

by:kenpar51
ID: 40586136
Hi Peter

Yes, it appears I'm banging my head against a brick wall here. I think reinstallation is the only option now!!

Many thanks for your assistance.
0

Featured Post

Will your db performance match your db growth?

In Percona’s white paper “Performance at Scale: Keeping Your Database on Its Toes,” we take a high-level approach to what you need to think about when planning for database scalability.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Sometimes drives fill up and we don't know why.  If you don't understand the best way to use the tools available, you may end up being stumped as to why your drive says it's not full when you have no space left!  Here's how you can find out...
OfficeMate Freezes on login or does not load after login credentials are input.
This tutorial will walk an individual through the process of configuring their Windows Server 2012 domain controller to synchronize its time with a trusted, external resource. Use Google, Bing, or other preferred search engine to locate trusted NTP …
This tutorial will walk an individual through the process of installing of Data Protection Manager on a server running Windows Server 2012 R2, including the prerequisites. Microsoft .Net 3.5 is required. To install this feature, go to Server Manager…

704 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question