Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 380
  • Last Modified:

Windows 8.1 Deployment with UEFI

I am trying to deploy a custom Windows 8.1 image.

Right now I am using a bootable Windows PE disk using the dism /apply-image command. After applying the image from the network share, I receive the error "boot device not found". I am guessing the problem is in the Diskpart Command.

Deploy;

netsh int ip set address "Local Area Connection" static 192.168.1.5 255.255.255.0 192.168.1.1
netsh int ip set dns name = "Local Area Connection" source = static addr = 192.168.1.10 validate = no
netsh int ip add dns name = "Local Area Connection" addr = 8.8.8.8 validate = no
ping 127.0.0.1 -n 10
net use Z: \\server\share password /USER:domain.local\user
diskpart /s diskpart.txt
dism /apply-image /imagefile:Z:\install.wim /index:1 /applydir:w:\
bcdboot w:\windows /s w:
ping 127.0.0.1 -n 10
exit



Diskpart;


select disk 0
clean
convert gpt
create partition primary size=300
format quick fs=ntfs label="Windows RE tools"
assign letter="T"
create partition efi size=100
rem == Note: for Advanced Format Generation One drives, change to size=260.

format quick fs=fat32 label="System"
assign letter="S"
create partition msr size=128
create partition primary
format quick fs=ntfs label="Windows"
assign letter="W"




I also tried to make a Bootable Thumb Drive with the image on it, GPT with FAT32, I split up the install.wim file into 4 smaller swm files due to the 4GB file system limit on Fat32. I keep receiving the error 'Windows cannot find the Microsoft Software License Terms.  Make sure the installation sources are valid and restart the installation.'



Either way would work for me. Ideally I would like to get both ways working.



The computer is a Dell Optiplex 9030 All in One
0
laurenofis
Asked:
laurenofis
  • 2
1 Solution
 
James HIT DirectorCommented:
You will need to go into the BIOS and change the UEFI to "legacy". This will allow you to properly boot from USB and install you image. I just recently had the same issue and that worked for me when using a bootable USB to image a machine.
0
 
laurenofisAuthor Commented:
What model machine were you using Spartan 1337? My option for Legacy boot is grayed out and will not allow me to change it. There is an option for add a boot option, but then it asks for a path.
0
 
laurenofisAuthor Commented:
That worked, awesome!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now