• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 530
  • Last Modified:

outlook 2013 search in contacts isn't working

Hi there,
I have been using Outlook 2013 for 6 or so months running on Windows 8.1 and connecting to Exchange 2010.  Search has been working fine mostly by going Ctrl, Shift F to begin a search, and choosing appointments, tasks or contacts.
About 4 weeks ago search in contacts stopped giving results. You can still search appointments and tasks and get the expected search results but searching contacts comes up with only contacts created in the last few weeks. The contacts can still be searched from my phone and on Outlook Web Access.  If you go to the contacts view in Outlook 2013 you can still see them. On another computer with Outlook 2013 they can still be searched.  
  I did some research and found that in Outlook if I go file > options > search > indexing options that you can see where outlook searches.  When I first went in, the outlook folder where the ost resides was in the exclude column.  I removed it and added it back in to the included locations.  Didn't help.
I have also seen on the internet that the Windows Search service can cause similar issues. I have restarted it because it was already going but it didn't help. When I restarted my computer it was running after the restart.
  I have also read that removing the app "Microsoft Outlook" from indexed locations closing out of options and going back in and adding it again so it reindexes it can help. It didn't help.  
  I have tried going into Advanced options and on the Index Settings tab clicking "Rebuild".  It didn't help.  It rebuilds and comes up with the same number it started with.
  On that window there is the option to move the index location.  Since I thought maybe the index was corrupted I tried moving it by adding a file path to a new location. I created a new folder inside the default Microsoft folder so I could see it create a new one. When I click ok it lets me but there is never any new file in the new location. If I rebuild the index it doesn't create a new file.
  I thought perhaps the ost file was corrupted so I renamed it and let it rebuild by reopening outlook connected to exchange.  Didn't help.  
  I found a site that said the ost file has to be set to allow indexing. I right clicked the ost file on my laptop in the default path c:\users\username\appdata\local\microsoft\outlook\username.ost and right clicked properties > General tab > Advanced Attributes and ticked "Allow this file to have contents indexed in addition to file properties".  Then I rebuilt the index again. It didn't help.
  I checked the ost file size which is 2.8 GB. I researched and the maximum size now is 20 GB.
  I went back to the "Allow this file to have contents indexed in addition to file properties" attribute for the ost file and it was unticked. I ticked it and ran the rebuild again and it unticked itself again. I tested when the attribute unticks and it is either when you restart Outlook after changing it, or if you restart Outlook, tick it again, then run the rebuild it unticks then too. So the search still doesn't work.  I checked permissions on this file and I have full control and am the owner of the ost file.
  I have run a repair on Office 2010 and restarted the computer and it didn't work.
  Since my original post I have also tried creating a new profile in Outlook but that hasn't worked either.

It seems to be a common problem when I Google but the fix seems to be changing the file attribute and rebuild but it didn't work for me because the file attribute won't stay ticked to index.  Any ideas?

Thanks heaps for your help in advance.
Shaun
0
shaunwoy
Asked:
shaunwoy
  • 4
  • 3
2 Solutions
 
JohnBusiness Consultant (Owner)Commented:
On another computer with Outlook 2013 they can still be searched.

I have run a repair on Office 2010 and restarted the computer and it didn't work.  Since my original post I have also tried creating a new profile in Outlook but that hasn't worked either.

On the problem computer, make a new, test, Windows User Account (Profile). Set up Outlook in the new Account (Profile) and test the search in the new Windows Account. It could be a damaged profile.
0
 
shaunwoyAuthor Commented:
Thanks heaps John for your suggestion.
Last night I was googling came across the idea it might be the profile. I recreated it last night and found the search rebuilding as I went to bed. This morning the search result just shows the last few days still and hasn't helped. I put this in the notes in the original question this morning.  
Any other ideas?
Shaun
0
 
JohnBusiness Consultant (Owner)Commented:
About the only other suggestion I can think of at this point is to actually delete the OST file. Then delete the Outlook Profile (the email profile). Then look at Search Properties in Windows and make sure User is in Index Options (that should be where the OST file lives) and Outlook itself is in the Index Options (included locations) .

Now shut right down, start up, set up Outlook, allow the OST file to completely re-create, and then rebuild the index. All of this will take time. When done, restart and test.
0
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
shaunwoyAuthor Commented:
Hi John,
I have been renaming the ost file as .old but i didn't rename the profile or delete it. I can give that a go.
Part of my troubleshooting was trying to move the Index in the hope recreating it somewhere else would fix it. I went:
File > options > search > indexing options > Advanced and found the default location to be c:\ProgramData\Microsoft. In that folder there are lots more folders but no file. So it appears there is no index file. I changed it to c:\ProgramData\Microsoft\Indexnew and rebuilt the index but there is no file in there either. I checked permissions and I am local admin so have full control of those folders. Does this help or do you have any thoughts on this?

I will delete my profile and old Osts and let you know the outcome.
Thanks for your advice,
Shaun
0
 
JohnBusiness Consultant (Owner)Commented:
The user does not need overt permission to the Program folder where the index is (not in my experience) and the user already has permission for c:\users\username where the OST file lives.

I will keep following you.
0
 
pgm554Commented:
The ost is a cached file from Exchange that can be as large as 50 gigs.

With that being said,the Exchange admin controls how large that file can grow,not you.

If you deleted or renamed the ost,then the next time you login to Exchange ,it will be rebuilt.

If you are still having issues ,it sounds like a problem with the Exchange server mailbox.
0
 
shaunwoyAuthor Commented:
Hi John,
I tried actually deleting the profiles and Ost and it didn't work. However just to see what happens I tried moving the mailbox from one datastore to another on Exchange 2010 and search in Outlook on my computer works!  So perhaps the master copy was corrupted in the Exchange datastore somehow.  Thanks heaps for your help!
0
 
JohnBusiness Consultant (Owner)Commented:
@shaunwoy  - Thanks for the update and I was happy to help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now