?
Solved

Dynamics CRM 20143 error on 2012r2

Posted on 2015-02-04
4
Medium Priority
?
232 Views
Last Modified: 2015-02-04
Hi,

I've installed Dynamics CRM 2013 on it's own dedicated VM running server 2012 r2 standard.

When i access http://servernamecrm.local:5555 on the server it works fine.
I have also binded https://servernamecrm.local:444 and this also works fine.

Any time i access it from the internal network on user pcs i get the error

No Microsoft Dynamics CRM user exists with the specified domain name and user ID
A Microsoft Dynamics CRM user record does not exist with the specified domain name and user ID

I don't want this Internet facing and would be happy with everyone using vpn to access the internal url.
I will implement internet facing at a later date but i would like it to be internal at the moment.

I do have an ADFS server on another VM but i have not set this up yet as i read i don't need this if i just want crm to be internal.

Thanks
0
Comment
Question by:mfmsupport
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 16

Expert Comment

by:Shaik M. Sajid
ID: 40588398
0
 

Author Comment

by:mfmsupport
ID: 40588437
Hi,

i did this before you posted it...and now i have all users working when they access both http and https links from their pc's.

https://technet.microsoft.com/en-us/library/dn531106.aspx

Do i have to do more configuration now to make sure no errors occur when accessing these links internally?
0
 
LVL 30

Accepted Solution

by:
Feridun Kadir earned 2000 total points
ID: 40588520
Microsoft Dynamics CRM does not support multiple bindings. You can use http or https but not more than one - even though IIS allows this.

It might work but you will run into problems at some stage.

If you change the binding in IIS you must also update the Web properties in the CRM Deployment Manager.

Since you are going to go IFD later remove the http binding and use the https binding only. Make sure that you use a trusted SSL certificate and not a self-signed one.
0
 

Author Comment

by:mfmsupport
ID: 40588806
I have removed the HTTP binding now.
0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

For cloud, the “train has left the station” and in the Microsoft ERP & CRM world, that means the next generation of enterprise software from Microsoft is here: Dynamics 365 is Microsoft’s new integrated business solution that unifies CRM and ERP fun…
In this article, I am going to show you how to simulate a multi-site Lab environment on a single Hyper-V host. I use this method successfully in my own lab to simulate three fully routed global AD Sites on a Windows 10 Hyper-V host.
In this Micro Tutorial viewers will learn how to use Boot Corrector from Paragon Rescue Kit Free to identify and fix the boot problems of Windows 7/8/2012R2 etc. As an example is used Windows 2012R2 which lost its active partition flag (often happen…
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…
Suggested Courses

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question