RDS task manager not showing usernames

We are running RDS on a Server 2008 R2 ENT SP1 VM. We are encountering an odd issue. The usernames of individuals is not displayed in Task Manager. The process of the user is shown but not their username (please see attached screenshot). My administrator account does show up. When I add domain users to the local admin group then all the names are seen. How can I have these individuals show up but not have admin right?
HodorAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

it_saigeDeveloperCommented:
Screen shot is missing.

-saige-
0
HodorAuthor Commented:
Sorry, screenshot has been uploaded now.
task-manager-screenshot.JPG
0
it_saigeDeveloperCommented:
What is the configuration of your RDS related services?  On a Test RDS Server running as a VM with Windows Server 2008 R2 Standard SP1Capture.JPGI can see the users in task manager with the services for RDS configured as follows:Capture.JPG-saige-
0
Acronis Data Cloud 7.8 Enhances Cyber Protection

A closer look at five essential enhancements that benefit end-users and help MSPs take their cloud data protection business further.

it_saigeDeveloperCommented:
As a test I created a limited user that is only a member of the Users group.  Task manager for that user shows as:Capture.JPGBut logged in with my administrative user I can see the LimitedUser in the task list:Capture.JPG-saige-
0
VB ITSSpecialist ConsultantCommented:
This happens when the Remote Desktop Services service isn't started. Go into Control Panel > Administrative Tools > open Services > verify that Remote Desktop Services is started. If it's stopped, right click on it and start it.
0
HodorAuthor Commented:
Some additional details: My RDS system is part of a farm. Users hit the gateway server and according to load balancing gets sent to 1 of 5 available RDS servers.

@saige

The RDS services are all started but only the gateway server has the "Remote Desktop Licensing" service (STARTED).

What local or domain groups is your administrator account part of compared to the Limited User?

@VB ITS

"Remote Desktop Services" is started on all my servers. Still missing usernames.
0
VB ITSSpecialist ConsultantCommented:
@Hodor I recently deployed a 2008 R2 RDS farm myself and I can't seem to replicate this issue on my end. The servers are running 2008 R2 Standard though and not Enterprise as you are using.

Have you tried going through the local groups on the Remote Desktop Servers to see if the Domain Admins group isn't in one it shouldn't be?

Seems to be a privilege issue with the account.
0
HodorAuthor Commented:
@VB ITS

I ran into the same issue with the old farm which was standard. I would agree the problem here is a privilege issue with the admin accounts used.

I found an account that worked! One of our admin accounts had special privileges and after logging in as that user I was able to see all usernames. Now I need to find which user rights my other admin accounts need. The admin account that worked were part of the following groups under GPO Computer>Windows Settings>Security settings>Local Policy>User Rights Assignment

Back up files and directories
Debug programs
Log on as batch file
Log on as service
Manage auditing and security log
Modify firmware environment values
Restore files and directories
Shut down the system
Take ownership of files or other objects
0
VB ITSSpecialist ConsultantCommented:
I'm thinking it's Debug programs. Compare the two accounts - which User Rights Assignments are missing?

I'll fire up a test 2008 R2 VM shortly to test on my end.
0
it_saigeDeveloperCommented:
@Hodor - In answer to your question, the Administrator account that I am using is a member of Domain Admins, which is a member of the RDS Server's Local Administrators Group.

-saige-
0
VB ITSSpecialist ConsultantCommented:
OK just fired up a fresh test 2008 R2 Standard VM with just the RD Session Host role installed on it. I removed Administrators from the Debug programs User Rights Assignment (which I will now refer to as URA), logged off, then log back on.

Opened up the Task Manager and I could immediately see a few processes where the User Name column was blank. Re-added the Administrators group to the Debug programs URA and logged out then logged back in. User Name column was showing all the values in the User Name column for each and every process again.

I'd be willing to bet your admin account hasn't been assigned the Debug programs URA. Try adding your specific admin account to this through Group Policy or even through the Local Security Policy (Start > Run > secpol.msc) - should fix the issue.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
HodorAuthor Commented:
Debug Programs group was the source of the problem. Thank you all for your help!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.