Solved

Why my mobile device could not work with my Exchange 2013 server?

Posted on 2015-02-05
10
62 Views
Last Modified: 2015-02-10
This is using MS Exchange 2013 server. However, I found that my mobile handphone couldn't be setup to sync with my exchange server for emails. How should I troubleshoot to get it resolved.

Thanks in advance.
0
Comment
Question by:MichaelBalack
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
10 Comments
 
LVL 20

Expert Comment

by:Satya Pathak
ID: 40590760
follow the below KB it might be help you .

http://msexchangeguru.com/2012/02/01/exchange-activesync/
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 40590779
You have provided no information to be able to provide assistance.
You haven't said what the device is (OS etc) or whether you have done anything yourself to resolve the issue.

Create a test account and run it through the Microsoft test site at http://exrca.com/ and see what that flags up.
Do you have a trusted SSL certificate on the server? If not then you will need to change that as most mobile clients will have problems with the self signed certificate generated by Exchange - which isn't supported for production use anyway.

Simon.
0
 
LVL 1

Author Comment

by:MichaelBalack
ID: 40590795
Hi Simon,

This is using self-signed cert. I will test if without cert, can my andriod work?
0
Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 
LVL 4

Expert Comment

by:Praveen Kumar Bonala
ID: 40591028
Hi MichaelBalack,
prvsly I had similar issue. I have solved in following way, I was domain admin group at that time.

1. Remove your user from domain admin group.

2. configure Active sync or exchange account on your mobile device.

3. Once your mailbox is synced again add your user in domain admin group.

if it doesnot works please check following steps

To work around this issue, assign the Exchange Servers group the right to change permissions against msExchActiveSyncDevices objects. To do this, follow these steps:1.Start Active Directory Users and Computers.
2.Click View, and then click to enable Advanced Features.
3.Right-click the object where you want to change the Exchange Server permissions, and then click Properties.

Note You can change permissions against a user, an organizational unit, or a domain.
4.On the Security tab, click Advanced.
5.Click Add, type Exchange Servers, and then click OK.
6.In the Apply to box, click Descendant msExchActiveSyncDevices objects.
7.Under Permissions, click to enable Modify Permissions.
8.Click OK three times.
0
 
LVL 1

Author Comment

by:MichaelBalack
ID: 40591416
Hi Praveen,

Let me have some time to do it. I'll update you the results.
0
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 500 total points
ID: 40592368
Self Signed certificates are not supported for use with ActiveSync. You need to use a trusted certificate. I wouldn't want to use ActiveSync without a certificate at all, as that means your username and password is going across in the clear.

Are you a domain admin? If not then the above doesn't apply. If you are then you should really be using the split permission model, with two accounts - one admin and one day to day that is not a domain admin (but can be a local admin on your workstation). That is how Microsoft are now designing their products.

Simon.
0
 
LVL 1

Author Comment

by:MichaelBalack
ID: 40592678
Hi Simon,

The activesync without cert is just to check whether it works or not.

Btw, how to configure activesync w/o cert?
0
 
LVL 31

Expert Comment

by:Gareth Gudger
ID: 40596507
Hey Michael,

ActiveSync works out of the box. All you need is a proper SSL certificate from a trusted third party CA and that's it. (Assuming you have also configured NATing on your firewall)

As Simon mentioned, configuring ActiveSync without SSL is not recommended for the reasons he stated.

GoDaddy has a single name SSL cert on sale right now for $55. And with some Google searching on GoDaddy promo codes you can pick one up for probably close to $40.
0
 
LVL 1

Author Comment

by:MichaelBalack
ID: 40600261
ok,

Please wait for my updates in 12-hour time.
0
 
LVL 1

Author Closing Comment

by:MichaelBalack
ID: 40602378
Thanks Simon, after I changed to use MS Internal CA, and mobile using EAS is working fine.
0

Featured Post

Free eBook: Backup on AWS

Everything you need to know about backup and disaster recovery with AWS, for FREE!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
exchange , email 8 44
script to trace the email in Office365 4 51
Cannot transfer Outlook autocomplete file to a new Exchange profile 4 42
Migrate EDB to PST 5 47
Utilizing an array to gracefully append to a list of EmailAddresses
This article explains how to install and use the NTBackup utility that comes with Windows Server.
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question