Error HTTP 404.3 - Not Found

Hi,
I installed the server of sprintometer ( http://sprintometer.com/node/70 ) and when i finished, i tryed to acces to a test page and i receive this page:

How to fix it?
Thanks for help
IIS-7.0-Erreur-d-taill-e---404.pdf
WathanAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Big MontyConnect With a Mentor Senior Web Developer / CEO of ExchangeTree.org Commented:
Go to this directroy in command prompt C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727

Run this command: Aspnet_regiis -I
The run this command: aspnet_iis -ga
0
 
Big MontySenior Web Developer / CEO of ExchangeTree.org Commented:
what url are you trying to access?

is this for classic asp or asp .net? they're two different technologies so it's important to know which one you're using
0
 
Big MontySenior Web Developer / CEO of ExchangeTree.org Commented:
also, make sure you have the asp .net framework installed (i'm starting to think this is just for asp.net)
0
What Kind of Coding Program is Right for You?

There are many ways to learn to code these days. From coding bootcamps like Flatiron School to online courses to totally free beginner resources. The best way to learn to code depends on many factors, but the most important one is you. See what course is best for you.

 
Emmanuel AdebayoGlobal Windows Infrastructure Engineer - ConsultantCommented:
This is because IIS will only serve out files that are defined MIME types - so you will need to add *.asmx manually.
0
 
WathanAuthor Commented:
The url i try to acces is: http://localhost/SWS/SWS.asmx 
And yes it's asp.net and i already installed the framework
0
 
Emmanuel AdebayoGlobal Windows Infrastructure Engineer - ConsultantCommented:
1. Go to IIS Manager, on the left hand side menu, click on Application Pools.
2. In the main window, right click on “DefaultAppPool” or “Classic .NET AppPool” depending on which one you use for your website.
3. Select “Advanced Settings”, in the “General” section in the pop-up window, check “Enable 32-Bit Applications” to “True”,
0
 
WathanAuthor Commented:
how to add *.asmx manually??
0
 
WathanAuthor Commented:
Now i get an Error HTTP 401.3 - Unauthorized
0
 
Big MontySenior Web Developer / CEO of ExchangeTree.org Commented:
0
 
Big MontySenior Web Developer / CEO of ExchangeTree.org Commented:
make sure IUSR and NETWROK SERVICES have permissions on your site folder
0
 
WathanAuthor Commented:
IUSR have it but how to know about NETWORK SERVICES?
0
 
Big MontySenior Web Developer / CEO of ExchangeTree.org Commented:
its a user found in the local machines user list (same place as the IUSR account)

what AppPool are you running the site under> Do you have any certificates (SSL) related to the site?
0
 
WathanAuthor Commented:
Good now i fixed the authorisation problem and MIME type problem and now i have this page:
localhost-SWS-SWS.pdf
0
 
Big MontySenior Web Developer / CEO of ExchangeTree.org Commented:
in IIS, go to the ASP.NET tab and make sure a version for the framework is selected
0
 
WathanAuthor Commented:
where is it IIS?
0
 
Big MontySenior Web Developer / CEO of ExchangeTree.org Commented:
0
 
WathanAuthor Commented:
The framework .NET is selected. It's: .NET Framework v2.0.50727
0
 
Big MontySenior Web Developer / CEO of ExchangeTree.org Commented:
i wonder if the IUSR and NETWORK SERVICES accounts have to have access to where the DLL resides. Other than that, I'm not sure what else to do.

Is there anything noteworthy is the Event log on the server?
0
 
WathanAuthor Commented:
I don't understand anything in that i just followed the installation tuto.
If you want, here is my SWS.asmx file, may be he is wrong:
0
 
WathanAuthor Commented:
sorry here the file (i can't uploade a file .asmx):

<%@ WebService Class=SprintometerWS.SprintometerWSClass %>
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.