?
Solved

how to configure cisco switch 3750

Posted on 2015-02-05
14
Medium Priority
?
382 Views
Last Modified: 2015-02-10
Hi Experts,

I am currently working on my lab which consists of 3 ESXi host with 8 NICs each and 2 cisco 3750 switched already stacked, I am not very fluent in cisco, but willing to learn.

What I am looking for is how to configure the switches in order to provide trunk VLAN's to the ESXi's which are going to be clustered, my current designe is as follow:


Management

VMK0 192.168.10.10 - VLAN 10
route based on physical nic load
vmnic 0

vMotion
VMK1 192.168.20.10 - VLAN 20
route based on physical nic load
vmnic 1

iSCSI
VMK2 192.168.30.10 - VLAN 30
route based on physical nic load
vmnic 2, 6, 3, 7

VM Network
VMK3 192.168.40.10 - VLAN 40
route based on physical nic load
vmnic 4, 5

All ports trunked (Management, vMotion, iSCSI and VM Network)


I need an expert to walk me through the switches configuration step by step and maybe explain to me some of the commands, I have a fair knowledge on the commands parts.
0
Comment
Question by:Islandr
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 6
14 Comments
 
LVL 25

Expert Comment

by:Ken Boone
ID: 40591286
So for vlan creation just in case you need that

conf t
vlan 10
  name Mgmt
vlan 20
 name vMotion
vlan 30
 name iSCSi
vlan 40
 name VMNetwork

So on the switchport that will connect to ESXI where you want to trunk these ports this is what you do:

int gig0/1
switchport mode trunk
switchport trunk allowed vlan 10,20,30,40
switchport trunk encapsulation 802.1q     <-- may or may not be necessary.  



What we did was define the port as a trunk instead of access
Then we specified what vlans are allowed over this trunk... This is not necessary as by default all vlans flow over a trunk, but it is good practice to prune the vlans down to what you want from a security perspective as well as bandwidth mgmt practice.
Cisco had a proprietary trunking protocol years ago and some switches still support it.  If it does then you need to specify the 8021q otherwise  the command will be rejected if its not needed.
0
 

Author Comment

by:Islandr
ID: 40591439
Ken Boone,

First of all, thank you for replying, I got a few other questions, since I got two switches already stacked, which will make 48 switch ports available, I am going to plug 24 NICs into the ports as I described above (3 servers 8 NICs each = 24 vmnic 0 -7) 1 NIC for the Management, 1 NIC for vMotion, 4 NICs for iSCSI, 2 NICs for VM network.

How Do I tell the switch where this NICs will be plug or Do I need to tell the switch this information?

Finally, I would like to make a description of the interface where is connected, for example vmnic 1 is vMotion connected to port gig0/4.

Thanks in advanced.
0
 
LVL 25

Expert Comment

by:Ken Boone
ID: 40591468
Ok so on the switchport

conf t
interface gig0/4
  description  ESXi-1 VMNIC 1 Vmotion

That will put the description on the switchport

Not sure about this question "How Do I tell the switch where this NICs will be plug or Do I need to tell the switch this information?"

Basically you configure the switchport for what you want it to do  i.e. trunk certain vlans etc..  then you plug it in.  The description is for your benefit when troubleshooting.. but the switch doesn't need to know specifically what vmmic is attached to what port.    I hope that answers your question.
0
Fill in the form and get your FREE NFR key NOW!

Veeam® is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

 

Author Comment

by:Islandr
ID: 40591501
Ken Boone,

Does one single interface (gig0/4) would be enough for all the VLANS? or Do I need to specify an interface for every VLAN? what would be the best practices for this case?

Thanks,
0
 
LVL 25

Expert Comment

by:Ken Boone
ID: 40591526
Well that depends on what you are trying to accomplish.. I am assuming you are using a minimum of gig links and not 100Meg links to start with.

I am not a ESX expert by any means.. but this is what I see a lot folks do:

ESX with 8 NICs

2 NICs for management
2 NICs for vmotion
2 NICs for iSCSI
2 NICs for Data

Generally in this setup, the nics for mgmt, motion and iscsi only need to carry the applicable vlan.  One the data nics, all of the data vlans that are needed would be trunked.  This is typically when you have VMs that need to be in different vlans.

I have also seen
2 NICS for mgmt and vmotion
2 nics for iscsi
4 nics for data

Again,
Im not a vmware expert my specialty is in the cisco realm.
0
 

Author Comment

by:Islandr
ID: 40591541
Ken Boone,

I'll try the configuration you suggested, and I should be able to get back to you soon.  Again, thank you for the information.
0
 

Author Comment

by:Islandr
ID: 40592181
Ken Boone,

I completed the configuration following the guidelines, I assigned an IP to the host and specify the VLAN ID as well, I am currently connected to the console of the switch, but when I ping the IP that I assigned to the host, I get:
% Unrecognized host or address, or protocol not running.

Any ideas?
0
 
LVL 25

Expert Comment

by:Ken Boone
ID: 40592209
Ok so here is a guide if you are not trunking vlans i.e. your ports are broken out to specific vlans.

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1004127

Here is a guide if you are trunking:

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1006628

And here is a guide on how to setup your vswitch:

http://kb.vmware.com/selfservice/search.do?cmd=displayKC&docType=kc&docTypeID=DT_KB_1_1&externalId=1004074

I think the last doc is probably what will help you the most.
0
 

Author Comment

by:Islandr
ID: 40592233
I got the guides, Where and how do I specify an IP address on the switch so I can ping the hosts?

The error happens when I try to ping the host from the console.
0
 
LVL 25

Expert Comment

by:Ken Boone
ID: 40592245
how do you specify an ip address on the cisco switch?  If that is your question.  You need to create a layer 3 vlan on your switch and give it an ip address.

i.e.

vlan 10
  name Mgmt

So that defined the layer 2 vlan

int vlan 10
  ip address x.x.x.x
 no shut

That defined the layer 3 vlan.
0
 

Author Comment

by:Islandr
ID: 40592274
Ken,

I really appreciated your help, I am going to redo this again to see, what I am doing wrong.

Thanks,

PS. I'll provide you with the points no matters what the outcome is, you've been very useful.
0
 

Author Comment

by:Islandr
ID: 40594472
Ken Boone,

Let me pick your brain one more time, here is what I do, I started all over again, reset the switches to factory settings and I added the VLANs, 10,20,30,40 with their respective names, then I plug one cable from vmnic0 to gig1/0/16 and did the following:

inter gig1/0/16
switchport trunk encapsulation dot1q
switch port mode trunk
switchport trunk allowed vlan 10,20,30,40
exit

Then I plug a laptop into a port in the switch (specifically gig1/0/12) configured a static IP in my laptop and I already have an IP on the ESXi host connected to port 16, and when I tried to ping it, I was unable to obtain a response, so I if I can not reach the host from the switch, I am not going to be able to install and deploy VM's

Do you know what I am doing wrong?

Thanks,
0
 
LVL 25

Accepted Solution

by:
Ken Boone earned 2000 total points
ID: 40594562
So there are multiple layers here.  I would have the management ports for the ESXi server on the mgmt vlan and not trunk that .  So you would connect the mgmt nic for ESXi to a switchport that would be configured as an access port:

int gig 1/0/16
switchport mode access
switchport access vlan 10
spanning-tree portfast

the port your pc should be should be configured identically

At that point you should be able to ping the ESXi host.

Once you have that you will assign other NICs for data,vmotion, iscsi whatever..
Typically I would have a single vlan for motion with and a difference one for iscsi.. so again these would be access ports and not trunk ports..

The nics for the DATa are usually where the trunks come in to play.

So start with getting connectivity to ESX without trunking
0
 

Author Closing Comment

by:Islandr
ID: 40601323
Ken Boone,

You were precise and very knowledgeable about the question, from the VMware perspective there were a few things that I wanted to put together that I was unable to understand such as separating the management VLAN from the rest of the VLAN, now I have a clear understanding of what I am doing.


Another resource that I was able to use and replicated the network piece was the Cisco Packet Tracer student, and Danscourses youtube video about VLANs and trunking.

Thank you so much for your assistance.
0

Featured Post

Simple, centralized multimedia control

Watch and learn to see how ATEN provided an easy and effective way for three jointly-owned pubs to control the 60 televisions located across their three venues utilizing the ATEN Control System, Modular Matrix Switch and HDBaseT extenders.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If we need to check who deleted a Virtual Machine from our vCenter. Looking this task in logs can be painful and spend lot of time, so the best way to check this is in the vCenter DB. Just connect to vCenter DB(default DB should be VCDB and using…
In this article, I will show you HOW TO: Install VMware Tools for Windows on a VMware Windows virtual machine on a VMware vSphere Hypervisor 6.5 (ESXi 6.5) Host Server, using the VMware Host Client. The virtual machine has Windows Server 2016 instal…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question