Limits to open SharePoint 2010 libraries in Windows Explorer

Hello,
Does anyone know if there are limitation on the number of items in a SharePoint 2010 document library that would prevent it from opening in Windows Explorer?
I can open a library with 33K+ documents but am having a problem with a library where there are 100K+ files.
No errors in the Events or System logs.
Should I follow this article
http://www.mysharepointadventures.com/2011/08/unable-to-browse-large-document-library-in-explorer-view/
Solution

The problem occurs because the size of all the file attributes that are returned by the WebDAV server is much larger than what is expected. By default, this size is limited to 1 MB.

To work around this problem, you need to modify the windows registry on the client computer.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters\
 Value:
 FileAttributesLimitInBytes
 Data Type: DWORD
 Default Value: 1,000,000
 decimal (1 MB)

Change the default value to a larger number, e.g. 100000000 for 100mb.


Thanks!
IT-NYCAsked:
Who is Participating?
 
Rainer JeschorConnect With a Mentor Commented:
Hi,
as the explorer view uses the WebDAV feature and the webclient service on the client side, there are some default settings in Windows 7 like default timeout and maximum upload size mentioned in this MS KB entry:
http://support.microsoft.com/kb/2668751

Besides that the general considerations for large lists and libraries will take account in regards to performance.
HTH
Rainer
0
 
IT-NYCAuthor Commented:
Thanks, Rainer!
I will try and let you know.
Have you tried opening libraries with the number of files I mention?
0
 
Rainer JeschorCommented:
Hi,
nope - I always tried to keep the libraries / folders on a reasonable size (max 5000 elements on one level).
Too many bad experiences from colleagues and customers who did not follow this approach :-)
But there are also other factors to consider e.g. item level permissions - this can kill performance as well (my first experience on SP 2010 saying you can have thousands of documents and you can have item level permissions - but it seems that nobody really tested the combination of both :-D)
HTH
Rainer
0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

 
IT-NYCAuthor Commented:
I hear you loud and clear, been there.
In my case, it is a combination of large number of folders and files. Will see it on Monday. I am optimistic :)
0
 
Rainer JeschorCommented:
Good luck - and have a nice weekend
0
 
IT-NYCAuthor Commented:
You, too.
0
 
IT-NYCConnect With a Mentor Author Commented:
It worked!!!
Thanks a lot
I applied the registry setting: FileAttributesLimitInBytes to 100000000
and FileSizeLimitInBytes 200000000
in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters
and
FsCtlRequestTimeoutInSec to 3600 in HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MRxDAV\Parameters
In IE, modified Compatibility settings as it wasn't opening from the menu (you have to add this site to the Trusted Sites message).
0
 
IT-NYCAuthor Commented:
Part of the solution was my own findings.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.