Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Visual Studio 2013 VB.net Firebird DDEX add connection closes form

Posted on 2015-02-06
4
Medium Priority
?
1,219 Views
Last Modified: 2015-05-09
This is really weird. I have uninstalled and installed the Firebird client 4.6.1.0 and the DDEXProvider 3.0.1.0. I have also used the nuget to install firebird into the solution. If I try to edit my existing connection string in the Settings I get an error "Unable to find the Requested .Net Framework Data Provider. It may not be installed."  If I attempt to add a connection to the server explorer I can get the add connection form but I cannot fill in the required information. The Firebird Data Source is listed next to the change box. If I start to type in the Data Source text box the form closes. I can launch the project and it will work. I just cannot add or edit anything in any dataset created earlier. Has anyone experienced this and what steps resolved it.
Capture1.PNG
Capture2.PNG
Capture3.PNG
0
Comment
Question by:Don VonderBurg
  • 2
  • 2
4 Comments
 
LVL 96

Expert Comment

by:Bob Learned
ID: 40753344
It has been quite a while since I have worked with Firebird, so please be patient, whilst I cull my memory banks...

As a test, I installed Firebird using the Nuget package.   What update are you using with Visual Studio 2013 (I am using Update 4)?
0
 
LVL 96

Expert Comment

by:Bob Learned
ID: 40753352
I also installed Firebird 2.5.4.
0
 
LVL 1

Accepted Solution

by:
Don VonderBurg earned 0 total points
ID: 40758933
I figured it out. For some weird reason the Firebird DDEX will install multiple times in the Machine.config file. I removed all but one and it works. This has happened again after the fix and when I checked the Machine.config file it had two more instances of Firebird in there again. So apparently something is buggy with the installer whereby it does not recognize that there is already an entry. Everytime I create a new project and add the Firebird resource it appears to add another instance in the Machine.config.

So for everyone else out there reading this, just open the Machine.config file in your .Net folder and delete the multiple lines referencing Firebird leaving one reference. Then you have to reboot your computer to make sure it takes affect.
0
 
LVL 1

Author Closing Comment

by:Don VonderBurg
ID: 40768197
After months of research I have figured out the issue.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article, I’ll look at how you can use a backup to start a secondary instance for MongoDB.
Instead of error trapping or hard-coding for non-updateable fields when using QODBC, let VBA automatically disable them when forms open. This way, users can view but not change the data. Part 1 explained how to use schema tables to do this. Part 2 h…
Video by: Steve
Using examples as well as descriptions, step through each of the common simple join types, explaining differences in syntax, differences in expected outputs and showing how the queries run along with the actual outputs based upon a simple set of dem…
This is a high-level webinar that covers the history of enterprise open source database use. It addresses both the advantages companies see in using open source database technologies, as well as the fears and reservations they might have. In this…
Suggested Courses

927 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question