Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 142
  • Last Modified:

Cannot remote desktop to 2003 R2 server with Exchange 2007 SP3

Our Exchange 2007 SP3 server is running on Server 2003 R2 x64 with SP2. After a crash resolved by uninstalling ethernet-drivers and antivirus I have no longer been able to remote desktop to my server. Everything else seems to be running fine. I have been looking through logs in event viewer, and Googled lots, but I cannot find a solution.

Any ideas on where to look/how to proceed would be much appreciated (even thought this server really needs to be upgraded/migrated soon!).
0
Erlend Ausland
Asked:
Erlend Ausland
1 Solution
 
Praveen Kumar BonalaCommented:
Can you able to ping to server.? ping with IP and hostname?
Please check remote desktop enabled on your server.

Please check firewall turned off on the server?
Please check 3389 port is opened for the server. user telnet to check.

if you have installed antivirus, please check if it is blocking it.
0
 
Chris MillardCommented:
Are you trying to RDP from inside or outside of the network?

Has the IP address of the server changed at all?

Have you tried turning off the option for remote desktop then re-enabling it?
0
 
Axis52401Security AnalystCommented:
What is the output of the ipconfing /all? does it show the correct ip address?
did windows firewall get turned on after uninstalling the a/v and blocking rdp?
is rdp using the default port of 3389?

You mentioned a crash so have you tried 'sfc /scannow' ? This will check to make sure all the sytem files are there.
0
 
Hello WorldCommented:
Hi,

This issue may be related to setting of remote desktop, for example permission, policy.
More details about Remote Desktop disconnected or can’t connect to remote computer or to Remote Desktop server, for your reference:
http://support.microsoft.com/kb/2477176/
0
 
Erlend AuslandAuthor Commented:
@Praveen Kumar Bonala:
Yes, I was able to ping the server both with IP and with hostname. Remote desktop was enabled. Firewall and a/v was disabled for testing.

@Chris Millard:
I was having problem with RDP from inside the network. The IP address was never changed. I did try re-enabling remote desktop.

@Axis52401:
The output of ipconfig /all was all correct. I did check firewall and a/v and even disabled both for testing purposes. I did do
an sfc /scannow based on your comment, but everything was fine.

@Ya Li:
I did already skim through that article (although the one for Server 2003 R2, not 2008 R2) - but after your posting I
went through it again and actually did figure it out based on the article! I have therefor accepted your post as the solution.

What I actually did to solve it was going into the Terminal Service Configuration under the Administrative Tools and went to the properities for the RDP-Tcp connection. Right of the bat it gave me a warning about disabled connections due to changes in the Network Adapter settings. The selected adapter under the Network Adapter was whiped out, as I mention in my original post i had actually reinstalled the ethernet drivers during a crash. I selected the appropriate adapter and everything works again!

Thanks everyone for your help!

Here is the link to the correct article for 2003 R2:
https://support.microsoft.com/kb/2477023
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now