• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 167
  • Last Modified:

database split cannot change table

I have just split my database and now I need to change a table field and I am always getting a set of errors:

ss1
this happens as I try to directly open the backend. When I normally open and try to change, then I am getting:

ss2

can anyone help?
0
João serras-pereira
Asked:
João serras-pereira
  • 6
  • 4
2 Solutions
 
PatHartmanCommented:
Try adding a trusted location.

File/options/Trust settings -- button/trusted locations
If this is a network location, check the allow trusted locations on network button.
Use the add button to navigate to the location.  Check the button to trust subfolders.

Do this for both the FE location (which should be on your local PC) and the BE (which should be on a network drive)
0
 
João serras-pereiraAuthor Commented:
almost there (I hope)

Please check the below screenshot (the Back End was accepted...)

Screen-Shot-2015-02-08-at-20.32.58.png
How do I change the security to allow it on my computer?
0
 
João serras-pereiraAuthor Commented:
I overcame the other problem by allowing "network drives. But the problem remains..... exactly the same errors :(
0
Easily Design & Build Your Next Website

Squarespace’s all-in-one platform gives you everything you need to express yourself creatively online, whether it is with a domain, website, or online store. Get started with your free trial today, and when ready, take 10% off your first purchase with offer code 'EXPERTS'.

 
PatHartmanCommented:
Is your file extension actually ".accdc"?  I would expect it to be .accdb, or possibly .accde or .accdr
The first error message is not coming from Access.  It is coming from windows.  You probably need to call your network admin to change your security settings.
0
 
João serras-pereiraAuthor Commented:
Please check below the screenshot for the folder where the back end is:

Screen-Shot-2015-02-08-at-22.03.14.png

The problem is that this is a single machine ( a Mac using parallels and I am the "network" administrator!). I do not know how to change the settings of the "network". Shall I put another question? Also, I see that ms/access, when splitting, automatically generates a protected package,  (you can see on the screenshot. Maybe this IS the problem and I need to change the way (or properties) of the split...
0
 
PatHartmanCommented:
Splitting the database doesn't generate an .accdc.

You chose the package and sign option.  You might just try using the .accdb instead.
0
 
João serras-pereiraAuthor Commented:
I was not aware of that...

but as I tried to split again from my backup database, I have noticed that there is a file type on the browsing menu. But it allows only for .accdc. So something must be wrong in my settings. How do I change it?.

The screenshot below shows the issue:

ss1
0
 
João serras-pereiraAuthor Commented:
Thnaks. I have got a workaround by changing the extension to .accdb and relinking the tabls to it
0
 
PatHartmanCommented:
That is really strange.  I have the same result.  I guess it's been a long time since I've had to split a db.    What version of Access are you using?

Renaming to .accdb after the fact solves the problem.
0
 
João serras-pereiraAuthor Commented:
I am using ms/access 2013. My problem is all the hassle that this new approach to security has. If I wanted to go that way I would use other database and not ms/access. I could go to SQL/Server for back end and a full development platform such as Visual Studio.
But this is a simple application for 3 - 4 users over a LAN or, at most, over a VPN... Anyway thanks for the help!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get 10% Off Your First Squarespace Website

Ready to showcase your work, publish content or promote your business online? With Squarespace’s award-winning templates and 24/7 customer service, getting started is simple. Head to Squarespace.com and use offer code ‘EXPERTS’ to get 10% off your first purchase.

  • 6
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now