Solved

Expression Engine Carthrob

Posted on 2015-02-08
3
73 Views
Last Modified: 2015-03-03
I have a site built on Expression Engine and have cartthrob Subscriptions.  I have added a price modifier but when I add to cart the price of the price modifier is not added to the subtotal.  Any Ideas?

{exp:channel:entries channel="subscriptions"}	
									{!-- specify the plan id to add the item to the cart --}
									{exp:cartthrob:add_to_cart_form 
										return="{local_template_group}/view_cart"
										subscription_plan_id="1"
										entry_id="{entry_id}"
										title="spoke insuracne"
										form_class="form-horizontal"
										no_tax="yes"
										no_shipping = "yes"
										allow_user_price="yes"
									}
									
									<input type="text" name="price"/>
										
									<br />
									
									    {exp:cartthrob:item_options entry_id="{entry_id}"}
							
									
										{first_name}
										{if first_row}
										<select name="item_options[first_name]">
										{/if}
												 <option {selected} value="{option_value}">{option_name} {if option_price_numeric >= 0} $ {price}{/if}</option>
										{if last_row}
										</select>
										{/if}
										{/first_name}
								
								
									 {/exp:cartthrob:item_options}	
										
									<div class="control-group">
										<div class="form-actions">
											<button type="submit" class="btn btn-primary"><i class="icon-ok-circle icon-white"></i>Add plan</button>
										</div>
									</div>

									{/exp:cartthrob:add_to_cart_form}
								
{/exp:channel:entries}

Open in new window

0
Comment
Question by:rgranlund
3 Comments
 
LVL 35

Accepted Solution

by:
Terry Woods earned 500 total points
ID: 40597756
Have you included a $ character in your modifier value? Doing a web search for this issue, it looks like it shouldn't have one. Note that I haven't used Expression Engine though.
0
 
LVL 7

Author Comment

by:rgranlund
ID: 40598810
Yes, Please add the topics.  Also, I made sure about the $sign.  I have done about 8 hours of research before I even posted here.  It must something in the way I have my channels set up or something stupid.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Things That Drive Us Nuts Have you noticed the use of the reCaptcha feature at EE and other web sites?  It wants you to read and retype something that looks like this.Insanity!  It's not EE's fault - that's just the way reCaptcha works.  But it is …
Learn about the eCommerce marketing trends for the year ahead.
The viewer will learn how to dynamically set the form action using jQuery.
You have products, that come in variants and want to set different prices for them? Watch this micro tutorial that describes how to configure prices for Magento super attributes. Assigning simple products to configurable: We assigned simple products…

910 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now