Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 205
  • Last Modified:

MS SQL can't connect

HI,

I had a server crash, and am trying to restore a classic ASP web application using an MS SQL 2008 Express database instance.

I successfully have the data tables and all intact records recovered in a new PC, with a new MS SQL installation.

The problem is, my connection file in the ASP application can no longer connect. On my login page I get:

Microsoft OLE DB Provider for SQL Server error '80004005'

[DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied.

/Connections/mande2.asp, line 20

My current connect string is:

MM_mande_STRING="Provider=SQLOLEDB;Data Source=localhost;UID=username; PWD=mypassword; database=database_name;"

Open in new window


I have a few questions, assuming that I've set up the correct user, assigned that user owner permissions on the restored database, and the user part of this is correct:

1. How do I tell if my MS SQL Server instance is "serving" to the outside world?

2. If I change the data source info from "localhost" to my actual server name and MS SQL instance "SERVER\SQLEXPRESS" the behavior changes. Instead of the error message, the page just loads forever when accessing the database from an ASP page on the site. Is this a clue of some kind? If I name this anything else (localhost, dilbert, etc) I get the error message from above.

3. Any other suggestions for checking the functionality of my new database instance and getting it reconnected?

Thank you

Bill
0
billium99
Asked:
billium99
  • 2
1 Solution
 
Shane KahkolaDirector of I.T.Commented:
Question 1:  Determining if your db server is listening to the outside world:

1.

Go to the Windows menu --> Microsoft Sql Server 2008 --> Configuration Tools --> Sql Server Configuration Manager

2.

Drill down on Sql Server Network Configuration --> Protocols for <your instance here>

3.

Double-click on TCP/IP in the right-hand pane

4.

Make sure enabled is set to "Yes"

5.

Click on the "IP Addresses" tab and find the IP address of the server in the list

6.

Make note of the TCP Port being used (default is 1433). If it's not the default, your connection string needs to reflect that by using a :#### after the server name in the string (#### = the TCP port)

7.

Make sure the Windows firewall is permitting the specified TCP port inbound

8.

Make sure your internet firewall is permitting the specified TCP port inbound for only the IP address of your web serverQuestion 2:  Response as a clue
Yes, that is a big clue.  If your web application is not on the same server as your SQL database, then localhost will not work.  If indeed they are separate, then you have to specify the actual server name or IP address of the SQL server.

As for the long-running of the page, is it possible you have a long-running query?  Are you doing any error trapping for SqlExceptions?  What version of ASP?

Question 3:  Additional suggestions
Try opening the SQL management studio using the same username and password you specified in your string.  See if that gives you a better error message.
0
 
billium99Author Commented:
Thanks for your time. The SQLEXPRESS was the correct name. I was having unrelated SSL certificate issues causing the rest of that delay.
0
 
Shane KahkolaDirector of I.T.Commented:
Just glad you were able to get it resolved.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now