Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Configuring Exchange in SBS 2003

Posted on 2015-02-08
5
Medium Priority
?
155 Views
Last Modified: 2015-02-10
I have a client with SBS 2003 that someone else installed years ago.  I have been supporting the system for a few years now and am interested in starting to use Exchange.  It was never used before so I can't assume much about how it was configured.

The general system is pretty straightforward.  SBS 2003 is the only server, email is hosted by an external provider, POP3 connector is being used (for now) to retrieve email, the external provider is being used for sending mail.

I am able to connect and test with OWA, but am not successful at getting mail to appear.  For example, I can open OWA for the user "Fred" and have Fred send an email to himself.  The message shows up in Sent Items but never appears in the Inbox.

There are two different domains to consider here.  I will call the local domain abc.local.  I will call the internet domain (used by their email) def.com.  I have had Fred send mail to both addresses and neither arrives.  I see this problem both with brand new users as well as ones that were created long ago.

In Fred's account properties, under E-mail Addresses, I have tried having both Fred@abc.local and Fred@def.com listed as SMTP addresses, alternating which is the default, and also just having one or the other.  The results are the same.  Under Exchange Features, everything (Outlook Mobile Access, User Initiated Synch, Up-to-date Notifications, OWA, POP3, and IMAP4) is enabled.

I have looked at the various properties in Exchange Manager and they appear to be consistent with a working test SBS 2003 system that I created.  I've not checked every single setting so if there is something here I might have overlooked, a comment about it would be appreciated.

I have run the latest SBS BPA and the only errors that I get are:
Free disk space is very low (1.4G on C:, 271G on D:)
NIC driver is more than one year old
Blue Shield - Update Services (I'm not using WSUS and am getting some errors there that I will resolve)
Sharepoint instance does not use SQL Server 2000 SP4 (SQL 2005 is running)

None of those appears to be something that would cause my Exchange problem.

If I send email to fred@def.con, the POP3 Connector appears to handle it correctly.  I get messages in the Event Log of the following sort:
There are 1 message(s) with a total of 4549 byte(s) for mailbox <mail.def.com(fred@def.com)>
The message <id:{bunch of numbers}> was downloaded from the POP3 server (mailbox <fred@def.com[mail.def.com]>).
The message....... was deleted from the POP3 server.....
The message <same id as above> was routed to <Fred@def.com> by an individual mailbox mapping.

That looks to me as if the message was received and delivered, but it doesn't show up.

I am assuming that this is just some basic configuration issue that I've overlooked.

Any suggestions about where to look would be appreciated.  I have access to the server remotely so I can provide any additional information that may be useful.
0
Comment
Question by:CompProbSolv
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
5 Comments
 
LVL 35

Expert Comment

by:Cris Hanna
ID: 40598009
The only recommendation I can give you that makes any sense, is to abandon your current plan.   Exchange 2003 has been out of support by Microsoft for more than a year and Server 2003 support ends in about 5 months (July of 2015)

The other issue you have is the amount of free space on the C: drive.  While there are articles available on cleaning this up...I have real concerns about how long you can keep it in that condition very long

So, as their trusted IT advisor, you should be working on a plan to get them off SBS 2003 all together.  And on to new hardware with a new operating system.   If you're under 25 users, Server 2012R2 Essentials as SKU would good point.  If they are over 25 users, you could move them to Server 2012R Standard and then install the Essentials role.   Email should either be left on the POP3 server or they should consider moving to Office 365.
0
 
LVL 22

Author Comment

by:CompProbSolv
ID: 40599045
There is a plan to move away from SBS 2003 later this year.  It is an accounting firm and nothing will be done to replace the server until after April.
In any case, Exchange should be able to function properly, with or without it being in support by Microsoft.
0
 
LVL 27

Accepted Solution

by:
davorin earned 2000 total points
ID: 40599607
Have you run internet and email configuration wizard to specify external accepted domain and all other needed settings?
Are exchange services running? Are missed mails in the mail queue? Any errors in the event viewer?

In the end I must agree with Cris. If you have waited for so long time, wait for a couple of months more and start using newer version of Exchange. You will have a lot of extra work, when you will try to migrate to newest version of Exchange server 2013. It can not be done directly, but you will first need to migrate to Exchange 2010 and then to Exchange 2013. Outlook 2013 does not support Exchange 2003, ...
Is any particular reason why the migration must be done now and can not be postponed?
0
 
LVL 22

Author Comment

by:CompProbSolv
ID: 40600183
I did run the Internet and Email config wizard with no significant change.  I will try it again in case I missed something.
All Exchange services are running except for Microsoft Exchange Event and Microsoft Exchange Site Replication Service.  I tried starting those and used OWA to have a user send an email to herself and the result was the same.  The email shows up as Sent Mail but never arrives in the Inbox.

The queue has what I think is significant information.  It shows 5 messages (recent tests that I have sent) as "Messages awaiting directory lookup".  I increased logging level for the Transport and now get an Event 9035 that starts with: "categorization of the message failed with a retryable error".  I will look further into this.

The intent was to use OWA as the standard email client.  Users frequently change which computer they use and also retrieve email for other users when they are out.  Exchange and OWA seemed like a good solution to this situation.  It is an accounting firm so communication is rather critical for the next couple of months.
0
 
LVL 22

Author Comment

by:CompProbSolv
ID: 40600193
Got it!
The system was set to do journaling, but was pointing to an obsolete user.  I unchecked "Archive all messages....." and I can now send local email.

It seems odd that this would stop the mail from being sent at all.

Nevertheless, thank you for the assistance!
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This guide is intended to provide step by step instructions on how to migrate from Small Business Server 2003 to Small Business Server 2011. NOTE: This guide has been written using the preview version of SBS2011 therefore some of the screens may …
The articles for turning off the Client firewall policy on the internet are for SBS 2008 and don't really help for SBS 2011. They actually moved the Client firewall policy. In 2011, the client firewall policy has moved to the SBS computers conta…
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…
Want to learn how to record your desktop screen without having to use an outside camera. Click on this video and learn how to use the cool google extension called "Screencastify"! Step 1: Open a new google tab Step 2: Go to the left hand upper corn…
Suggested Courses

610 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question