Win 7 Desktop became bluish (not BSoD) when mouse is released (& possibly Ctrl key pressed)

Quite often after moving the mouse & my right hand let go of the mouse (& possibly I may
have pressed Ctrl key), the Desktop will become bluish as shown in attached.

I'm not exactly sure what I pressed (as I can't consistently reproduce this) that bring up
this disruptive bluish desktop.  To recover from it, I just move the mouse & click on the
Desktop & it will recover.

Not sure if it's related but currently when I pressed the fullstop ie the . key which is also
the key/button with > on it), it will often activate a key below it: it's the key between the
right Alt & right Ctrl keys on my Thinkpad X220 keypad) & this will bring up a little menu:
refer to attachment 2's screen (in a browser, while typing the . key, it will pop up a menu
with Undo, Redo, ...).   Our laptop support guys gave me a USB keyboard to use & it seems
to help so far while reinstalling the entire Windows 7 did not help so we're inclined to
believe it's a keypad hardware issue as the . key was just right above that key (I can take a
 photo of that key if needed; I dont know what's that key called).

Let's resolve the disruptive bluish screen first as our IT guys are going to order a spare
keypad for my X220 later.

This very same Logitech Darkfield Anywhere mouse did not trigger this bluish desktop
 issue when used on another Windows 7 PC
BluescrDesktop-Mousemove.jpg
keypadissue1.jpg
sunhuxAsked:
Who is Participating?
 
VB ITSConnect With a Mentor Specialist ConsultantCommented:
The blue-ish Desktop you see is the Aero Peek feature in Windows 7. You can trigger Aero Peek by either moving your mouse to the bottom right hand corner of your screen and hovering it over the Show Desktop button or by pressing the Windows + Space keys on your keyboard simultaneously.
Aero-Peek.pngYou can disable Aero Peek if you want but what I think is happening here is that you've moved the cursor to the bottom right corner of your screen when you let go of the mouse or your mouse cursor is drifting somehow to the bottom right corner of your screen by itself. If you look at your BluescrDesktop-Mousemove.jpg screenshot you can see the words Show Desktop on the bottom right corner which is where your mouse needs to be to activate Aero Peek.

If you would like to disable Aero Peek then you can do so through the steps in this article: http://www.howtogeek.com/howto/5473/make-aero-peek-display-instantly-or-disable-it-in-windows-7/

As for your second issue, I think I know what the key between your Alt + Ctrl keys does - I believe it brings up the context menu you would normally see when you right click on a page. If this key is being triggered by the full stop key above it then it definitely sounds like you have a faulty keyboard. Use the external USB keyboard until you get your laptop keyboard replaced.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.