How to configure Gridview control so that the Header text are not connect and have certain padding between them

Hi, I'm using VS2012
My gridview would have a couple of header text connected.  How to ensure all header text have some padding between them.  
Also, in the Edit mode, each column seemed to expanded way too wide.  How to limit that to be the same width as in the non-editing mode?

Thank you.
Who is Participating?
Bob LearnedConnect With a Mentor Commented:
I would think that CSS applied to the Grid might have more fine-grain control over the appearance.

GridView custom CSS style example in ASP.NET

<%@ Page Language="C#" AutoEventWireup="true" CodeFile="Default.aspx.cs" Inherits="_Default" %> 
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "">
<html xmlns="">
<head runat="server">
    <link href="Gridstyle.css" rel="stylesheet" type="text/css" />
    <title>GridView Style</title>
    <form id="form1" runat="server">
        <asp:GridView ID="gvEmployee" runat="server" AutoGenerateColumns="false" Width="600px"
                      AllowPaging="true" PageSize="8" OnPageIndexChanging="gvEmployee_PageIndexChanging"
                      PagerStyle-CssClass="pgr" >        
         <asp:BoundField DataField="empid" HeaderText="Employee ID" />
         <asp:BoundField DataField="name" HeaderText="Name" />
         <asp:BoundField DataField="designation" HeaderText="Designation" />
         <asp:BoundField DataField="city" HeaderText="City" />
         <asp:BoundField DataField="country" HeaderText="Country" />        

Open in new window

.Grid {background-color: #fff; margin: 5px 0 10px 0; border: solid 1px #525252; border-collapse:collapse; font-family:Calibri; color: #474747;}
.Grid td {
      padding: 2px;
      border: solid 1px #c1c1c1; }
.Grid th  {
      padding : 4px 2px;
      color: #fff;
      background: #363670 url(Images/grid-header.png) repeat-x top;
      border-left: solid 1px #525252;
      font-size: 0.9em; }
.Grid .alt {
      background: #fcfcfc url(Images/grid-alt.png) repeat-x top; }
.Grid .pgr {background: #363670 url(Images/grid-pgr.png) repeat-x top; }
.Grid .pgr table { margin: 3px 0; }
.Grid .pgr td { border-width: 0; padding: 0 6px; border-left: solid 1px #666; font-weight: bold; color: #fff; line-height: 12px; }  
.Grid .pgr a { color: Gray; text-decoration: none; }
.Grid .pgr a:hover { color: #000; text-decoration: none; }
- See more at:
Scott McDaniel (Microsoft Access MVP - EE MVE )Infotrakker SoftwareCommented:
I'm not sure you have any control over the padding in the column headers. However, there are several design view options for AutoSizeColumnMode. Try changing those to see if those better suit you needs. Several of those settings will auto-size based on Header text.
lapuccaAuthor Commented:
I don't see where is this AutoSizeColumnMode property that I can set.  Can you give me steps on how to locate this?  What design view do you mean?  I check both in Source and Design of the aspx page but can't find this property.  Thank you.
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Bob LearnedCommented:
The ASP.NET GridView control has different style properties (ControlStyle, FooterStyle, HeaderStyle, ItemStyle).  There are a lot of examples of how to apply style.  You can mix styles with CSS styling to achieve the effect that you require.

GridView Examples for ASP.NET 2.0: Formatting the GridView

  <asp:GridView ID="productGridView" Runat="server" 
            DataKeyNames="ProductID" AutoGenerateColumns="False" 
             BorderWidth="1px" BackColor="#DEBA84" 
             CellPadding="3" CellSpacing="2" BorderStyle="None" 
            <FooterStyle ForeColor="#8C4510" 
            <PagerStyle ForeColor="#8C4510" 
            <HeaderStyle ForeColor="White" Font-Bold="True" 


Open in new window

lapuccaAuthor Commented:
I played with Gridview control's cellspacing and it didn't seem to make a bit of diffference.  I also played with in Edit Column (Design) of headerStyle and ItemStyle and it looks fine in the Gridview control's Design view but when the application running it's nothing like it!
I would set all column Headerstyle to be center Horizontally but at run time they all aligned to the left.  
Also, why is each column 2,3 times the width in Edit Mode than in display mode?  The gridview control would expand over to the <div> width that contains it.  How to fix this?  
Thank you.
Bob LearnedCommented:
Did you try setting the CellPadding property?

Can you show me how the style is applied for the GridView in the HTML?
lapuccaAuthor Commented:
I attached the grid's html code and the screen capture of what it looks like in VS Design view.  Thank you for the help.
lapuccaAuthor Commented:
I'm attaching the column headers in Normal mode and in Edit mode.  You see the columns suddenly expanded their width to more than double of their width in normal mode.  The right most column, half of it has grey background because in edit mode it leaks over the div that contains it so there is a horizontal scrolling bar to get to it.  Very frustrating!
lapuccaAuthor Commented:
I would like around 15 or 20 pixels between each column.  This should be the same in Edit or Normal mode.  
Also, any way to set the cell will grow, or is that the default, if the data has one that's is longer than others?

Thank you.
lapuccaAuthor Commented:
Bob, I played wiht the cellspacing settting it from 10 to 150 makes no difference in the spacing between the columns.  The cellPadding does make a difference but it also increase the Header row height and oddly enough not the cells below that row.  Anyway, cellspacing is not working and cellpadding is changing the height.   Also, in Edit it still grows ouside of the screen.
lapuccaAuthor Commented:
yes, agree.  Have to use CSS for this to work correctly.  Thank you.
Bob LearnedCommented:
P.S. I am stuck in the ASP.NET MVC 5 world so much that I had to think about this, but I always try to apply CSS for styles.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.