Expiring Today—Celebrate National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Exchange 2010 Shared Calendar Permission Error

Posted on 2015-02-09
8
Medium Priority
?
3,162 Views
Last Modified: 2015-04-10
My company has a few resource room mailboxes. They all have the same settings, full permission, and policies. The mailbox control the rooms that are used for meetings. They all have calendars that are shared so you can view when you can book the room or not. Recently I found out that some of the users are not able to view some calendars. They are getting a permission error. The error says "You don't have permission to view" and it will ask if you want to ask to view the calendar.

I'm not sure what can be the issue as all the settings, policies are the same. Everyone in the domain should be able to view the shared calendar but they are getting a permission issue.

I can't remove the calendar and mailbox as there are some appointments are already made and that would cause problems.

So far I have verify that the default sharing policy are all the same. My company has it set to *.CalendarSharingFreeBusySimple. The shared calendars that are working have the same policy.
When I grant myself full permission I am able to view it. The groups and users are the same for the calendar that are working.

This is all I can think of and list as of right now.

Does anyone have a clue or give any suggestion where to start to find the problem and fix it?
0
Comment
Question by:xouvang
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
8 Comments
 
LVL 5

Expert Comment

by:Dejan Vasiljevic
ID: 40599870
Hi xouvang,

Can You give us few more infos?
1st Which outlook are You using while You are trying to open/view calendar?
2nd Which error message are You getting? Like is it - "Could not read the Calendar. Network Problems are preventing connection to Microsoft Exchange"  or "Microsoft Outlook We can't complete this because we can't contact the server right now. Please try again later." so full error message. Because there are few different error messages when You dont have permission to calendar.

Thanks,
D.
0
 

Author Comment

by:xouvang
ID: 40600006
Thank you for your response.

I am using outlook 2007 and I have other users who uses outlook 2013.

The full error message is "You do not have permission to view this calendar. Do you want to ask <Name of Calendar Owner> to share his or her calendar with you?"

When a user clicks yes it sends an email to the mailbox but since the mail box is a resource mailbox the notification goes right into trash. When I give myself full access I can see the the email asking for notification. I can then approve it but that would mean someone is required to manage this mailbox.

I hope that helps.
0
 
LVL 24

Expert Comment

by:VB ITS
ID: 40600012
So far I have verify that the default sharing policy are all the same. My company has it set to *.CalendarSharingFreeBusySimple. The shared calendars that are working have the same policy.
You may have things a bit mixed up here. Sharing policies are designed to control how your users share their calendars with users outside of your Exchange organization. You don't use them to grant your users access to other calendars within the organization.

Please see this article if you need confirmation: https://technet.microsoft.com/en-us/library/dd351201(v=exchg.141).aspx

The easiest way to modify the permissions to your resource calendars is to grant yourself full access to the mailbox, open the calendar in Outlook, then change the permissions from there.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 

Author Comment

by:xouvang
ID: 40600020
Thank you, that is good to know.

VB ITS, I gave myself full access and verified the permissions were the same as the other working resource mailbox. Is there something else that I could be missing? I'm not at work now but I can get some settings screen shots of the working one and non working one.
0
 
LVL 24

Accepted Solution

by:
VB ITS earned 2000 total points
ID: 40600024
Can you please verify what those permissions are?

If you need all users to be able to open the calendar then you need to set the Default access level to at least Free/Busy Time.

- Right click on the resource calendar that you've added to Outlook then click on Properties...
- Click on the Permissions tab
- Verify that Default permission level is not set to None
Default-Calendar-Permissions.png
0
 

Author Comment

by:xouvang
ID: 40600160
I'm new to powershell as I'm just a junior system admin learning.
So running the powershell command Set-CalendarPermissions.ps1 will set the calendar permissions to default?

For example the resource mailbox is call confroomcwc

What would the command look like?

I will try what VB ITS suggest to see if that works, if it does not work I can try via powershell if you can provide me a powershell command.

Thanks!
0
 
LVL 24

Expert Comment

by:VB ITS
ID: 40600219
If you want to make permission changes through PowerShell then you can use the below commands.

Firstly check if the Default user currently has access to the confroomcwc resource mailbox:
Get-MailboxFolderPermission -Identity "confroomcwc:\Calendar" | fl

Open in new window

Look for User: Default in the output. This will dictate what command we need to use next to set the permissions.

If the Default user currently has access but AccessRights is been set to None then you'll need to use the Set-MailboxFolderPermission command to change this:
Set-MailboxFolderPermission -Identity "confroomcwc:\Calendar" -AccessRights AvailabilityOnly

Open in new window


If the Default user doesn't have access then you'll need to use the Add-MailboxFolderPermission command:
Add-MailboxFolderPermission -Identity "confroomcwc:\Calendar" -AccessRights AvailabilityOnly

Open in new window

0
 

Author Comment

by:xouvang
ID: 40601225
Thank you for your input.

I fixed it by looking at the calendar permission. It was set to none so I changed it to Reviewer and it work.
Thanks for teaching me some shell commands. I made note of it and made note that mailbox permission is different from calendar permissions.

Thanks again!
0

Featured Post

Veeam Task Manager for Hyper-V

Task Manager for Hyper-V provides critical information that allows you to monitor Hyper-V performance by displaying real-time views of CPU and memory at the individual VM-level, so you can quickly identify which VMs are using host resources.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Check out this step-by-step guide for using the newly updated Experts Exchange mobile app—released on May 30.
There are times when we need to generate a report on the inbox rules, where users have set up forwarding externally in their mailbox. In this article, I will be sharing a script I wrote to generate the report in CSV format.
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question