• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 101
  • Last Modified:

Problem to generate file

Hi,
I want to adjust this option - "Register for COM interop", to Visual studio project, but I don't know where to adjust the option below
https://dl.dropboxusercontent.com/u/40211031/t973.png

to the project?

I now cannot generate TLB file to this project
https://dl.dropboxusercontent.com/u/40211031/CSDemo%20150207.zip
0
HuaMin Chen
Asked:
HuaMin Chen
  • 5
  • 3
2 Solutions
 
it_saigeDeveloperCommented:
You have opened the solution properties -Capture.JPGNot the project properties -Capture.JPGWith the project properties open, select the 'Application' tab and press the 'Assembly Information...' button.Capture.JPG-saige-
0
 
HuaMin ChenSystem AnalystAuthor Commented:
Thanks.
I enable the Checkbox

Application\Assembly Information\Mark assembly COM-visible

and then re-generate the solution/project, but I still get no TLB file generated.
0
 
it_saigeDeveloperCommented:
Make sure that your project is a 'Library' type:Capture.JPGThen on the 'Compile' page, you will see an option for 'Register for COM interop':Capture.JPG-saige-
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

 
HuaMin ChenSystem AnalystAuthor Commented:
Thanks. I don't know why the option is disabled (see the attached). Can you please refer to the project (attached in above), if possible?
t982.png
0
 
it_saigeDeveloperCommented:
The option is disabled because you are not building a library.

-saige-
0
 
HuaMin ChenSystem AnalystAuthor Commented:
Previously, when re-building the solution, .TLB file would be generated. I don't know why now it would not. What is the reason to this? Thanks.
0
 
it_saigeDeveloperCommented:
HuaMin,

I downloaded your project and unzipped it.  I cannot replicate your issue.  All of the required options are selected for the CSDemo project and it does build the tlb file.Capture.JPG
Are you perhaps looking in the wrong folder?

-saige-
0
 
it_saigeDeveloperCommented:
I think I have identified your problem.  Did you recently change the configuration from 'Any CPU' to 'x86'?Capture.JPGIf so, the updated files are located in the x86\Debug folder -Capture.JPG
Proof of concept (results after changing the configuration to Any CPU and rebuilding):Capture.JPGCapture.JPG-saige-
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now