My Documents folder missing

Have set up folder redirection in Windows 2008 R2 standard. Everything maps ok, the only issue is that the my documents folder is not showing on the users desktop for whoever logs in. It shows through the start menu but not the desktop.

1) How this be rectified via GP ?
2) If not, is there a script that will create this for all users on the local PC for whoever logs in ?

Thanks
LVL 1
discoveranotherAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
VB ITSConnect With a Mentor Specialist ConsultantCommented:
In 2008 R2/7 there's no longer a native Documents icon. Instead it has been replaced with the User folder, which when double clicked will then show the Documents, Desktop, Downloads, etc. folders.

You can deploy this folder on the Desktop for all users using Group Policy Preferences.

- Open up the Group Policy Management Console on a DC running Windows Server 2008 and later
- Expand User ConfigurationPreferencesWindows SettingsRegistry
- Right click on Registry then click NewRegistry Item
- Use the below settings for the registry item:
Action: Replace
Hive: HKEY_CURRENT_USER
Key Path: Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\NewStartPanel
Value Name: {59031A47-3F72-44A7-89C5-5595FE6B30EE}
Value Type: REG_DWORD
Value Data: 00000000
- Click OK when done
0
 
rindiCommented:
"My Documents" is no longer a folder from Windows 2008/Vista upwards, but rather it is "\Users\UserName\Documents". So look for "Documents". The "My documents", if there, is only a junction point that points to the Documents folder so ancient software built for XP or even older finds the proper location, so it isn't really needed.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.