Windows Automatic Updates

Hey all.

So, I do have a GPO to automatically apply Windows updates from our WSUS and reboot if necessary at 3am.

I have seen in two occasions that while logged in, a server gives me the warning that it needs to reboot in order to finish applying updates and boom! It reboots out of the blue.

What setting am I missing?

Thank you!
IDMAAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
MaheshConnect With a Mentor ArchitectCommented:
Ensure that "No auto restart with logged on user for schedule automatic update installation" setting is enabled.

Also ensure that "always automatically restart at schedule time" setting is not configured.
0
 
rindiCommented:
In my point of view servers should never be automatically updated. You should always do that manually. Then you are there to recover from a problem should something unforeseen happen. Besides that, particularly last year m$ prematurely released several updates that were buggy and caused major issues. So if you wait 1 or 2 weeks after patch Tuesday, and then initiate the updates manually, chances are better that buggy updates have been removed.
0
 
IDMAAuthor Commented:
Thank you, Mahesh.  That was it.

Also, may I add.  I enabled and configured "Re-prompt for restart with scheduled installations"
The default for this setting is 10 minutes.  So, when users are logged in, the would have to manually select the maximum (4 hours) to avoid being logged out.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.