?
Solved

timeout error when running reports that are not on the server

Posted on 2015-02-11
3
Medium Priority
?
48 Views
Last Modified: 2015-07-10
I have SSRS reports that i deployed to the SSRS/SQL server.  I can view them in Report Manager and they come up VERY quickly.  However, when people try to connect to report manager from a different computer they get a timeout error.  Any reason why?
0
Comment
Question by:vbnetcoder
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 29

Accepted Solution

by:
sammySeltzer earned 2000 total points
ID: 40604828
Hi,

First, ask your users to fix their browsers.

They do so by going to:

Internet Options
Click on the Advanced tab
Scroll down to Browsing section. While on this section, look for Show friendly HTTP error messages
. Uncheck the box.

Apply
Close browse and ask them to try again.

This should review the actual problem they are running into.

Based on what the actual reason is or reasons are, try the following:

a.       Open the ReportServer’s Web.config file by going to Start -> Administrative Tools -> Internet Information Services.
 b.      From there, expand Web Sites -> Default Web Site, and click on ReportServer. On the right-hand pane, right-click ‘Web.Config’ and select ‘Open’.
 c.       Locate the HttpRuntime parameter. If it doesn’t exist, you will have to create it within the <System.Web> section.
 d.      Set the executionTimeout value to ‘10800’ (3 hours) as shown below:


<system.web>
 <httpRuntime executionTimeout = "10800" />
 </system.web>


2) Increase the script timeout on the report server

    1. Go onto your Reporting Server and open up Internet Information Services; right-click on the ReportServer and select Properties.
    2. Go to the Options tab, and set the ASP Script timeout to 300 seconds as shown below.

3) Set the report to never time out on the server

    1. Open your web browser on the server and go to http://localhost/Reports
    2. Navigate to the Report location and click on the problem report(s).
    3. On the left-hand pane, click on Properties.
    4. In the ‘Report Execution Timeout’ click the ‘Do not timeout report execution’.

For more, check out this link:

http://geekswithblogs.net/ssrs/archive/2009/10/30/steps-to-resolve-ssrs-timeout-issues.aspx
0
 

Author Comment

by:vbnetcoder
ID: 40612927
will get back to this
0
 

Author Closing Comment

by:vbnetcoder
ID: 40876302
ty
0

Featured Post

What Is Blockchain Technology?

Blockchain is a technology that underpins the success of Bitcoin and other digital currencies, but it has uses far beyond finance. Learn how blockchain works and why it is proving disruptive to other areas of IT.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hi, I have heard from my friends that it’s not possible to create Label Printing report using SSRS. I am amazed after hearing this words not possible in SSRS. I googled lot and found that it is possible to some of people know about the Report Bui…
This article explains how to reset the password of the sa account on a Microsoft SQL Server.  The steps in this article work in SQL 2005, 2008, 2008 R2, 2012, 2014 and 2016.
This tutorial will teach you the special effect of super speed similar to the fictional character Wally West aka "The Flash" After Shake : http://www.videocopilot.net/presets/after_shake/ All lightning effects with instructions : http://www.mediaf…
How to fix incompatible JVM issue while installing Eclipse While installing Eclipse in windows, got one error like above and unable to proceed with the installation. This video describes how to successfully install Eclipse. How to solve incompa…

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question