• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 578
  • Last Modified:

How To Run MS Excel 10 Macros On HP Stream 8 Tab

Hi Experts,

I had recently purchase HP Stream 8 Windows based tablet and installed MS Office 2010 which is successfully done. Now I have macro enabled files which I want to run on this tablet but buttons which are there in in .xlsm file is not working. Any idea how to do it?

Thanks
0
Naresh Patel
Asked:
Naresh Patel
  • 7
  • 3
  • 2
5 Solutions
 
Michael FowlerSolutions ConsultantCommented:
0
 
Michael FowlerSolutions ConsultantCommented:
I have had a look online and it appears that this tablet is not RT so I think the problem is that you are opening the file in Excel Online which does not support macros. You should be able to transfer the file to the tablet and open it locally to solve this issue

https://support.office.microsoft.com/en-us/article/Differences-between-using-a-workbook-in-the-browser-and-in-Excel-f0dc28ed-b85d-4e1d-be6d-5878005db3b6?CorrelationId=f4aabd34-b101-4ee9-9fe5-4a72438aa837&ui=en-US&rs=en-US&ad=US
0
 
Naresh PatelTraderAuthor Commented:
File is stored in my tablet ....not trying to open online. Macro have active X controls ....

Please guide me what to enable.

Thanks
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
Scott McDaniel (Microsoft Access MVP - EE MVE )Infotrakker SoftwareCommented:
I don't work on the mobile platform much, but in general you need to insure the file is in a Trusted Location. You can do that in several ways. If you have Excel installed on the table (which you obviously do), then you can use the Excel menus to do that. With the workbook open:

1. Click File
2. Click Trust Center
3. Click Trust Center Settings
4. Click Trusted Locations
5. Click Add New Location
6. Browse to the location where your workbook is stored on the tablet
7. If needed, check the "Subfolders of this location are also trusted"
8. Click OK
9. Close the Option menu
10. Close the Workbook

Now reopen the workbook and your macros should be enabled.
0
 
Naresh PatelTraderAuthor Commented:
Sorry for Delay,

I had did what you suggested but not go further.

Thanks
0
 
Scott McDaniel (Microsoft Access MVP - EE MVE )Infotrakker SoftwareCommented:
Do you mean that you added the location of the file on the Tablet to a Trusted Location, and that did not work?
0
 
Naresh PatelTraderAuthor Commented:
Yes not worked .....give me 30 min I will attching screen short ...

Thanks
0
 
Naresh PatelTraderAuthor Commented:
Excel ScreenTrusted LocationDirectory Path Thanks
0
 
Scott McDaniel (Microsoft Access MVP - EE MVE )Infotrakker SoftwareCommented:
Try creating a new workbook in the same location, and add a button to it. Does that button work?

If it does, then you may have issues with the workbook and may need to recreate it.
0
 
Naresh PatelTraderAuthor Commented:
Let me try....


Thanks
0
 
Naresh PatelTraderAuthor Commented:
yes I had run simple macro In new WB ...it is working.

Thanks
0
 
Naresh PatelTraderAuthor Commented:
Thank You
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 7
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now